Opened 15 years ago

Closed 14 years ago

#7949 closed defect (fixed)

Xorg fails with "Hi, my name is xorg / I am broken and looking for someone to fix me ..."

Reported by: nathan.stocks@… Owned by: macports-tickets@…
Priority: High Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…
Port:

Description

I ran 'sudo port -dv selfupdate' about 30 minutes before posting this bug. Then I tried to install xorg. It failed, so I ran 'sudo port clean --all xorg' and then tried again. No effect. The output is below:

$ sudo port -vd install xorg DEBUG: Found port in file:///opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/x11/xorg DEBUG: Changing to port directory: /opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/x11/xorg DEBUG: Requested variant powerpc is not provided by port xorg. DEBUG: Requested variant macosx is not provided by port xorg. DEBUG: Executing variant darwin provides darwin DEBUG: Executing com.apple.main (xorg) DEBUG: No TGZ archive: /opt/local/var/db/dports/packages/darwin/powerpc/xorg-X11R6.8.2_0.powerpc.tgz DEBUG: Skipping unarchive (xorg) since no archive found DEBUG: Skipping completed com.apple.unarchive (xorg) ---> Fetching xorg DEBUG: Executing proc-pre-com.apple.fetch-fetch-0 Hi, my name is xorg I am broken and looking for someone to fix me What can I say ?

Change History (1)

comment:1 Changed 14 years ago by markd@…

Cc: markd@… added
Resolution: fixed
Status: newclosed

The "I am broken message is informational" and not a bug; though the port's being broken is a bug, we've chosen to deal with it for now by telling people to use Apple's X11 so I've modified the message to tell people what to do if they encounter this message.

Note: See TracTickets for help on using tickets.