Opened 15 years ago

Closed 14 years ago

#7979 closed defect (fixed)

NTL does not build on MacOS X 10.4.5

Reported by: enrico.franchi@… Owned by: ralf@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: blb@…
Port:

Description

NTL does not build on MacOS X 10.4.5 Intel. The error is:

Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_math_ntl/work/ntl-5.4/src" && make all CC=/usr/bin/gcc-3.3 CPP=/usr/bin/cpp-3.3 CXX=/usr/bin/g++-3.3" returned error 2 Command output: make setup1 /usr/bin/gcc-3.3 -I../include -I. -O2 -c MakeDescAux.c gcc-3.3: installation problem, cannot exec `cc1': No such file or directory make[1]: * [setup1] Error 1 make: * [all] Error 2

However opening the portfile and removing the additional build args that require gcc-3.3 and g++ and cpp fixes this bug.

Attachments (3)

patch0 (370 bytes) - added by enrico.franchi@… 15 years ago.
This is a simple patch that seems to fix the build problem.
Portfile (1.7 KB) - added by ralf@… 15 years ago.
Updated Portfile for math/ntl (ntl-5.4)
Portfile.2 (1.8 KB) - added by ralf@… 15 years ago.
updated Portfile for math/ntl (ntl-5.4)

Download all attachments as: .zip

Change History (10)

Changed 15 years ago by enrico.franchi@…

Attachment: patch0 added

This is a simple patch that seems to fix the build problem.

comment:1 Changed 15 years ago by enrico.franchi@…

attachments.description: This is a simple patch that lets compile Portfile with your default compiler instead than forcing the 3.3 versionThis is a simple patch that seems to fix the build problem.

(From update of attachment 7294) However I don't know why 3.3 should be used. It thart was because 4.0 was bugged, this may not be the ideal solution

comment:2 Changed 15 years ago by blb@…

Owner: changed from darwinports-bugs@… to ralf@…

Assigning to maintainer.

Changed 15 years ago by ralf@…

Attachment: Portfile added

Updated Portfile for math/ntl (ntl-5.4)

comment:3 Changed 15 years ago by ralf@…

(From update of attachment 7327) Confirmed. The proper fix is to detect what version of gcc we're using and only resorting to gcc-3.3 if the default gcc is 4.0.0 (Apple Build 4061). The install DVD of OSX 10.4.4 shipped with the Intel Macs contains a gcc 4.0.1 that doesn't exhibit the compiler error experienced with gcc 4.0.0. On systems that were installed from a 10.4 DVD and subsequently upgraded to 10.4.x, gcc 4.0.0 still is the default gcc however. Attached Portfile should remedy the situation in all cases (except the one where we have a system with a gcc 4.0.0 that doesn't have a gcc-3.3 installed at all).

comment:4 Changed 15 years ago by ralf@…

Status: newassigned

comment:5 Changed 15 years ago by enrico.franchi@…

The patch does not work for me:

sudo port install ntl Error: Error executing darwin_8: can't read "gcc-suffix": no such variable Error: /opt/local/bin/port: Status 1 encountered during processing.

I think the reason is that gcc-suffix is set if and only if the output of gcc --version matches

if {[regexp "build 4061" $data]} {

set gcc-suffix "-3.3"

}

However on my Mac

$ gcc --version i686-apple-darwin8-gcc-4.0.1 (GCC) 4.0.1 (Apple Computer, Inc. build 5250) Copyright (C) 2005 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

I don't know TCL (so I don't know how to fix this): I suppose gcc-suffix should be set to "" in other cases. On MacIntel gcc standard is the 4.0.1.

Changed 15 years ago by ralf@…

Attachment: Portfile.2 added

updated Portfile for math/ntl (ntl-5.4)

comment:6 Changed 15 years ago by enrico.franchi@…

This time it worked perfectly to me. Have I to set the bug "fixed"? Don't know how's the protocol in this cases.

comment:7 Changed 14 years ago by ralf@…

Cc: blb@… added
Resolution: fixed
Status: assignedclosed

case closed. please check in patched Portfile from 2006-03-28 03:43 PDT (attachment ID 7355).

Note: See TracTickets for help on using tickets.