Opened 15 years ago

Closed 14 years ago

#8164 closed enhancement (invalid)

RFC: php5-5.1.2

Reported by: joe@… Owned by: opendarwin-2006@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: markd@…
Port:

Description

php5-5.1.2

I will attach the portfile to thie bug

Description:

For your consideration all,

I've attempted to enhance the portfile some, and the changes are pretty significant, so I thought I would put it out here for all to see and maybe make use of for the port? Please note, most of my testing has been with kitchen sink builds.

Things I have done and various comments:

  • many modules needing external dependancies have been broken off into variants - anything not needing a dependency has been turned on in the base build
  • many new variants have been added for all kinds of things not enabled yet
  • i --disable-all and explicitly turn things to keep the build predictable (less arg-delete this way)
  • i commented out the 'macos' variant, but you might not want that... it interferes with letting other darwinports provided libraries from being able to link in. (IE: getting unixodbc to link instead of iodbc) I assume this variant is automagically added? I'd propose a 'builtins' variant that the Portfile can use as a boolean to decide if we want linkage to /usr/lib or /opt/local ?
  • any particular database driver being activated will also result in the matching PDO support being activated as well if available

Notes / Remaining issues:

  • recode conflicts with mysql it seems. both use similarly named symbols that seem to colide on linkage
  • freetds doesn't quite yet work. i suspect php's configure just needs to add -ltds to the build, but i'm not sure the best angle on fixing that, and it's not important to me yet. :)
  • xml has been made an all or nothing thing, as theres a lot of interdependancies. i'm sure with some work they could be individually specified too (though, full builds already have a LOT of variants in ther list. :) )

Attachments (1)

Portfile (10.5 KB) - added by joe@… 15 years ago.
Ehancement to the php5 portfile

Download all attachments as: .zip

Change History (5)

Changed 15 years ago by joe@…

Attachment: Portfile added

Ehancement to the php5 portfile

comment:1 Changed 15 years ago by mww@…

the number of variants are kept to be as low as possible, not as high as possible. Also please submit DIFFs as attachements in the future so you can see the differences easily.

comment:2 Changed 15 years ago by joe@…

I will do my final submission as diff. Actually hold off on folding this in a bit, as I'm about to present something even better. Just polishing a few bits off. I was more after comments on the approach at this stage, as I've still been doing significant work to improve this port (allowing for a common build including multiple SAPIs)

The comment on the variants is noted, the problem is PHP has such a large number of possible permutations to it's build, and I know many will not want some of the more obscure functions, while others do. I was concerned about forcing too much on people.

Would it be safe for me to follow this guideline then? If it's something common, people expect to be around (IE: curl, ldap, etc), make it default, and leave only the obscure (or needed to be, like mysql, so versions can be changed) modules as variants?

I'll be posting the new and improved Portfile whole once more for comment before I try to submit for commit.

comment:3 Changed 15 years ago by opendarwin-2006@…

Owner: changed from darwinports-bugs@… to opendarwin-2006@…

comment:4 Changed 14 years ago by markd@…

Cc: markd@… added
Resolution: invalid
Status: newclosed

No response. Closing. Any new submissions should be on a new ticket against the current portfile version.

Note: See TracTickets for help on using tickets.