Opened 15 years ago

Closed 14 years ago

#8249 closed defect (invalid)

BUG: gnumeric 1.6.2 crashes with a bus error

Reported by: paulbeard@… Owned by: rhwood@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: gnome-darwinports@…
Port:

Description

paul$ gnumeric

(gnumeric:11043): GLib-GObject-WARNING : Two different plugins tried to register 'BasicEngineFc'.

(gnumeric:11043): GLib-GObject-CRITICAL : g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed Failed to load Pango module for id: 'BasicScriptEngineFc' (gnumeric:11043): GLib-GObject-WARNING : Two different plugins tried to register 'BasicEngineFc'.

(gnumeric:11043): GLib-GObject-CRITICAL : g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed Failed to load Pango module for id: 'BasicScriptEngineFc' (gnumeric:11043): GLib-GObject-WARNING : Two different plugins tried to register 'BasicEngineFc'.

(gnumeric:11043): GLib-GObject-CRITICAL : g_object_new: assertion `G_TYPE_IS_OBJECT (object_type)' failed Failed to load Pango module for id: 'BasicScriptEngineFc' (gnumeric:11043): GLib-CRITICAL : g_convert: assertion `str != NULL' failed

(gnumeric:11043): GLib-CRITICAL : g_convert: assertion `str != NULL' failed

(gnumeric:11043): GLib-CRITICAL : g_convert: assertion `str != NULL' failed

(gnumeric:11043): GLib-CRITICAL : g_convert: assertion `str != NULL' failed

(gnumeric:11043): GLib-CRITICAL : g_convert: assertion `str != NULL' failed

(gnumeric:11043): GLib-CRITICAL : g_convert: assertion `str != NULL' failed

(gnumeric:11043): GLib-CRITICAL : g_convert: assertion `str != NULL' failed

(gnumeric:11043): GLib-CRITICAL : g_convert: assertion `str != NULL' failed

Bus error

I reinstalled after cleaning, re-syncing, and found that scrollkeeper-update was failing to run. So I reinstalled scrollkeeper with its dependencies, no better.

This is my list of installed ports: The following ports are currently installed:

aalib @1.4rc5_2 (active) aspell @0.60.4_0 (active) aspell-dict-en @6.0_0 (active) atk @1.10.3_0 atk @1.11.4_0 (active) audiofile @0.2.6_0 (active) autoconf @2.59_0 (active) automake @1.9.6_0 (active) bison @2.1_0 (active) bittorrent @4.2.0_0 (active) bzip2 @1.0.3_0 (active) cairo @1.0.4_0 (active) cfengine @2.1.19p1_0 (active) cups-headers @1.1.15_0 (active) db4 @4.3.29_0+darwin_8 (active) docbook-xml-scrollkeeper @4.2_0 (active) docbook-xsl @1.69.1_0 (active) esound @0.2.36_0 (active) expat @2.0.0_1 (active) fontconfig @2.3.2_0 (active) fox @1.2.13_1 (active) freetype @2.1.10_1 (active) fribidi @0.10.7_0 (active) fugu @1.2.0_0 (active) gconf @2.14.0_0 (active) gettext @0.14.5_0 (active) gimp-print @4.2.7_0 (active) gimp2 @2.2.10_0 (active) glib1 @1.2.10_5 (active) glib2 @2.10.1_1 (active) gnome-icon-theme @2.12.1_0 (active) gnome-mime-data @2.4.2_0 (active) gnome-vfs @2.12.2_0 (active) gnumeric @1.6.2_0 (active) gnupg @1.4.2.2_0 (active) goffice @0.2.0_0 (active) gpgme @1.1.2_1 (active) gtk1 @1.2.10_6 (active) gtk2 @2.8.16_0+darwin_8 (active) hicolor-icon-theme @0.5_0 (active) intltool @0.34.2_0 (active) jpeg @6b_1 (active) lablgtk @1.2.7_0 (active) lame @3.97b2_0 (active) lcms @1.15_0 (active) libart_lgpl @2.3.17_0 (active) libbonobo @2.14.0_0 (active) libbonoboui @2.14.0_0 (active) libexif @0.6.12_0 (active) libglade2 @2.5.1_1 (active) libgnome @2.14.0_0 (active) libgnomecanvas @2.12.0_0 libgnomecanvas @2.14.0_0 (active) libgnomecups @0.2.2_0 (active) libgnomeprint @2.12.1_0 (active) libgnomeprintui @2.12.1_0 (active) libgpg-error @1.1_0 (active) libgsf @1.14.0_0 (active) libiconv @1.10_1+darwin_8 (active) libidl @0.8.6_0 (active) libmad @0.15.1b_0 (active) libmng @1.0.8_0 (active) libogg @1.1.3_0 (active) libpixman @0.1.6_0 (active) libpng @1.2.8_2+darwin_8 (active) libtool @1.5.20_0 (active) libvorbis @1.1.2_0 (active) libwmf @0.2.8.4_0 (active) libxml2 @2.6.22_0 (active) libxslt @1.1.15_0 (active) lzo @1.08_0 (active) mldonkey @2.7.3_0 (active) MPlayer @1.0pre7try2_0 (active) ocaml @3.09.1_0 (active) openssl @0.9.8a_0+darwin_8 (active) orbit2 @2.14.0_0 (active) p5-xml-parser @2.34_3 (active) pango @1.12.0_0 pango @1.12.0_1 (active) pcre @6.6_0 (active) perl5.8 @5.8.8_0+darwin_8 (active) pkgconfig @0.20_0 (active) popt @1.10.4_1 (active) popt @1.7_4 pth @2.0.6_0 (active) py-gobject @2.9.1_0 (active) py-gtk2 @2.8.4_0 (active) py-numeric @24.2_0+darwin_8+macosx (active) python24 @2.4.2_3+darwin_8+macosx (active) rb-acl @1.0.1_1 (active) rb-drb @2.0.4_1 (active) readline @5.0.005_0+darwin_8 (active) render @0.9_0 (active) rsync @2.6.7_1+darwin_8 (active) ruby @1.8.4_2 (active) scrollkeeper @0.3.14_0 (active) tidy @20051025_0+darwin_8 (active) tiff @3.8.0_0+darwin_8 (active) wget @1.10.2_0+darwin_8 (active) Xft2 @2.1.7_0 (active) xrender @0.9.0_0 (active) xtide @2.8.2_0 (active) zlib @1.2.3_0 (active)

This is on an iBook G4, running 10.4.6.

Darwin white.paulbeard.org 8.6.0 Darwin Kernel Version 8.6.0: Tue Mar 7 16:58:48 PST 2006; root:xnu-792.6.70.obj~1/RELEASE_PPC Power Macintosh powerpc

Attachments (1)

crash.log (1.2 KB) - added by paulbeard@… 14 years ago.
output from running a new version (updated/built today)

Download all attachments as: .zip

Change History (11)

comment:1 Changed 15 years ago by paulbeard@…

Version 1.6.2.

comment:2 Changed 15 years ago by paulbeard@…

Summary: gnumeric crashes with a bus errorgnumeric 1.6.2 crashes with a bus error

comment:3 Changed 15 years ago by rhwood@…

Owner: changed from darwinports-bugs@… to gnome-darwinports@…

comment:4 Changed 15 years ago by rhwood@…

Status: newassigned
Summary: gnumeric 1.6.2 crashes with a bus errorBUG: gnumeric 1.6.2 crashes with a bus error

comment:5 Changed 15 years ago by rhwood@…

Cc: gnome-darwinports@… removed

What language are you using and if you are not using english, have you tried using english? This looks like a translation problem, but I can't tell at the moment.

comment:6 Changed 15 years ago by paulbeard@…

(In reply to comment #2)

What language are you using and if you are not using english, have you tried using english? This looks like a translation problem, but I can't tell at the moment.

Um, I am using English. Do I need to specifically export a language variable?

comment:7 Changed 14 years ago by rhwood@…

Cc: gnome-darwinports@… added
Owner: changed from gnome-darwinports@… to rhwood@…
Status: assignednew

New version of gnumeric has been committed to CVS.

Please test.

comment:8 Changed 14 years ago by rhwood@…

Status: newassigned

Changed 14 years ago by paulbeard@…

Attachment: crash.log added

output from running a new version (updated/built today)

comment:9 Changed 14 years ago by rhwood@…

If you can, please use the bug-buddy tool to report this error to the Gnumeric maintainers.

If you are using the GNOME desktop environment in your X11 session, bug-buddy should automatically launch when gnumeric crashes.

comment:10 Changed 14 years ago by rhwood@…

Resolution: invalid
Status: assignedclosed

This version of gnumeric is no longer in the ports database. Please open a new ticket based on the current version of gnumeric if this issue still exists.

Note: See TracTickets for help on using tickets.