Opened 13 years ago

Closed 12 years ago

Last modified 10 years ago

#8599 closed defect (fixed)

php5 can't +fastcgi if you have +apache(2)

Reported by: wyuenho (Jimmy Yuen Ho Wong) Owned by: ryandesign (Ryan Schmidt)
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: bugzilla@…, ryandesign (Ryan Schmidt)
Port: php5

Description (last modified by ryandesign (Ryan Schmidt))

Error: Target com.apple.destroot returned: xinstall: Cannot stat: /opt/local/var/db/dports/build/_private_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_www_php5/work/php-5.1.2/sapi/cgi/php, No such file or directory
Warning: the following items did not execute (for php5): com.apple.activate com.apple.destroot com.apple.archive com.apple.install
Error: /opt/local/bin/port: Status 1 encountered during processing.

Attachments (2)

php5-Portfile-conflicts.diff (828 bytes) - added by opendarwin-2006@… 13 years ago.
Ensures that only one of apache, apache2 or fastcgi can be selected
php5-Portfile-fastcgi-anytime.diff (4.8 KB) - added by ryandesign (Ryan Schmidt) 12 years ago.
Allow +fastcgi and +apache(2) at the same time

Download all attachments as: .zip

Change History (14)

comment:1 Changed 13 years ago by wyuenho (Jimmy Yuen Ho Wong)

I was trying to install this variant: php5 +apache2+fastcgi+mysql5+postgresql My apache2 already has mod_fastcgi installed.

comment:2 Changed 13 years ago by opendarwin-2006@…

Owner: changed from darwinports-bugs@… to opendarwin-2006@…

Yes, unfortunately, apparently because of the intricacies of the PHP build process, you can have one of the apache, apache2 or fastcgi variants, but not a combination of them. The initial solution will be to mark these three variants as conflicting in the portfile. The better solution will be to allow simultaneous selection of both fastcgi and an Apache module, but I suspect this will require more work.

comment:3 Changed 13 years ago by opendarwin-2006@…

Status: newassigned
Summary: php5 fastcgi variant fails to destrootphp5 can't +fastcgi if you have +apache(2)

comment:4 Changed 13 years ago by opendarwin-2006@…

Cc: bugzilla@… added

* Bug 9449 has been marked as a duplicate of this bug. *

comment:5 Changed 13 years ago by opendarwin-2006@…

+apache installs the Apache module. +apache2 installs the Apache 2 module. +fastcgi installs the fastcgi binary for use with any FastCGI-supporting web server, e.g. Apache, Apache 2, lighttpd, etc.

If you're trying to use FastCGI with Apache(2), and don't require the Apache module, then you don't need the +apache(2) variants. You will probably need to configure your httpd.conf yourself though.

The only time you would need both +apache(2) and +fastcgi is if you want to use the Apache modules with Apache, and also the FastCGI interface with, say, lighttpd at the same time.

Changed 13 years ago by opendarwin-2006@…

Ensures that only one of apache, apache2 or fastcgi can be selected

comment:6 Changed 13 years ago by jyrkiwahlstedt

Resolution: fixed
Status: assignedclosed

committed, thanks!

comment:7 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: closedreopened

comment:8 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: ryandesign@… added
Milestone: Port Bugs
Owner: changed from opendarwin-2006@… to ryandesign@…
severity: majorSerious
Status: reopenednew

Changed 12 years ago by ryandesign (Ryan Schmidt)

Allow +fastcgi and +apache(2) at the same time

comment:9 Changed 12 years ago by ryandesign (Ryan Schmidt)

Patch attached to allow +fastcgi even when already using +apache or +apache2. Problem is it only works with MP 1.4.0, not trunk. Read the comments in the patch and you can make it work with MP trunk, but not 1.4.0. Need a way to make it work with both before committing...

comment:10 Changed 12 years ago by ryandesign (Ryan Schmidt)

Resolution: fixed
Status: newclosed

The current version, MacPorts 1.4.40, supports the same command execution method as trunk, so now I can commit this in r25226.

The strategy I'm using here is apparently ill-advised because I'm using an internal MacPorts API that may change in the future. Well, if it does, I can update the port again. The alternative to using the internal API appears to be copying most of that API into the portfile itself, which is not very appealing to me.

comment:11 Changed 10 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: php5 added

comment:12 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.