Opened 15 years ago

Closed 15 years ago

#8973 closed defect (fixed)

BUG: gimp2-2.2.11 cannot install

Reported by: lschiere@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: joe_merchant@…, markd@…
Port:

Description

Using gcc 4.0.1, gimp2 cannot install.

pomme:~ lukeschierer$ sudo port install gimp2 Password: ---> Configuring gimp2 Error: Target com.apple.configure returned: configure failure: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_graphics_gimp2/work/gimp-2.2.11" && LDFLAGS=-L/opt/local/lib CPPFLAGS=-I/opt/local/include ./configure --prefix=/opt/local --enable-mp --mandir=/opt/local/share/man" returned error 1 Command output: checking libintl.h presence... yes checking for libintl.h... yes checking for ngettext in libc... no checking for bindtextdomain in -lintl... yes checking for ngettext in -lintl... yes checking for dgettext in -lintl... yes checking for bind_textdomain_codeset... yes checking for msgfmt... /opt/local/bin/msgfmt checking for dcgettext... yes checking for gmsgfmt... /opt/local/bin/msgfmt checking for xgettext... /opt/local/bin/xgettext checking for catalogs to be installed... bg ca cs da de el en_CA en_GB es eu fi fr ga gl he hu hr id it ja ko lt mk ms nb nl no pa pl pt pt_BR ro ru sk sr sr@Latn sv tr uk vi yi zh_CN zh_TW checking for pkg-config... /opt/local/bin/pkg-config checking for GLIB - version >= 2.4.5... yes (version 2.10.2) checking pkg-config is at least version 0.9.0... yes checking for GMODULE... yes checking if GLib is version 2.7.0 or newer... yes checking for bind_textdomain_codeset... (cached) yes checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include checking for gethostbyname... yes checking for connect... yes checking for remove... yes checking for shmat... yes checking for IceConnectionNumber in -lICE... yes checking for pkg-config... (cached) /opt/local/bin/pkg-config checking for GTK+ - version >= 2.4.4... no * Could not run GTK+ test program, checking why... * The test program failed to compile or link. See the file config.log for the * exact error that occured. This usually means GTK+ is incorrectly installed. configure: error: Test for GTK+ failed. See the file 'INSTALL' for help.

Error: /opt/local/bin/port: Status 1 encountered during processing. pomme:~ lukeschierer$ sudo port install gtk2 ---> Installing gtk2 2.8.17_0+darwin_8 Error: Target com.apple.install returned: Registry error: gtk2 2.8.17_0+darwin_8 already registered as installed. Please uninstall it first. Error: /opt/local/bin/port: Status 1 encountered during processing. pomme:~ lukeschierer$

Change History (5)

comment:1 Changed 15 years ago by lschiere@…

Since submitting this, the error has changed:

gcc -g -O2 -Wall -o .libs/png png.o -L/opt/local/lib ../../libgimp/.libs/libgim pui-2.0.dylib /opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rs ync.rsync.darwinports.org_dpupdate_dports_graphics_gimp2/work/gimp-2.2.11/libgim p/.libs/libgimp-2.0.dylib /opt/local/var/db/dports/build/_opt_local_var_db_dport s_sources_rsync.rsync.darwinports.org_dpupdate_dports_graphics_gimp2/work/gimp-2 .2.11/libgimpwidgets/.libs/libgimpwidgets-2.0.dylib -L/usr/X11R6/lib /opt/local/ var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org _dpupdate_dports_graphics_gimp2/work/gimp-2.2.11/libgimpmodule/.libs/libgimpmodu le-2.0.dylib ../../libgimpwidgets/.libs/libgimpwidgets-2.0.dylib ../../libgimp/. libs/libgimp-2.0.dylib /opt/local/var/db/dports/build/_opt_local_var_db_dports_s ources_rsync.rsync.darwinports.org_dpupdate_dports_graphics_gimp2/work/gimp-2.2. 11/libgimpcolor/.libs/libgimpcolor-2.0.dylib /opt/local/var/db/dports/build/_opt _local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_graphic s_gimp2/work/gimp-2.2.11/libgimpbase/.libs/libgimpbase-2.0.dylib ../../libgimpco lor/.libs/libgimpcolor-2.0.dylib ../../libgimpbase/.libs/libgimpbase-2.0.dylib / opt/local/lib/libgtk-x11-2.0.dylib /opt/local/lib/libgdk-x11-2.0.dylib /opt/loca l/lib/libatk-1.0.dylib /opt/local/lib/libgdk_pixbuf-2.0.dylib /opt/local/lib/lib tiff.dylib /opt/local/lib/libjpeg.dylib /opt/local/lib/libpangocairo-1.0.dylib / opt/local/lib/libpangoft2-1.0.dylib /opt/local/lib/libpango-1.0.dylib -lm /opt/l ocal/lib/libcairo.dylib /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libgm odule-2.0.dylib /opt/local/lib/libglib-2.0.dylib /opt/local/lib/libfontconfig.dy lib /opt/local/lib/libfreetype.dylib /opt/local/lib/libexpat.dylib /opt/local/li b/libXrender.dylib -lX11 /opt/local/lib/libpng12.dylib -lz /opt/local/lib/libint l.dylib /opt/local/lib/libiconv.dylib -lc /usr/bin/ld: warning prebinding disabled because dependent library: /opt/local/l ib/libgimpui-2.0.0.dylib is not prebound /usr/bin/ld: Undefined symbols: _png_read_destroy _png_write_destroy collect2: ld returned 1 exit status make[3]: * [png] Error 1 make[2]: * [all-recursive] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Error: /opt/local/bin/port: Status 1 encountered during processing. pomme:~ lukeschierer$

comment:2 Changed 15 years ago by mstepnicki@…

I can't get it to work either, but my error is different:

# port install gimp2 ---> Verifying checksum(s) for atk Error: Target com.apple.checksum returned: Could not open file: /opt/local/var/db/dports/distfiles/atk/atk-1.11.4.tar.bz2 Error: The following dependencies failed to build: gtk2 atk cairo fontconfig expat freetype libpixman libpng render xrender pango Xft2 tiff jpeg lcms libart_lgpl libexif libmng libwmf p5-xml-parser perl5.8 Error: /opt/local/bin/port: Status 1 encountered during processing.

I can install other programs, though.

comment:3 Changed 15 years ago by joe_merchant@…

Cc: joe_merchant@… added

Similar problem, different symptoms:

mike-inmans-computer:~ minman$ sudo port install gimp2 ---> Fetching aalib ---> Attempting to fetch aalib-1.4rc5.tar.gz from ftp://ftp.FreeBSD.org/pub/FreeBSD/ports/distfiles/ ---> Verifying checksum(s) for aalib ---> Extracting aalib ---> Applying patches to aalib ---> Configuring aalib ---> Building aalib with target all ---> Staging aalib into destroot ---> Packaging tgz archive for aalib 1.4rc5_2 ---> Installing aalib 1.4rc5_2 ---> Activating aalib 1.4rc5_2 ---> Cleaning aalib ---> Fetching gimp-print ---> Attempting to fetch gimp-print-4.2.7.tar.gz from http://puzzle.dl.sourceforge.net/gimp-print ---> Verifying checksum(s) for gimp-print ---> Extracting gimp-print ---> Applying patches to gimp-print ---> Configuring gimp-print ---> Building gimp-print with target all ---> Staging gimp-print into destroot ---> Packaging tgz archive for gimp-print 4.2.7_0 ---> Installing gimp-print 4.2.7_0 ---> Activating gimp-print 4.2.7_0 ---> Cleaning gimp-print ---> Fetching glib2 ---> Attempting to fetch glib-2.10.3.tar.bz2 from ftp://ftp.gtk.org/pub/gtk/v2.10 ---> Verifying checksum(s) for glib2 ---> Extracting glib2 ---> Applying patches to glib2 ---> Configuring glib2 ---> Building glib2 with target all ---> Staging glib2 into destroot ---> Packaging tgz archive for glib2 2.10.3_0 ---> Installing glib2 2.10.3_0 ---> Activating glib2 2.10.3_0 ---> Cleaning glib2 ---> Fetching atk ---> Attempting to fetch atk-1.11.4.tar.bz2 from http://www.gtlib.cc.gatech.edu/pub/gnome/sources/atk/1.11 ---> Verifying checksum(s) for atk ---> Extracting atk ---> Configuring atk ---> Building atk with target all ---> Staging atk into destroot ---> Packaging tgz archive for atk 1.11.4_0 ---> Installing atk 1.11.4_0 ---> Activating atk 1.11.4_0 ---> Cleaning atk ---> Fetching expat ---> Attempting to fetch expat-2.0.0.tar.gz from http://puzzle.dl.sourceforge.net/expat ---> Verifying checksum(s) for expat ---> Extracting expat ---> Configuring expat ---> Building expat with target all ---> Staging expat into destroot ---> Packaging tgz archive for expat 2.0.0_1 ---> Installing expat 2.0.0_1 ---> Activating expat 2.0.0_1 ---> Cleaning expat ---> Fetching freetype ---> Attempting to fetch freetype-2.1.10.tar.bz2 from http://download.savannah.gnu.org/releases/freetype/ ---> Verifying checksum(s) for freetype ---> Extracting freetype ---> Applying patches to freetype ---> Configuring freetype ---> Building freetype with target all ---> Staging freetype into destroot ---> Packaging tgz archive for freetype 2.1.10_1 ---> Installing freetype 2.1.10_1 ---> Activating freetype 2.1.10_1 ---> Cleaning freetype ---> Fetching fontconfig ---> Attempting to fetch fontconfig-2.3.2.tar.gz from http://fontconfig.org/release/ ---> Verifying checksum(s) for fontconfig ---> Extracting fontconfig ---> Configuring fontconfig ---> Building fontconfig with target all ---> Staging fontconfig into destroot ---> Packaging tgz archive for fontconfig 2.3.2_2+macosx ---> Installing fontconfig 2.3.2_2+macosx ---> Activating fontconfig 2.3.2_2+macosx ---> Cleaning fontconfig ---> Fetching libpixman ---> Attempting to fetch libpixman-0.1.6.tar.gz from http://www.cairographics.org/snapshots/ ---> Verifying checksum(s) for libpixman ---> Extracting libpixman ---> Configuring libpixman ---> Building libpixman with target all ---> Staging libpixman into destroot ---> Packaging tgz archive for libpixman 0.1.6_0 ---> Installing libpixman 0.1.6_0 ---> Activating libpixman 0.1.6_0 ---> Cleaning libpixman ---> Fetching render ---> Attempting to fetch renderext-0.9.tar.bz2 from http://xlibs.freedesktop.org/release/ ---> Verifying checksum(s) for render ---> Extracting render ---> Configuring render ---> Building render with target all ---> Staging render into destroot ---> Packaging tgz archive for render 0.9_0 ---> Installing render 0.9_0 ---> Activating render 0.9_0 ---> Cleaning render ---> Fetching xrender ---> Attempting to fetch libXrender-0.9.0.tar.bz2 from http://xlibs.freedesktop.org/release/ ---> Verifying checksum(s) for xrender ---> Extracting xrender ---> Configuring xrender ---> Building xrender with target all ---> Staging xrender into destroot ---> Packaging tgz archive for xrender 0.9.0_0+darwin_8 ---> Installing xrender 0.9.0_0+darwin_8 ---> Activating xrender 0.9.0_0+darwin_8 ---> Cleaning xrender ---> Fetching cairo ---> Attempting to fetch cairo-1.0.4.tar.gz from http://cairographics.org/releases/ ---> Verifying checksum(s) for cairo ---> Extracting cairo ---> Configuring cairo ---> Building cairo with target all ---> Staging cairo into destroot ---> Packaging tgz archive for cairo 1.0.4_0 ---> Installing cairo 1.0.4_0 ---> Activating cairo 1.0.4_0 ---> Cleaning cairo ---> Fetching Xft2 ---> Attempting to fetch libXft-2.1.7.tar.bz2 from http://xlibs.freedesktop.org/release/ ---> Verifying checksum(s) for Xft2 ---> Extracting Xft2 ---> Configuring Xft2 ---> Building Xft2 with target all ---> Staging Xft2 into destroot ---> Packaging tgz archive for Xft2 2.1.7_0 ---> Installing Xft2 2.1.7_0 ---> Activating Xft2 2.1.7_0 ---> Cleaning Xft2 ---> Fetching pango ---> Attempting to fetch pango-1.12.3.tar.bz2 from http://www.gtlib.cc.gatech.edu/pub/gnome/sources/pango/1.12 ---> Verifying checksum(s) for pango ---> Extracting pango ---> Applying patches to pango ---> Configuring pango ---> Building pango with target all ---> Staging pango into destroot ---> Packaging tgz archive for pango 1.12.3_0 ---> Installing pango 1.12.3_0 ---> Activating pango 1.12.3_0 ---> Cleaning pango ---> Fetching gtk2 ---> Attempting to fetch gtk+-2.8.19.tar.bz2 from ftp://ftp.gtk.org/pub/gtk/v2.8 ---> Verifying checksum(s) for gtk2 ---> Extracting gtk2 ---> Applying patches to gtk2 ---> Configuring gtk2 ---> Building gtk2 with target all ---> Staging gtk2 into destroot ---> Packaging tgz archive for gtk2 2.8.19_0+darwin_8 ---> Installing gtk2 2.8.19_0+darwin_8 ---> Activating gtk2 2.8.19_0+darwin_8 ---> Cleaning gtk2 ---> Fetching lcms ---> Attempting to fetch lcms-1.15.tar.gz from http://www.littlecms.com/ ---> Verifying checksum(s) for lcms ---> Extracting lcms ---> Configuring lcms ---> Building lcms with target all ---> Staging lcms into destroot ---> Packaging tgz archive for lcms 1.15_0 ---> Installing lcms 1.15_0 ---> Activating lcms 1.15_0 ---> Cleaning lcms ---> Fetching libart_lgpl ---> Attempting to fetch libart_lgpl-2.3.17.tar.bz2 from http://www.gtlib.cc.gatech.edu/pub/gnome/sources/libart_lgpl/2.3 ---> Verifying checksum(s) for libart_lgpl ---> Extracting libart_lgpl ---> Configuring libart_lgpl ---> Building libart_lgpl with target all ---> Staging libart_lgpl into destroot ---> Packaging tgz archive for libart_lgpl 2.3.17_0 ---> Installing libart_lgpl 2.3.17_0 ---> Activating libart_lgpl 2.3.17_0 ---> Cleaning libart_lgpl ---> Fetching libexif ---> Attempting to fetch libexif-0.6.12.tar.bz2 from http://puzzle.dl.sourceforge.net/libexif ---> Verifying checksum(s) for libexif ---> Extracting libexif ---> Applying patches to libexif ---> Configuring libexif ---> Building libexif with target all ---> Staging libexif into destroot ---> Packaging tgz archive for libexif 0.6.12_0 ---> Installing libexif 0.6.12_0 ---> Activating libexif 0.6.12_0 ---> Cleaning libexif ---> Fetching libmng ---> Attempting to fetch libmng-1.0.8.tar.gz from http://puzzle.dl.sourceforge.net/libmng ---> Verifying checksum(s) for libmng ---> Extracting libmng ---> Applying patches to libmng ---> Configuring libmng ---> Building libmng with target all ---> Staging libmng into destroot ---> Packaging tgz archive for libmng 1.0.8_0 ---> Installing libmng 1.0.8_0 ---> Activating libmng 1.0.8_0 ---> Cleaning libmng ---> Fetching libwmf ---> Attempting to fetch libwmf-0.2.8.4.tar.gz from http://puzzle.dl.sourceforge.net/wvware ---> Verifying checksum(s) for libwmf ---> Extracting libwmf ---> Configuring libwmf ---> Building libwmf with target all ---> Staging libwmf into destroot ---> Packaging tgz archive for libwmf 0.2.8.4_0 ---> Installing libwmf 0.2.8.4_0 ---> Activating libwmf 0.2.8.4_0 ---> Cleaning libwmf ---> Fetching perl5.8 ---> Attempting to fetch perl-5.8.8.tar.bz2 from http://www.cpan.org/src/5.0/ ---> Verifying checksum(s) for perl5.8 ---> Extracting perl5.8 ---> Applying patches to perl5.8 ---> Configuring perl5.8 ---> Building perl5.8 with target all ---> Staging perl5.8 into destroot ---> Packaging tgz archive for perl5.8 5.8.8_0+darwin_8 ---> Installing perl5.8 5.8.8_0+darwin_8 ---> Activating perl5.8 5.8.8_0+darwin_8 ---> Cleaning perl5.8 ---> Fetching p5-xml-parser ---> Attempting to fetch XML-Parser-2.34.tar.gz from ftp://ftp.funet.fi/pub/languages/perl/CPAN/modules/by-module/XML ---> Verifying checksum(s) for p5-xml-parser ---> Extracting p5-xml-parser ---> Configuring p5-xml-parser ---> Building p5-xml-parser with target all ---> Staging p5-xml-parser into destroot ---> Packaging tgz archive for p5-xml-parser 2.34_3 ---> Installing p5-xml-parser 2.34_3 ---> Activating p5-xml-parser 2.34_3 ---> Cleaning p5-xml-parser ---> Fetching gimp2 ---> Attempting to fetch gimp-2.2.11.tar.bz2 from ftp://ftp.cs.umn.edu/pub/gimp/v2.2/ ---> Attempting to fetch gimp-2.2.11.tar.bz2 from ftp://ftp.flirble.org/pub/X/gimp/gimp/v2.2/ ---> Verifying checksum(s) for gimp2 ---> Extracting gimp2 ---> Applying patches to gimp2 ---> Configuring gimp2 ---> Building gimp2 with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_graphics_gimp2/work/gimp-2.2.11" && make all" returned error 2 Command output: screenshot.c:375: error: 'Window' undeclared (first use in this function) screenshot.c:384: error: 'x_win' undeclared (first use in this function) screenshot.c:384: error: 'None' undeclared (first use in this function) screenshot.c:385: error: 'x_root' undeclared (first use in this function) screenshot.c:385: warning: implicit declaration of function 'RootWindow' screenshot.c:386: error: 'x_cursor' undeclared (first use in this function) screenshot.c:386: warning: implicit declaration of function 'XCreateFontCursor' screenshot.c:389: warning: implicit declaration of function 'XGrabPointer' screenshot.c:389: error: 'False' undeclared (first use in this function) screenshot.c:390: error: 'ButtonPressMask' undeclared (first use in this function) screenshot.c:390: error: 'ButtonReleaseMask' undeclared (first use in this function) screenshot.c:390: error: 'GrabModeSync' undeclared (first use in this function) screenshot.c:390: error: 'GrabModeAsync' undeclared (first use in this function) screenshot.c:391: error: 'CurrentTime' undeclared (first use in this function) screenshot.c:393: error: 'GrabSuccess' undeclared (first use in this function) screenshot.c:401: warning: implicit declaration of function 'XAllowEvents' screenshot.c:401: error: 'SyncPointer' undeclared (first use in this function) screenshot.c:402: warning: implicit declaration of function 'XWindowEvent' screenshot.c:402: error: 'x_event' undeclared (first use in this function) screenshot.c:406: error: 'ButtonPress' undeclared (first use in this function) screenshot.c:416: error: 'ButtonRelease' undeclared (first use in this function) screenshot.c:426: warning: implicit declaration of function 'XUngrabPointer' screenshot.c:427: warning: implicit declaration of function 'XFreeCursor' screenshot.c: In function 'create_image': screenshot.c:490: warning: pointer targets in assignment differ in signedness screenshot.c:502: warning: pointer targets in assignment differ in signedness make[3]: * [screenshot.o] Error 1 make[2]: * [all-recursive] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Error: /opt/local/bin/port: Status 1 encountered during processing.

This is a brand-new MacBook Pro with latest XCode installed from Apple's website.

Please mail any suggested fixes to joe_merchant (at) yahoo.com

Thanks.

comment:4 Changed 15 years ago by markd@…

Cc: markd@… added

gimp 2.2.13 installs fine now. Is this problem resolved?

comment:5 Changed 15 years ago by markd@…

Resolution: fixed
Status: newclosed
Summary: gimp2 cannot installBUG: gimp2-2.2.11 cannot install

2.2.13 works fine for me on a MacBook Pro with Xcode 2.4 so I'll mark as fixed. If you still have a problem with 2.2.13 it is probably best to open a new bug and reference the new version rather than open this older one.

Note: See TracTickets for help on using tickets.