Opened 14 years ago

Closed 14 years ago

Last modified 4 years ago

#9511 closed update (fixed)

UPDATE: MPlayer 1.0pre8

Reported by: ecronin (Eric Cronin) Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: mww@…, markd@…
Port: MPlayer

Description (last modified by ryandesign (Ryan Schmidt))

--- /opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/multimedia/MPlayer/Portfile.old	2006-05-25 03:17:17.000000000 -0400
+++ /opt/local/var/db/dports/sources/rsync.rsync.darwinports.org_dpupdate_dports/multimedia/MPlayer/Portfile	2006-06-19 20:56:52.000000000 -0400
@@ -1,12 +1,11 @@
 # $Id: Portfile,v 1.18 2006/05/25 06:54:59 blb Exp $
 
-PortSystem			1.0
-name				MPlayer
-version				cvs-20060408
-epoch				20060408
-categories			multimedia
-maintainers			darwinports@opendarwin.org
-description			The Unix movie player
+PortSystem	1.0
+name		MPlayer
+version		1.0pre8
+categories	multimedia
+maintainers	darwinports@opendarwin.org
+description	The Unix movie player
 long_description \
 	MPlayer can play most standard video formats out of the box and almost \
 	all others with the help of external codecs.  MPlayer currently works \
@@ -15,35 +14,41 @@
 	displaying subtitles. MPlayer also has a GUI with skin support and \
 	several unofficial alternative graphical frontends are available.
 
-platforms			darwin
+platforms	darwin
 
-homepage			http://www.mplayerhq.hu/
-master_sites		http://www.opendarwin.org/~blb/ \
-					http://www1.mplayerhq.hu/MPlayer/releases/codecs/:codecs \
-					http://www2.mplayerhq.hu/MPlayer/releases/codecs/:codecs
-use_bzip2			yes
-
-checksums			${distname}${extract.suffix} \
-						md5 d79ce79b767ca858a3cb555c41daa255 \
-						sha1 91ec82c5bbd0aed6e68256891bdf84af5d7d53da \
-						rmd160 cd62009e46a7ed58074cac9af472e22270f5d0e7
-
-depends_lib			port:libpng port:jpeg port:lzo port:libvorbis \
-					port:libmad port:lame
-
-configure.args		--with-extraincdir=${prefix}/include \
-					--with-extralibdir=${prefix}/lib \
-					--datadir=${prefix}/share/${name} \
-					--confdir=${prefix}/etc/${name} \
-					--mandir=${prefix}/share/man \
-					--enable-inet6 --enable-png --enable-jpeg \
-					--enable-liblzo --enable-vorbis --enable-mad \
-					--enable-mencoder \
-					--disable-sdl --disable-x11 --disable-freetype \
-					--disable-fontconfig --disable-gif --disable-arts \
-					--disable-esd --disable-fribidi --disable-theora \
-					--disable-xvid --disable-x264 --disable-cdparanoia \
-					--disable-libcdio
+homepage	http://www.mplayerhq.hu/
+master_sites	http://www1.mplayerhq.hu/MPlayer/releases/ \
+		http://www2.mplayerhq.hu/MPlayer/releases/ \
+		http://www4.mplayerhq.hu/MPlayer/releases/ \
+		http://studwww.ira.uni-karlsruhe.de/~s_doeffi/MPlayer/ \
+		http://equinox.campus.ltu.se/MPlayer/releases/ \
+		http://tranquillity.campus.ltu.se/~rtogni/ \
+		http://www.people.virginia.edu/~drf8f/MPlayer/releases/ \
+		http://www1.mplayerhq.hu/MPlayer/releases/codecs/:codecs \
+		http://www2.mplayerhq.hu/MPlayer/releases/codecs/:codecs
+use_bzip2	yes
+
+checksums	${distname}${extract.suffix} \
+			md5 f82bb2bc51b6cd5e5dd96f88f6f98582 \
+			sha1 8a0929b84dcb37d47c062230ce693b64b3e30921 \
+			rmd160 23fd13fe75a5c4029ead043aa4b3b08fe5fe44f0
+
+depends_lib	port:libpng port:jpeg port:lzo port:libvorbis \
+			port:libmad port:lame
+
+configure.args	--with-extraincdir=${prefix}/include \
+			--with-extralibdir=${prefix}/lib \
+			--datadir=${prefix}/share/${name} \
+			--confdir=${prefix}/etc/${name} \
+			--mandir=${prefix}/share/man \
+			--enable-inet6 --enable-png --enable-jpeg \
+			--enable-liblzo --enable-vorbis --enable-mad \
+			--enable-mencoder --enable-largefiles \
+			--disable-sdl --disable-x11 --disable-freetype \
+			--disable-fontconfig --disable-gif --disable-arts \
+			--disable-esd --disable-fribidi --disable-theora \
+			--disable-xvid --disable-x264 --disable-cdparanoia \
+			--disable-libcdio
 
 post-destroot {
 	file mkdir ${destroot}${prefix}/share/doc/${name}
@@ -53,23 +58,23 @@
 
 variant real {
 	global mplayerRP8 mplayerRP9 mplayerRP8file mplayerRP9file
-	set mplayerRP8			rp8codecs-ppc-20050115
-	set mplayerRP9			rp9codecs-macosx-20041107.pkg
-	set mplayerRP8file		${mplayerRP8}.tar.bz2
-	set mplayerRP9file		${mplayerRP9}.zip
-	distfiles-append		${mplayerRP8file}:codecs ${mplayerRP9file}:codecs
-	checksums-append		${mplayerRP8file} \
-								md5 4cc9a6270f9aa834b4fef49d71b9faf9 \
-								sha1 12ce04765bdf96e6ad386de1ef637b471d947796 \
-								rmd160 8d3feedca9ef50a25c5b7560dd5bca9184c1dd01 \
-							${mplayerRP9file} \
-								md5 788cf4940280fd787c0a2141d88ce3c7 \
-								sha1 18abd6d0424c4682815a13b34695d37d2fda2a73 \
-								rmd160 c6f49012633bbb84ffa405b8881dc90605d26fc6
+	set mplayerRP8		rp8codecs-ppc-20050115
+	set mplayerRP9		rp9codecs-macosx-20041107.pkg
+	set mplayerRP8file	${mplayerRP8}.tar.bz2
+	set mplayerRP9file	${mplayerRP9}.zip
+	distfiles-append	${mplayerRP8file}:codecs ${mplayerRP9file}:codecs
+	checksums-append	${mplayerRP8file} \
+					md5 4cc9a6270f9aa834b4fef49d71b9faf9 \
+					sha1 12ce04765bdf96e6ad386de1ef637b471d947796 \
+					rmd160 8d3feedca9ef50a25c5b7560dd5bca9184c1dd01 \
+				${mplayerRP9file} \
+					md5 788cf4940280fd787c0a2141d88ce3c7 \
+					sha1 18abd6d0424c4682815a13b34695d37d2fda2a73 \
+					rmd160 c6f49012633bbb84ffa405b8881dc90605d26fc6
 
-	extract.only			${distname}${extract.suffix}
+	extract.only		${distname}${extract.suffix}
 
-	depends_lib-append		bin:unzip:unzip
+	depends_lib-append	bin:unzip:unzip
 
 	post-extract {
 		cd ${worksrcpath}
@@ -90,7 +95,7 @@
 }
 
 variant x11 requires freetype requires fontconfig {
-	depends_lib-append		lib:libX11.6:XFree86
+	depends_lib-append	lib:libX11.6:XFree86
 	configure.args-delete	--disable-x11
 	configure.args-append	--enable-x11
 	configure.env-append	PKG_CONFIG_PATH=${prefix}/lib/pkgconfig:${x11prefix}/lib/pkgconfig
@@ -105,12 +110,12 @@
 # configure doesn't fully build up necessary flags when --enable-fontconfig
 # is used, so use autodetect instead
 variant fontconfig {
-	depends_lib-append		port:fontconfig
+	depends_lib-append	port:fontconfig
 	configure.args-delete	--disable-fontconfig
 }
 
 variant freetype {
-	depends_lib-append		port:freetype
+	depends_lib-append	port:freetype
 	configure.args-delete	--disable-freetype
 	configure.args-append	--enable-freetype
 }
@@ -118,30 +123,43 @@
 # configure doesn't pick up the right -l flag if we --enable-gif, so
 # we let it autodetect this
 variant gif {
-	depends_lib-append		port:libungif
+	depends_lib-append	port:libungif
 	configure.args-delete	--disable-gif
 }
 
+# BROKEN: x264 port needs updated...
+#variant x264 {
+#	depends_lib-append	port:x264
+#	configure.args-delete	--disable-x264
+#	configure.args-append	--enable-x264
+#}
+
+variant xvid {
+	depends_lib-append	port:XviD
+	configure.args-delete	--disable-xvid
+	configure.args-append	--enable-xvid
+}
+
 variant arts {
-	depends_lib-append		port:arts
+	depends_lib-append	port:arts
 	configure.args-delete	--disable-arts
 	configure.args-append	--enable-arts
 }
 
 variant esd {
-	depends_lib-append		port:esound
+	depends_lib-append	port:esound
 	configure.args-delete	--disable-esd
 	configure.args-append	--enable-esd
 }
 
 variant fribidi {
-	depends_lib-append		port:fribidi
+	depends_lib-append	port:fribidi
 	configure.args-delete	--disable-fribidi
 	configure.args-append	--enable-fribidi
 }
 
 variant theora {
-	depends_lib-append		port:libtheora
+	depends_lib-append	port:libtheora
 	configure.args-delete	--disable-theora
 	configure.args-append	--enable-theora
 }
@@ -159,7 +177,7 @@
 
 platform macosx {
 	configure.args-append	--enable-macosx --enable-macosx-finder-support \
-							--enable-macosx-bundle --enable-qtx
+					--enable-macosx-bundle --enable-qtx
 }
 
 platform darwin {

Attachments (2)

Portfile.diff (2.1 KB) - added by ecronin (Eric Cronin) 14 years ago.
patch to Portfile
Portfile.2.diff (2.1 KB) - added by ecronin (Eric Cronin) 14 years ago.
Patch to Portfile

Download all attachments as: .zip

Change History (8)

comment:1 Changed 14 years ago by mww@…

Cc: mww@… added

would you mind attaching the diff as file? Ripping text manually from bugzilla is a real pain - thanks!

comment:2 Changed 14 years ago by rhwood@…

severity: normalenhancement

Updates and new ports are enhancements

Changed 14 years ago by ecronin (Eric Cronin)

Attachment: Portfile.diff added

patch to Portfile

Changed 14 years ago by ecronin (Eric Cronin)

Attachment: Portfile.2.diff added

Patch to Portfile

comment:3 Changed 14 years ago by ecronin (Eric Cronin)

attachments.isobsolete: 01

(From update of attachment 9021) Use other patch instead

comment:4 Changed 14 years ago by markd@…

* Bug 9583 has been marked as a duplicate of this bug. *

comment:5 Changed 14 years ago by markd@…

Cc: markd@… added
Resolution: fixed
Status: newclosed

Committed, thanks!

comment:6 Changed 4 years ago by ryandesign (Ryan Schmidt)

Description: modified (diff)
Port: MPlayer added
Type: enhancementupdate
Note: See TracTickets for help on using tickets.