New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Timeline


and

01/21/12:

23:35 Changeset [89254] by stromnov@…
py-regex: update to version 0.1.20120122
22:27 ram edited by ram@…
(diff)
22:02 Ticket #32979 (py-mako: unified port) created by stromnov@…
Unified port Version bump to 0.6.0 Added missed dependency to py-beaker
21:59 Changeset [89253] by ram@…
science/gstlal: new port
20:35 Ticket #32978 (nsd 3.2.8 fails to build due to specifying _POSIX_C_SOURCE but using ...) created by cjsv@…
The first error is that u_long is an unrecognized type at util.c:745. …
17:31 Changeset [89252] by raimue@…
sysutils/vimpager: New port for using vim as pager, version 1.6.6
16:57 Changeset [89251] by ryandesign@…
iodine: use the right -arch flags; add universal variant
16:55 Changeset [89250] by ryandesign@…
iodine: whitespace changes and add modeline
16:41 Ticket #32930 (sqlite3: Undefined symbols: _OSAtomicCompareAndSwapPtrBarrier) closed by ryandesign@…
fixed: Fixed in r89249 using upstream fix.
16:41 Changeset [89249] by ryandesign@…
sqlite3: fix build on Tiger; see #32930
16:15 Ticket #32947 (alliance: non-void function 'elpLotrsShrink' should return a value) closed by and.damore@…
fixed: Committed r89248, ticket closed.
16:15 Changeset [89248] by and.damore@…
port alliance: choosing right compiler on Lion, closing ticket #32947, …
16:11 Changeset [89247] by ryandesign@…
webp: fix compile errors with gcc-4.0 on i386
15:55 Changeset [89246] by and.damore@…
port py-gdal: moving to python portgroup from py27-gdal (deleted)
15:27 Changeset [89245] by and.damore@…
removing unneeded python.default_version 24 from port py-twitter and …
15:21 Changeset [89244] by and.damore@…
port py-simplejson: adding conditional check for subport before using …
15:19 Changeset [89243] by and.damore@…
port py-twitter: adding py24 version, removing wrong comment
15:18 Changeset [89242] by raimue@…
daemondo: Found with clang analyzer: "Value stored to 'status' is never …
15:18 Changeset [89241] by snc@…
surf: add missing dependency
15:06 Ticket #30036 (mcpp @2.7.2 patch for comments on end of line) closed by blair@…
fixed: Fixed in r89236 with other cleanup commits in r89235 and r89237.
15:02 Changeset [89240] by snc@…
surf: add missing dependency
14:59 Changeset [89239] by and.damore@…
port py-twitter: switching to python portgroup, removing separated ports …
14:54 Ticket #32977 (surf: Build failure due to missing xorg-libXmu dependency) closed by snc@…
fixed: Dependency added in r89238.
14:53 Changeset [89238] by snc@…
surf: add missing lib dependency, #32977
14:47 Ticket #32977 (surf: Build failure due to missing xorg-libXmu dependency) created by justin@…
As the summary says. I get this error while building: […] If I …
14:36 Changeset [89237] by blair@…
mcpp: do not use capital letters when the filename has lowercase.
14:35 Changeset [89236] by blair@…
mcpp: fix support for lines with comments at the end; closes #30036.
14:29 Changeset [89235] by blair@…
mcpp: rename a patch file to use standard naming convention.
13:40 Ticket #32976 (gcc46 fails to compile (upgrade) on Lion) created by mojca.miklavec.lists@…
When I tried to update gcc46 (port upgrade outdated) I stumbled across the …
13:40 Ticket #32759 (reduce-algebra upgrade renamed reduce-3.8.0-r1535 - installs both csl and ...) closed by snc@…
duplicate
13:35 Ticket #32970 (iodine should be UsingTheRightCompiler) closed by snc@…
fixed: Also added missing platforms: r89234.
13:35 Changeset [89234] by snc@…
iodine: * ensure UsingTheRightCompiler, #32970 * add missing platforms
13:31 Changeset [89233] by afb@…
py26-pygpgme: update version, add livecheck
13:27 Ticket #32794 (py26-pygpgme 'Not operational' error when creating Context) closed by afb@…
fixed: Fixed, r89232.
13:27 Changeset [89232] by afb@…
py26-pygpgme: work with newer libgpgme (#32794)
13:25 Ticket #32975 (qt4-mac: wrong pkg-config cflags) created by mojca.miklavec.lists@…
When calling […] with qt4-mac installed, I get […] but …
12:43 Changeset [89231] by blair@…
ice-python*: do not compile with clang++, use llvm-gcc-4.2 instead.
12:24 Changeset [89230] by mk@…
libalkimia: append forgotten dep to kdelibs4
12:12 Changeset [89229] by mk@…
skrooge: update to 1.2.1
12:11 Ticket #27528 (ImageMagick: expected '#pragma omp' clause before 'omp_throttle') reopened by dhruvahuja@…
Replying to michael.himmelsbach@…: > ImageMagick fails to …
12:03 Ticket #32854 (mono @2.10.6_0 configure fails when using clang) closed by raimue@…
fixed: Fixed in r89228.
12:02 Changeset [89228] by raimue@…
devel/mono: Do not overwrite -L${prefix} in configure.ldflags Fixes build …
12:01 Changeset [89227] by raimue@…
lang/clang-{2.9,3.0,3.1}: Fix scan-view-mp-X.Y symlink, accidentally named …
11:44 Ticket #32974 (platypus: wrong paths in platypus command line utility) created by michael.klein@…
[…] resp. files are (correctly) installed to /opt/local: […]
11:22 Ticket #32973 (reduce: replaces reduce-algebra) created by mark.brethen@…
The upgrade to reduce-algebra renames the port to reduce, following other …
11:11 Changeset [89226] by mk@…
libalkimia: update to 4.3.2
11:04 Changeset [89225] by mk@…
makeicns: update to version 1.4.10 to fix issue 12 at bitbucket (suffix …
11:03 Ticket #32972 (Upgrade gdal to 1.9.0) created by and.damore@…
I'm attaching patch to upgrade gdal to 1.9.0
11:00 Ticket #32961 (py27-gdal fatal error: 'cpl_port.h' file not found) closed by and.damore@…
fixed: The '@1.8.0' in summary refers to gdal, not to py27-gdal. The patch is …
10:57 Changeset [89224] by and.damore@…
port py27-gdal: upgrading version to 1.8.1, adding patch as per ticket …
10:50 Ticket #32971 (Request: Rust) created by macports.org@…
[https://mail.mozilla.org/pipermail/rust-dev/2012-January/001256.html Rust …
10:23 Changeset [89223] by raimue@…
port.tcl: List local options in 'port echo' only, remove global options.
09:41 Ticket #30889 (Nedit abort()s in __memset_chk) closed by raimue@…
fixed: Fixed, see comment:ticket:30854:12
09:40 Ticket #30854 (nedit on lion is aborted) closed by raimue@…
fixed: Thanks for the patch, this is now being applied as of r89222.
09:40 Changeset [89222] by raimue@…
editors/nedit: Fix a segmentation fault on startup caused by wrong buffer …
09:34 Changeset [89221] by raimue@…
editors/nedit: Remove platform block as we are always building for darwin. …
08:56 Changeset [89220] by raimue@…
port.tcl: Restrict port select behavior to options related to this action. …
08:47 Ticket #32970 (iodine should be UsingTheRightCompiler) created by snc@…
[…]
08:43 Ticket #32969 (clang-2.9, clang-3.0, clang-3.1: documentation is missing) created by raimue@…
The clang ports do not install any documentation. Anyhow, the llvm ports …
08:34 Ticket #32960 (py-mercurial_keyring: update to version 0.5.0) closed by and.damore@…
fixed: Committed r89219. Ticket closed.
08:28 Changeset [89219] by and.damore@…
py-mercurial_keyring: updated to 0.5.0, closed ticket #32960
08:08 Ticket #32968 (p5-file-homedir missing p5-file-which dependency) created by coax@…
p5-file-homedir depends on p5-file-which, but this is not included in the …
08:04 Ticket #32967 (cvsps needs to be UsingTheRightCompiler) created by snc@…
[…]
07:16 Ticket #32966 (py25-webhelpers not found while cleaning) created by gary.verhaegen@…
Macports 2.0.3, just did a selfupdate. Doing a port clean all
05:40 Changeset [89218] by raimue@…
port.tcl: Make info --pretty the default if no other option was given to …
04:42 Ticket #32965 (kdepimlibs4: Could NOT find LIBICAL (missing: LIBICAL_INCLUDE_DIRS)) created by mparchet@…
Hi, I wold like to install kontact and use the contact's api but I can't …
04:14 Changeset [89217] by jmr@…
add missing dry-run check
03:42 Changeset [89216] by hum@…
opal-ml: optimize CFLAGS; add a comment.
03:36 Changeset [89215] by hum@…
New port: mallet @2.0.7 - MAchine Learning for LanguagE Toolkit.
03:32 Changeset [89214] by hum@…
hadoop: fix 'ln -s' to conf.pseudo; simplify livecheck.url; see …
03:28 Changeset [89213] by and.damore@…
base: moving worksymlink creation out of the workpath creation block, this …
03:15 Ticket #32964 (NEW: JCC 2.12) created by petrus.hyvonen@…
I saw that the JCC java-python interface module was not in macports. I …
02:16 Changeset [89212] by mk@…
kmymoney4-devel: try building with 'build.asroot yes'
01:00 Changeset [89211] by ryandesign@…
jake: update to 0.2.11
00:33 Changeset [89210] by ryandesign@…
sqlite3: refresh patch
00:23 Changeset [89209] by ryandesign@…
sqlite3: refresh patch
00:17 Ticket #32962 (octave-image fails to build with libpng 1.4.x) closed by ryandesign@…
duplicate: Duplicate of #29084.
00:04 Ticket #32922 (jubatus: use github portgroup) closed by hum@…
fixed: Thank you for your patch to use the github portgroup! Committed in r89206

01/20/12:

23:27 Changeset [89208] by hum@…
hadoop: update to 1.0.0; fix master_sites and livecheck; use Tcl 'ln' …
23:22 Changeset [89207] by hum@…
pficommon: use github portgroup; fix livecheck.
23:20 Changeset [89206] by hum@…
jubatus: use github portgroup; fix configure.compiler; see #32922.
22:39 Ticket #30478 (libsdl crashes on fullscreen in Lion) closed by jmr@…
fixed: Fixed in 1.2.15, r89205.
22:39 Changeset [89205] by jmr@…
libsdl: update to 1.2.15 (fixes crash on Lion, #30478)
21:31 Changeset [89204] by hum@…
vowpal_wabbit: use github portgroup; fetch from distfile instead of git; …
21:24 Changeset [89203] by hum@…
py-mecab: remove python.default_version; see …
19:24 Changeset [89202] by ram@…
science/ligo-lvalert: new port
19:23 Changeset [89201] by ram@…
science/ligo-lars: new port
19:22 Changeset [89200] by ram@…
science/ligo-gracedb: new port
19:21 Changeset [89199] by ram@…
science/ligo-common: new port
19:17 Changeset [89198] by ram@…
science/glue: update to 1.37.1
19:12 Ticket #32944 (Install of py27-matplotlib fails) closed by ram@…
invalid
18:17 Changeset [89197] by dports@…
py-fuse: update to v0.2.1
14:54 Changeset [89196] by takeshi@…
upc: revamped for 4.7.0.1
13:23 Ticket #32963 (depot_tools: gclient doesn't work, port installs files without tracking) created by singingwolfboy@…
On trying to use gclient from the depot_tools port to check out the …
12:07 Ticket #32962 (octave-image fails to build with libpng 1.4.x) created by barry.j.mcinnes@…
Mac 10.7.2 Xcode 4.2.1 octave-image fails to build Log file attached.
11:59 Changeset [89195] by singingwolfboy@…
oops: py-nose-testconfig does not actually support python2.4
11:59 Changeset [89194] by singingwolfboy@…
New port: py-nose-testconfig
11:46 Ticket #32961 (py27-gdal fatal error: 'cpl_port.h' file not found) created by jea@…
Trying to install py27-gdal. Lion 10.7.2 Server, XCode 4.2.1 Seems to be …
11:28 Ticket #32960 (py-mercurial_keyring: update to version 0.5.0) created by peter.linss@…
Version 0.5.0 fixes incompatibility with largefiles extension. Available …
11:22 Ticket #32938 (python/py*-enum: unify using python portgroup) closed by ram@…
fixed: Done, pushed.
11:20 Changeset [89193] by ram@…
python/py-enum: remove jann as maintainer #32938
11:20 Changeset [89192] by ram@…
python/py*-enum: unify
11:20 Changeset [89191] by ram@…
python/py-enum: update to 0.4.4
11:20 Changeset [89190] by ram@…
python/py-enum: add livecheck
11:20 Changeset [89189] by ram@…
python/py-enum: whitespace
11:20 Changeset [89188] by ram@…
python/py-enum: take co-maintainership
10:32 Ticket #32948 (liblastfm is not correctly linked during build process) reopened by mparchet@…
10:28 Ticket #32959 (ushare 1.1a fails to build with clang) created by macosforge@…
main.log is attached. OS is 10.7.2
09:17 Ticket #32958 (kde kontact is not availlable) closed by macsforever2000@…
invalid: It is part of kdepim4.
07:47 Ticket #32958 (kde kontact is not availlable) created by mparchet@…
Hello, I need to work with kde kontact on mac os 10.7.2 but it seem be …
07:38 Ticket #32289 (py27-rbtools do not work) closed by singingwolfboy@…
fixed: Should be fixed by #32290. Please let me know if it still doesn't work.
07:36 Ticket #32290 (py-rbtools misses dependency to py-simplejson) closed by singingwolfboy@…
fixed: Fixed in r89187
07:36 Changeset [89187] by singingwolfboy@…
py-rbtools: added simplejson dependency for py24 and py25
07:29 Ticket #32953 (py24-pylons: Error: Dependency 'py24-simplejson' not found) closed by singingwolfboy@…
fixed: Fixed in r89186
07:29 Changeset [89186] by singingwolfboy@…
unified py*-simplejson ports, updated to 2.3.2
06:37 Ticket #32942 (phpsh: use tarball) closed by singingwolfboy@…
fixed
06:37 Ticket #32942 (phpsh: use tarball) reopened by singingwolfboy@…
I was mistaken -- this patch does work, after all. Committed in r89185.
06:36 Changeset [89185] by singingwolfboy@…
phpsh: changed fetch to pull tarball instead of git clone, fixes #32942
06:17 Ticket #32941 (Quicksilver: use tarball) closed by singingwolfboy@…
fixed: Ah, I see -- I had an old copy of the Quicksilver portfile lying in my …
06:07 Changeset [89184] by singingwolfboy@…
switch quicksilver fetch to pull a tarball, fixes #32941
06:02 Ticket #32957 (ocamlsdl does not apply a needed patch) created by cedric.pasteur@…
The patch called patch-configure.diff was disabled when going to v0.8, but …
06:02 Changeset [89183] by stromnov@…
py-milk: update to version 0.4.2
06:01 Changeset [89182] by stromnov@…
py-pyproj: update to version 1.9.0
05:54 Changeset [89181] by stromnov@…
py-regex: update to version 0.1.20120119
05:36 Ticket #32956 (wview install build failure) created by abrauda@…
:info:build ../ftp/ftpUtils.c:380:9: error: non-void function …
05:35 Ticket #32955 (xmms 1.2.11 build fail) created by fheday@…
xmms fails to build in MacOS 10.7.2. Complaining about: […]
05:08 Ticket #32954 (octave-odepkg needs to list build-time dependencies, gsed in particular) created by alexey.muranov@…
octave-odepkg needs gsed to install, but it is not listed as …
04:12 Changeset [89180] by cal@…
Add port help rev-upgrade
03:58 Changeset [89179] by cal@…
port(1): Reference macports.conf(5) in the documentation for rev-upgrade
03:33 Ticket #32887 (nu2: update to 2.0.1 for real) closed by and.damore@…
fixed: Nu2 is now using ivars in a objC class extension and therefore it can only …
03:31 Changeset [89178] by and.damore@…
port nu2: updated to main github repository rather than a fork, revision …
01:18 Changeset [89177] by ryandesign@…
fnlib: rewrite master_sites to avoid redirects
01:15 Changeset [89176] by ryandesign@…
graphviz-devel, graphviz-gui-devel, gvedit-devel: update to …
01:02 Changeset [89175] by ciserlohn@…
nodejs: update to version 0.6.8 * removed patch included upstream
00:37 Changeset [89174] by dports@…
gnumeric: revert r89173; already had a license tag
00:17 Changeset [89173] by dports@…
gnumeric: license
00:03 Changeset [89172] by ryandesign@…
libpixman: update to 0.24.2

01/19/12:

23:56 Changeset [89171] by ryandesign@…
curl-ca-bundle: update certdata.txt to 1.81
23:51 Changeset [89170] by ryandesign@…
VillainousStyle: new port, version 20110713, with subports …
23:45 Ticket #32845 (fuse-bindings-python(25): unify and rename) closed by dports@…
fixed: r89168 and r89169
23:44 Changeset [89169] by dports@…
fuse-bindings-python(25): replace with renamed py24/py25-fuse (#32845, …
23:42 Changeset [89168] by dports@…
py-fuse: unified and renamed version of fuse-bindings-python(25); see …
23:21 Ticket #32953 (py24-pylons: Error: Dependency 'py24-simplejson' not found) created by ryandesign@…
[…]
23:15 Changeset [89167] by ryandesign@…
php54: update to 5.4.0RC6
20:37 Changeset [89166] by ryandesign@…
py-pylons: append to, don't overwrite, portgroup dependencies
20:35 Changeset [89165] by ryandesign@…
py-pastescript: append to, don't overwrite, portgroup dependencies; don't …
20:33 Changeset [89164] by ryandesign@…
py-pastedeploy: append to, don't overwrite, potential portgroup …
20:27 Changeset [89163] by ryandesign@…
fsvs: update to 1.2.4
20:21 Changeset [89162] by ryandesign@…
py-paste: append to, don't overwrite, portgroup dependencies
20:08 Changeset [89161] by ryandesign@…
mysql5, mysql5-server: update to 5.1.61
20:03 Changeset [89160] by ryandesign@…
py-harstorage: append to, don't overwrite, portgroup dependencies
19:49 Changeset [89159] by ryandesign@…
astyle: simplify overcomplicated Makefile patch and return to the standard …
19:34 Ticket #32952 (AppKiDo 0.986sp4 crashes at startup) created by ryandesign@…
When I launch AppKiDo or AppKiDo-for-iPhone on Snow Leopard x86_64, they …
19:32 Ticket #28543 (AppKiDo 0.985 crashes after starting up) closed by ryandesign@…
fixed: r89158
19:32 Ticket #31739 (AppKiDo: upgrade to 0.986sp4, fetch from git) closed by ryandesign@…
fixed: Yes, thanks. Now it crashes differently, but I committed this update in …
19:32 Changeset [89158] by ryandesign@…
AppKiDo: update to 0.986sp4 (#31739) and fix a crash on 64-bit systems …
19:26 Changeset [89157] by ryandesign@…
astyle: add universal variant; build for the right archs
19:22 Changeset [89156] by ryandesign@…
astyle: fix description
18:18 Changeset [89155] by jmr@…
delete duplicate py25-WebHelpers
18:03 Ticket #32951 (redis server fails to start) created by conradwt@…
I recently download the redis port. […] However, when I attempt to …
17:35 Ticket #32950 (glib2 @2.30.2 destroot staging failure when /opt/local/bin/perl doesn't ...) created by ollie@…
When trying to install glib2, I encounter a problem similar to #32185, …
17:18 Ticket #32932 (freeciv fails to build: AI_NUMERICSERV undeclared) closed by ryandesign@…
fixed
17:16 Ticket #32948 (liblastfm is not correctly linked during build process) closed by ryandesign@…
duplicate: Duplicate of #32675.
17:14 Ticket #32941 (Quicksilver: use tarball) reopened by ryandesign@…
I did of course verify the patch works correctly on my system before …
15:35 Ticket #32949 (drop dependency on gtk2, so librsvg can be made a dependency of gtk2) created by cal@…
librsvg is required for gtk2 applications to show SVG icons. However, …
15:27 Changeset [89154] by cal@…
gtk2: remove dependency for librsvg to avoid circular dependency
14:58 Changeset [89153] by eborisch@…
py-pil: Revbumping; likely should have been bumped with r81424 which …
14:53 Changeset [89152] by cal@…
subsurface: remove name and version, which are superseded by github.setup, …
14:50 Changeset [89151] by cal@…
new port: libdivecomputer, dependency of subsurface
14:49 Changeset [89150] by cal@…
libdivecomputer: Fix version
14:38 Changeset [89149] by mk@…
kmymoney4-devel: git version update, remove documentation and manpage due …
14:34 Changeset [89148] by singingwolfboy@…
Forgot some dependencies for py-harstorage
14:20 Changeset [89147] by singingwolfboy@…
New port: py-harstorage
14:15 Ticket #32917 (clang++ 2.9, 3.0 and 3.1 do not link with the C++ standard library) closed by jeremyhu@…
fixed: r89146
14:15 Changeset [89146] by jeremyhu@…
llvm-*, clang-*, dragonegg-3.1: revbump 3.1s and address execution of …
14:14 Changeset [89145] by ryandesign@…
magic: notice when essential libraries don't get built by the build script …
14:13 Changeset [89144] by singingwolfboy@…
unified py*-pylons and updated to 1.0.1rc1
14:11 Changeset [89143] by cal@…
new port: subsurface
14:11 Changeset [89142] by singingwolfboy@…
unified py*-beaker ports, updated to 1.6.2
14:05 Changeset [89141] by cal@…
gtk2: Add dependency on librsvg, which is required for SVG icons in gtk …
14:02 Changeset [89140] by cal@…
astyle: UsingTheRightCompiler
13:53 Changeset [89139] by singingwolfboy@…
unified py*-webtest, updated to 1.3.3
13:49 Changeset [89138] by singingwolfboy@…
moved py26-weberror to py-weberror, converted to unified format
13:48 Changeset [89137] by ryandesign@…
magic: do not look for headers in Fink directory
13:47 Ticket #32948 (liblastfm is not correctly linked during build process) created by blender3dartist@…
Calling liblastfm.0.dylib (via Amarok) fails and crashes Amarok, because …
13:47 Changeset [89136] by cal@…
subsurface: Fix build after update to 1.2
13:46 Ticket #32947 (alliance: non-void function 'elpLotrsShrink' should return a value) created by yannick.heinrich@…
The port does not compile on Mac Os X Lion
13:45 Changeset [89135] by singingwolfboy@…
unified py*-formencode ports
13:16 Ticket #32946 (nodejs-devel: update to 0.7.3) created by ryandesign@…
[http://nodejs.org/dist/v0.7.0/ nodejs development version 0.7.0 has been …
13:14 Ticket #32918 (nodejs: build for i386 fails on my x86_64 Mac) closed by ciserlohn@…
fixed: Fixed in r89134.
13:12 Changeset [89134] by ciserlohn@…
nodejs: explicitly pass $build_arch to configure (fixes #32918)
13:01 Changeset [89133] by cal@…
user ports libdivecomputer: update to current, subsurface: update to 1.2, …
12:58 Changeset [89132] by ryandesign@…
py-flask: livecheck only in the stub port
12:57 Changeset [89131] by ryandesign@…
py-flask: fix stub port by changing python.default_version to one that the …
12:56 Changeset [89130] by singingwolfboy@…
removed unneeded py27-paste port (since we have py-paste unified port)
12:55 Changeset [89129] by singingwolfboy@…
unified py*pastescript ports, updated to 1.7.5, updated dependencies
12:53 Changeset [89128] by singingwolfboy@…
unified py*-pastedeploy ports, updated to 1.5.0
12:51 Ticket #32923 (GitX: use github portgroup) closed by cal@…
fixed: Thanks for the patch, r89127.
12:51 Changeset [89127] by cal@…
GitX: Switch to github portgroup, closes #32923
12:50 Changeset [89126] by ryandesign@…
magic: add mesa dependency; ensure we're UsingTheRightCompiler by patching …
12:40 Changeset [89125] by singingwolfboy@…
Unified py*-paste ports, updated to 1.7.5.1
12:34 Changeset [89124] by singingwolfboy@…
unified py*-webhelpers ports, updated to 1.3
12:26 Changeset [89123] by singingwolfboy@…
unified py*-routes ports into py-routes port, updated to 1.12.3
12:24 Changeset [89122] by singingwolfboy@…
Removed unneded py26-flask
12:24 Changeset [89121] by singingwolfboy@…
Removed unneeded py27-selenium
12:17 Changeset [89120] by snc@…
guide: add macports-clang-* options for configure.compiler
12:00 Changeset [89119] by singingwolfboy@…
moved py27-selenium to unified framework, updated to 2.17.0
11:53 Ticket #32499 (replace py26-flask with unified py-flask port) closed by singingwolfboy@…
fixed: Fixed in r89118
11:52 Changeset [89118] by singingwolfboy@…
Converted py26-flask portfile to unified format, fixes #32499
11:47 Ticket #32498 (py*-werkzeug: update and unify ports) closed by singingwolfboy@…
fixed: Maintainer timeout. Committed in r89117
11:47 Changeset [89117] by singingwolfboy@…
Converted py-werkzeug, py25-werkzeug, and py26-werkzeug to unified format; …
11:34 Ticket #31354 (miniupnpc: Update to 1.6) closed by singingwolfboy@…
fixed: Fixed in r89116
11:34 Changeset [89116] by singingwolfboy@…
miniupnpc: update to 1.6
11:30 Ticket #32921 (multimarkdown: update to 3.5) closed by singingwolfboy@…
fixed: fixed in r89115
11:30 Changeset [89115] by singingwolfboy@…
multimarkdown: updated to version 3.5
11:21 Ticket #32833 (py27-whoosh 2.2.2 checksum mismatch) closed by singingwolfboy@…
fixed: Fixed in r89114.
11:21 Changeset [89114] by singingwolfboy@…
py-whoosh: update to 2.3.2, pull from PyPI instead of bitbucket
11:17 Ticket #32942 (phpsh: use tarball) closed by singingwolfboy@…
invalid: That patch doesn't work: Macports doesn't know where to download the file …
11:15 Ticket #32941 (Quicksilver: use tarball) closed by singingwolfboy@…
invalid: That patch doesn't work: Macports doesn't know where to download the file …
10:49 Changeset [89113] by ram@…
science/lalapps: update to 6.6.2
10:49 Changeset [89112] by ram@…
science/lalstochastic: update to 1.1.3
10:49 Changeset [89111] by ram@…
science/lalinference: update to 0.1.1
10:49 Changeset [89110] by ram@…
science/lalpulsar: update to 1.2.1
10:49 Changeset [89109] by ram@…
science/lalinspiral: update to 1.2.2
10:49 Changeset [89108] by ram@…
science/lalburst: update to 1.1.1
10:49 Changeset [89107] by ram@…
science/lalsimulation: update to 0.1.1
10:49 Changeset [89106] by ram@…
science/lalxml: update to 1.1.2
10:49 Changeset [89105] by ram@…
science/lalmetaio: update to 1.0.3
10:49 Changeset [89104] by ram@…
science/lalframe: update to 1.0.4
10:49 Changeset [89103] by ram@…
science/lal: update to 6.6.1
10:12 Changeset [89102] by jwa@…
new port: py-robotframework-ride, unified python port with subports for …
10:12 Ticket #32945 (dbus needs unloading and reloading the .plist items in order for ...) created by vloodo@…
On Snow Leopard, I have this recurring problem where applications that …
10:07 Changeset [89101] by krischik@…
Update to version 0.4.905
10:06 Changeset [89100] by ryandesign@…
cc: use https link to wiki
09:49 Changeset [89099] by ryandesign@…
magic: update to 7.5.214, add blt dependency, fix non-portable use of …
09:45 Ticket #32944 (Install of py27-matplotlib fails) created by ch-n@…
I when Installing py27-matplotlib during an attempt to install py27-spyder …
09:32 Ticket #32934 (magic vlsi fails: tclmagic.dylib image not found) reopened by ryandesign@…
I'm able to reproduce the issue. The problem is tclmagic.dylib does not …
09:07 Changeset [89098] by ryandesign@…
magic: fix livecheck
08:30 Changeset [89097] by pvanek@…
qlipper: version bump 2.0.0
01:20 Ticket #32943 (planner: upgrade to v0.14.6) created by kurtjaeke@…
Please upgrade planner to v0.14.6. Portfile patch attached.
00:36 Ticket #32942 (phpsh: use tarball) created by ryandesign@…
In r89095 I updated phpsh to use the new github portgroup. Is there a …
00:27 Changeset [89096] by ryandesign@…
phpsh: reinplace in post-patch not configure
00:24 Changeset [89095] by ryandesign@…
phpsh: use github portgroup, thereby fixing livecheck
00:19 Changeset [89094] by ryandesign@…
tagainijisho: use github portgroup, thereby fixing livecheck
00:06 Ticket #32941 (Quicksilver: use tarball) created by ryandesign@…
In r89093 I updated Quicksilver to use the new github portgroup. Is there …

01/18/12:

23:59 Ticket #32940 (flann 1.7.1 Portfile doesn't build headers. Changeset 88262) created by shinko.cheng@…
I port installed flann 1.7.1 but the headers are missing. There isn't an …
23:46 Changeset [89093] by ryandesign@…
Quicksilver: use github portgroup, thereby fixing livecheck
23:35 Ticket #32939 (gtksourceview2 @2.10.5_2 build error:) created by yuku@…
Using Xcode 4.2, also tried to use llvm and apple-gcc42 as described in …
23:27 Changeset [89092] by ryandesign@…
ShiftIt: use MacPorts libX11 instead of system version
23:05 Changeset [89091] by ryandesign@…
ShiftIt: use standard livecheck based on tags
23:05 Changeset [89090] by ryandesign@…
ShiftIt: GPL-3+ license
23:04 Changeset [89089] by ryandesign@…
ShiftIt: build a specific revision, not master, and call it 1.5; it's …
22:45 Changeset [89088] by jmr@…
libsdl_ttf: update to 2.0.11
22:28 Changeset [89087] by jmr@…
libsdl_net-framework: switch to creating framework the same way as …
22:26 Changeset [89086] by jmr@…
libsdl_net: update to 1.2.8
21:53 Ticket #32764 (virtualbox version modification throwing off downstream software) closed by royliu@…
wontfix: On second thought, I don't think a fix is feasible. Performing a grep
21:52 Changeset [89085] by jmr@…
libsdl_mixer: update to 1.2.12
21:32 Ticket #32711 (virtualbox: gcc-apple-4.2: not found) closed by royliu@…
fixed: Fixed in r89084.
21:31 Changeset [89084] by royliu@…
virtualbox: fix build for Xcode 3.2.6 and close ticket #32711
21:24 Changeset [89083] by jmr@…
libsdl_image: update to 1.2.11
21:12 Changeset [89082] by ryandesign@…
ShiftIt: whitespace fix
21:10 Changeset [89081] by ryandesign@…
ShiftIt: fix tag prefix in github.setup line
21:09 Changeset [89080] by ryandesign@…
ShiftIt: fix livecheck
21:06 Changeset [89079] by ryandesign@…
ShiftIt: use github portgroup
21:05 Changeset [89078] by ryandesign@…
ShiftIt: whitespace changes to conform to modeline
21:01 Changeset [89077] by ryandesign@…
MyLoss: install a specific revision instead of master, and call it '1.0', …
20:53 Ticket #32938 (python/py*-enum: unify using python portgroup) created by ram@…
I'd like to unify the py*-enum ports. Attached is the final Portfile, I …
20:52 Ticket #32937 (jpeg: update to 8d) created by jmr@…
Current stable version released 15-Jan-2012.
20:48 Ticket #31767 (jpeg: distfile is HTML file) closed by jmr@…
worksforme: No response; closing.
20:43 Ticket #32936 (tiff: update to 4.0.2) created by jmr@…
Note that this release is not ABI compatible with 3.x, so dependents will …
20:40 Changeset [89076] by ryandesign@…
MyLoss: fix livecheck
20:39 Changeset [89075] by ryandesign@…
MyLoss: use github portgroup
20:38 Changeset [89074] by ryandesign@…
MyLoss: whitespace changes, add modeline
20:36 Changeset [89073] by ryandesign@…
HideSysFiles: install a specific revision instead of master, and call it …
20:33 Changeset [89072] by ryandesign@…
HideSysFiles: fix livecheck
20:32 Changeset [89071] by ryandesign@…
HideSysFiles: use github portgroup
20:31 Changeset [89070] by ryandesign@…
HideSysFiles: whitespace changes, add modeline
20:28 Changeset [89069] by ryandesign@…
Fonzy: fetch a specific revision instead of fetching from master; call it …
20:20 Changeset [89068] by ryandesign@…
Fonzy: enable livecheck
20:19 Changeset [89067] by ryandesign@…
Fonzy: use github portgroup
20:17 Changeset [89066] by ryandesign@…
Fonzy: modify whitespace to conform to modeline
20:15 Changeset [89065] by ryandesign@…
GetPoints: use a specific git revision instead of building from master; …
20:10 Changeset [89064] by ryandesign@…
Readown: simplify livecheck.url using github.raw
20:10 Changeset [89063] by ryandesign@…
github-1.0.tcl: add github.raw for Portfiles to use as needed
19:58 Changeset [89062] by ryandesign@…
GetPoints: whitespace changes, add modeline
19:56 Changeset [89061] by ryandesign@…
GetPoints: use github portgroup
19:22 Changeset [89060] by ryandesign@…
github-1.0.tcl: ignore ssl cert when fetching; github's ssl cert is too …
19:04 Changeset [89059] by ryandesign@…
mldonkey: update to 3.1.0; ensure we're UsingTheRightCompiler; fix …
17:53 Ticket #32934 (magic vlsi fails: tclmagic.dylib image not found) closed by macsforever2000@…
duplicate: #25214
17:53 Ticket #32935 (blt: use of undeclared identifier 'EAGAIN') closed by ryandesign@…
duplicate: Duplicate of #32599.
17:51 Changeset [89058] by ryandesign@…
freeciv: update to 2.3.1
17:14 Ticket #32935 (blt: use of undeclared identifier 'EAGAIN') created by yannick.heinrich@…
I tried to install the BLT port. It does not compile, an error appear in …
17:12 Ticket #32934 (magic vlsi fails: tclmagic.dylib image not found) created by yannick.heinrich@…
I just install the port but it does not find the dynamic library.
17:09 Ticket #32933 (py-blist: Integrate py31-blist, add py32-blist) created by mistersheik@…
Copy: /trunk/dports/python/py31-blist/Portfile To: …
17:03 Changeset [89057] by ryandesign@…
freeciv: incorporate freeciv-x11 as a subport
16:57 Changeset [89056] by ryandesign@…
ipe: don't use 'system' just to make a symlink
16:52 Changeset [89055] by ryandesign@…
ipe: rewrite master_sites to avoid redirects
15:58 Ticket #25757 (php5-ftp php5 5.3.2 upgrade disables ftp) closed by ryandesign@…
worksforme
15:02 Ticket #32932 (freeciv fails to build: AI_NUMERICSERV undeclared) created by hraban@…
End of log: […]
14:48 Changeset [89054] by ram@…
science/pylal: set svn properties
14:37 Changeset [89053] by afb@…
zeroinstall-injector: upgrade to 1.5
14:22 Ticket #32931 (ntop fails to upgrade with error "GeoIP library is missing") created by stephen.marshall@…
despite having the libGeoIP installed, sudo port install ntop fails during …
14:19 Ticket #32925 (expat configure failure with Xcode 4.3 beta) closed by ryandesign@…
invalid: Ok, then this is solved by the aforementioned fix, and you need to build …
14:03 Ticket #32831 (qlandkartegt: upgrade to 1.3.2) closed by dports@…
fixed: Thanks! r89052.
14:02 Changeset [89052] by dports@…
qlandkartegt: maintainer update to v1.3.2 (#32831)
13:56 Changeset [89051] by ryandesign@…
py-zc-buildout: fix stub port by not running the post-destroot block there
13:44 Changeset [89050] by ram@…
science/match: set properties correctly
13:38 Changeset [89049] by ram@…
science/match: new port
13:08 Ticket #32926 (ipe update from 7.0.14 to 7.1.2) closed by dports@…
fixed: Thanks! Committed in r89048. It looks like the license is GPL-3+ ("any …
13:06 Changeset [89048] by dports@…
ipe: update to v7.1.2 (#32926; approved by maintainer; supersedes #31153) …
12:57 Ticket #32930 (sqlite3: Undefined symbols: _OSAtomicCompareAndSwapPtrBarrier) created by macports@…
In upgrading from 3.7.9_0 to 3.7.10_0, the link stage fails with undefined …
12:57 Ticket #31153 (ipe version update to 7.1.1) closed by dports@…
duplicate: Superseded by #32926
12:56 Ticket #30540 (ipe @7.0.14: Please add an application bundle to Applications/MacPorts/) closed by dports@…
duplicate: Superseded by #32926
12:49 Ticket #32929 (libpixman does not propagate universal to libpng) closed by ryandesign@…
duplicate: Duplicate of #32260.
12:29 Ticket #31564 (installing ipe) closed by dports@…
invalid
11:36 Ticket #32929 (libpixman does not propagate universal to libpng) created by gary.verhaegen@…
While trying to get firefox-x11 to compile, I first tried to compile it …
11:29 Changeset [89047] by singingwolfboy@…
py-zc-buildout: add dependency on distribute
10:15 Changeset [89046] by singingwolfboy@…
New port: py-zc-buildout
10:07 Ticket #32928 (py-mechanize @0.1.9 fails to perform a livecheck) created by nonstop.server@…
Port fails to perform a livecheck. […] Setting variables …
10:05 Ticket #32927 (Update gimp2-devel from 2.7.3 to 2.7.4) created by blender3dartist@…
The Gimp project has released the latest in their gimp development …
09:32 Changeset [89045] by pixilla@…
net/avahi: - Fix pyxx-gdbm depends_lib in pythonxx variants.
08:28 Changeset [89044] by mww@…
openssl: version 1.0.0g
08:27 Ticket #32926 (ipe update from 7.0.14 to 7.1.2) created by Torsten.Maehne@…
Please update ipe from version 7.0.14 to the most recent version 7.1.2. I …
08:26 Changeset [89043] by jwa@…
unify paver port, remove the version specific ones, take maintainership
08:24 Changeset [89042] by ram@…
science/pylal: add nick as co-maintainer
07:22 Ticket #32925 (expat configure failure with Xcode 4.3 beta) created by alex.godbehere@…
I'm trying to install dnsmasq to use my PC as a siri server. When I …
07:06 Ticket #32924 (poppler: Add library dependencies) created by macosx12345@…
Poppler and libpoppler actually depend on several dependencies that were …
05:32 Changeset [89041] by ryandesign@…
multimarkdown: remove default git.branch value
05:32 Changeset [89040] by ryandesign@…
github-1.0.tcl: fix default git.branch value when github.tag_prefix is …
05:08 Changeset [89039] by ryandesign@…
java_memcached: remove default git.branch value
05:07 Ticket #32923 (GitX: use github portgroup) created by ryandesign@…
This patch simplifies the GitX portfile by using the new github portgroup. …
05:06 Changeset [89038] by ryandesign@…
github-1.0.tcl: provide a sensible default value for git.branch
04:49 Ticket #32922 (jubatus: use github portgroup) created by ryandesign@…
Here is a patch to simplify the jubatus port by using the new github …
04:41 Changeset [89037] by ryandesign@…
yajl: update to 2.0.4
04:40 Changeset [89036] by ryandesign@…
yajl: use github portgroup
04:38 Changeset [89035] by ryandesign@…
multimarkdown: use github portgroup
04:38 Ticket #32921 (multimarkdown: update to 3.5) created by ryandesign@…
[…]
04:33 Ticket #32920 (liblrdf: update to 0.5.0) created by ryandesign@…
Here's a patch that updates liblrdf to 0.5.0, and now uses a distfile …
04:27 Changeset [89034] by ryandesign@…
jake: update to 0.2.10 and fix jake symlink
04:18 Changeset [89033] by ryandesign@…
liblrdf: use github portgroup, thereby fixing livecheck
04:14 Ticket #32919 (arq_restore installs binaries into applications_dir) created by ryandesign@…
arq_restore contains these items: […] These are command-line programs …
04:11 Changeset [89032] by ryandesign@…
arq_restore: use github portgroup
04:02 Changeset [89031] by ryandesign@…
portcheckup: work correctly for ports using *.setup procedures that don't …
03:58 Changeset [89030] by ryandesign@…
youtube-dl: update to 2012.01.08b
03:51 Changeset [89029] by ryandesign@…
portcheckup: script to update a port's version and checksums
03:34 Ticket #32918 (nodejs: build for i386 fails on my x86_64 Mac) created by ryandesign@…
On my x86_64 Mac running Snow Leopard, installing nodejs normally works …
03:29 Changeset [89028] by ryandesign@…
unsort: simplify getting -arch flags
02:13 Changeset [89027] by stromnov@…
py-scientific: fix mpi variant
02:08 Ticket #32917 (clang++ 2.9, 3.0 and 3.1 do not link with the C++ standard library) created by roland@…
The clang++-mp-2.9 compiler from the MacPorts (from port clang-2.9) …
00:09 Changeset [89026] by ryandesign@…
mongodb: use MacPorts snappy instead of bundled version

01/17/12:

23:44 Changeset [89025] by ram@…
science/pylal: new port
22:24 Changeset [89024] by jmr@…
make sure to only add pre-build and post-destroot code once
22:17 GNOME edited by dports@…
remove mention of dbus-launch (diff)
21:32 Changeset [89023] by ryandesign@…
putty: avoid build failure when some conflicting port is installed
21:11 Ticket #32767 (pango install error) closed by ryandesign@…
invalid
20:59 Ticket #32784 (okular: Poppler must be installed with +qt4 and +quartz variants) closed by nicos@…
worksforme: Closing the ticket as it is not a Portfile defect.
19:19 Ticket #32902 (mercurial: hg command not available) closed by ryandesign@…
fixed: It looks like r89021 fixed this. You'll have to force a rebuild of …
18:34 Ticket #32910 (putty 0.62 available) closed by ryandesign@…
fixed: r89022. I also refreshed the patchfile.
18:33 Changeset [89022] by ryandesign@…
putty: update to 0.62; see #32910
18:30 Ticket #32916 (rabbitmq-server: launchctl script does not match created node) created by mbartz@…
I followed the normal port installation procedures and was unable to …
18:00 Changeset [89021] by jmr@…
automatically set python.versions to python.default_version for apps; see …
17:18 Changeset [89020] by ryandesign@…
putty: whitespace changes; add modeline
16:54 Ticket #28642 (py27-bpython) closed by dports@…
fixed: A py27-bpython quietly appeared in r88303.
16:42 Ticket #29409 (Failed to start message bus: launch_msg("CheckIn") IPC failure: Operation ...) closed by dports@…
fixed: Patched gnome-session in r89019.
16:42 Changeset [89019] by dports@…
gnome-session: do not check for a dbus session using the …
15:30 Ticket #32915 (py-clint: use github portgroup) created by ryandesign@…
py-clint could benefit from using the new github portgroup. Attached is a …
14:41 Ticket #32176 (mercurial: missing files) closed by ryandesign@…
worksforme
14:39 Ticket #32912 (mercurial is not available in $PATH) closed by ryandesign@…
duplicate
14:37 Ticket #32907 (tesseract @3.00_2+eng Not using leptonica) closed by ryandesign@…
fixed: This ticket was about tesseract not using leptonica. As I said above, I …
12:16 Ticket #32914 (tin: port update to 2.0.1) created by nefar@…
11:54 Changeset [89018] by ciserlohn@…
npm: update to version 1.1.0-2
10:16 Ticket #32913 (Tesseract 3.01 won't build with automake 1.11.2) created by dersh@…
I am trying to upgrade tesseract 3.00_2 to 3.01_0 and I get a build error: …
08:18 Ticket #32912 (mercurial is not available in $PATH) created by dulmandakh@…
Hello, I'm new to macports, but after installing mercurial there is no hg …
04:28 Ticket #32911 (growl could not be installed on Mac OSX 10.7.3) created by tsingyoung@…
The error message is as bellows: […] Please see log file as well, …
03:32 Changeset [89017] by phw@…
py-clint: upgrade 0.3.0 -> 0.3.1
03:30 Ticket #32910 (putty 0.62 available) created by nano103@…
Hello just changing version to 0.6.2 and checksums in Portfile seems work …
01:38 Changeset [89016] by ryandesign@…
ficl: update to 4.1.0; add universal variant and respect build_arch; …
01:13 Ticket #32895 (valgrind-devel: build failure with automake 1.11.2) closed by raimue@…
fixed: Upstream report: https://bugs.kde.org/show_bug.cgi?id=290719 Fix …
01:12 Changeset [89015] by raimue@…
devel/valgrind-devel: Update to r12339, VEX r2239 Fix build with automake …
00:57 Changeset [89014] by ryandesign@…
ferite: adjust whitespace and formatting; add modeline
00:55 Ticket #32889 (py*-fastimport not in macports, but required by bzr-fastimport) closed by raimue@…
fixed: Thank you for the report! Sorry that I didn't properly test the update. I …
00:54 Changeset [89013] by ryandesign@…
ferite: update to 1.1.17, rewrite homepage and master_sites to avoid …
00:52 Changeset [89012] by raimue@…
devel/bzr-fastimport: Add missing dependency on py27-fastimport, closes …
00:52 Changeset [89011] by raimue@…
python/py-fastimport: Add new port required for bzr-fastimport, see #32889
00:33 Ticket #32909 (php5 5.3.9 Segmentation Fault 11 in call to array_intersect) closed by ryandesign@…
duplicate
00:33 Ticket #31590 (php5-pear: Segmentation fault during installation when php5 is built with ...) closed by ryandesign@…
fixed: Has duplicate #32909. Fixed php5 in r89008, php5-devel in r89009, php54 …
00:33 Changeset [89010] by ryandesign@…
php54: use llvm-gcc-4.2 instead of clang; see #31590
00:30 Changeset [89009] by ryandesign@…
php5-devel: update to 5.3.9 final, update suhosin variant to match, use …
00:28 Changeset [89008] by ryandesign@…
php5: use llvm-gcc-4.2 instead of clang to avoid segfaults; see #31590
Note: See TracTimeline for information about the timeline view.