wiki:MavericksProblems

Mavericks Problems

General Issues

First of all, please read Migration.

Updating MacPorts Base

Versions of MacPorts built on 10.8 or lower will fail to install packages on Mavericks because of a missing /usr/bin/gnutar. The solution to that problem is to re-install MacPorts using the installer for Mavericks. Do not create a symlink named /usr/bin/gnutar pointing to a different version of tar or a version of gnutar you installed using MacPorts or yourself.

Ensure you have at least the command line tools installed by running xcode-select --install from a Terminal. Make sure to also run this even if you have Xcode installed, because you might otherwise see an error message about MacPorts not being able to find Tcl with the next selfupdate. You may have to open the Xcode application to accept a new license even after doing this.

Tickets for Broken Ports

#40958
media tomb does not build on Maverick
#41107
Apache-ivy fails to install on OS X Mavericks
#41202
qtiplot @0.9.8.9_7 crashes with segmentation fault: 11
#41241
vxl fails to build on OS X 10.9 Mavericks
#41252
mysql-connector-java fails build on OSX Mavericks
#41282
wine: Assertion failed at address 0x000b:0x9938f952 (thread 0009), starting debugger...
#41292
libvmime @0.9.1_1: error: unknown type name 'pthread_mutex_t'
#41378
Installing subversion-javahlbindings (1.8.4) fails on OS X 10.9
#41431
kdenlive fails to run on 10.9 if gavl is installed
#41687
gcc48 @4.8.2 fortran does not work
#41744
herrie @2.2_0: Error: some dependencies are missing <spiff/spiff_c.h>
#42061
mysql5: uses /usr/lib/libstdc++.6.dylib as C++ standard library although macports::cxx_stdlib is set to libc++
#42739
zenity on Maverics errors with GTK-warning cannot open display
#45681
libgcc @4.9.2: build fails with 10 parallel jobs
#55198
ffmpeg @3.4: ld: cannot link directly with /System/Library/Frameworks//CoreImage.framework/CoreImage
#55888
go @1.10: Assertion failed: (ref_addr_die != NULL), function AppendDependants
#55915
mariadb-10.2 @10.2.12: clang: error: unknown argument: '-fwhole-program'
#55920
FreeRDP @2.0.0-rc1: error: unknown type name 'AudioFormatID'
#58592
go @1.12.5: Undefined symbols _fstatat64 _openat _unlinkat
#60477
stack @2.3.1_0: Undefined symbols: _utimensat
#60650
osquery @4.3.0: error: use of undeclared identifier '_SC_PHYS_PAGES'
#60769
svn2git @1.0.18: error: Qt requires a C++11 compiler and yours does not seem to be that.
#61076
wxWidgets-3.2 @3.1.4: error: use of undeclared identifier 'LSCopyDefaultApplicationURLForContentType'
#62455
pngpaste: error: use of undeclared identifier 'NSBitmapImageFileTypeGIF'
#62964
QT 5.9: Add Mavericks Compatibility
#64195
ngs: malloc.c:22:87: error: use of undeclared identifier 'MAP_ANONYMOUS'
#64280
onetbb @2021.5.0: error: declaration does not declare anything
#64658
zig @0.9.0 undefined symbols __availability_version_check, _fstatat$INODE64
#64666
dtrace @370.40.1 build failure: 'sys/elf.h' file not found
#64667
mpv @0.34.1 Build failed: -> task in 'objects' failed with exit status 1:
#65148
py310-cryptography: error: linking with `cc` failed: exit status: 1
#65163
llvm-14 @14.0.3+universal: error: no matching function for call to 'min'

#45965
mt-daapd not compiling on Mavericks 10.10
#46626
slatec @4.1_0+gcc49 Mavericks Slatec Linking Error
#57474
bladeRF @20181024_1 fails to build on Mavericks
#58486
go-tools @d1a3278ee74994e9aa609e9e711c616bba677d5d fails to build on mavericks

Last modified 5 years ago Last modified on Sep 27, 2017, 3:31:02 PM