New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #11180 (closed defect: worksforme)

Opened 7 years ago

Last modified 5 years ago

commons-logging BUILD FAILED

Reported by: pierre_auclair@… Owned by: jberry@…
Priority: Normal Milestone:
Component: ports Version: 1.1
Keywords: commons-logging, tomcat5 Cc: jberry@…
Port:

Description

while trying to install tomcat5 (sudo port install tomcat5) I have a BUILD FAILED while building commons-logging.

--->  Building commons-logging with target all
Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_java_commons-logging/work/commons-logging-1.1-src" && ant all -Dlog4j12.jar=/opt/local/share/java/jakarta-log4j.jar -Dlogkit.jar=NONE -Davalon-framework.jar=NONE -Dservletapi.jar=/opt/local/share/java/servlet23-api.jar" returned error 1
Command output:     [junit]     at org.apache.tools.ant.taskdefs.optional.junit.JUnitTestRunner.main(JUnitTestRunner.java:743)
    [junit] 
    [junit] ------------- ---------------- ---------------
    [junit] Testsuite: org.apache.commons.logging.simple.DefaultConfigTestCase
    [junit] Tests run: 4, Failures: 0, Errors: 0, Time elapsed: 0.023 sec
    [junit] 
    [junit] Testsuite: org.apache.commons.logging.tccl.BadTCCLTestCase
    [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.001 sec
    [junit] 
    [junit] Testsuite: org.apache.commons.logging.tccl.NullTCCLTestCase
    [junit] Tests run: 1, Failures: 0, Errors: 0, Time elapsed: 0.002 sec
    [junit] 
    [junit] Testsuite: org.apache.commons.logging.tccl.log.TcclDisabledTestCase
    [junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.038 sec
    [junit] 
    [junit] Testsuite: org.apache.commons.logging.tccl.log.TcclEnabledTestCase
    [junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.016 sec
    [junit] 
    [junit] Testsuite: org.apache.commons.logging.tccl.logfactory.TcclDisabledTestCase
    [junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.009 sec
    [junit] 
    [junit] Testsuite: org.apache.commons.logging.tccl.logfactory.TcclEnabledTestCase
    [junit] Tests run: 2, Failures: 0, Errors: 0, Time elapsed: 0.012 sec
    [junit] 
    [junit] Tests FAILED

BUILD FAILED
/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_java_commons-logging/work/commons-logging-1.1-src/build.xml:771: One or more unit tests failed.

Total time: 7 seconds

Error: Status 1 encountered during processing.

Looking at BUG#10903, I installed servlet23-api successfully, but problem remains.

Change History

comment:1 Changed 7 years ago by pguyot@…

  • Owner changed from macports-dev@… to jberry@…

comment:2 Changed 7 years ago by markd@…

  • Cc jberry@… added

Ping maintainer, since I think emails don't go out on assignment.

comment:3 Changed 7 years ago by jberry@…

  • Status changed from new to closed
  • Resolution set to worksforme

I haven't seen any other reports of this problem, and don't see any errors in the test results displayed. Are there any other reports of this issue? commons-logging builds fine for me.

comment:4 follow-up: ↓ 5 Changed 6 years ago by seth_macports@…

FWIW, I believe I have found the source of this problem, and it is the result of an interaction with another port, jakarta-log4j (which happens to be a prerequisite for the mysql jdbc adaptor, which is how I ran into this problem as well). The necessity of this additional vector is likely why jberry@ was unable to reproduce this issue. I've filed a more specific bug with the details: r13869

comment:5 in reply to: ↑ 4 Changed 6 years ago by seth_macports@…

Sorry, that's ticket #13869 not the entirely unrelated changeset with that number.

comment:6 Changed 6 years ago by jmpp@…

  • Priority changed from High to Normal
  • Milestone set to Port Bugs

comment:7 Changed 5 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.