New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #12566 (closed defect: duplicate)

Opened 7 years ago

Last modified 5 years ago

gtk2 +quartz fails to build

Reported by: nox@… Owned by: rhwood@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: Cc: rhwood@…, nox@…
Port:

Description

 gcc -DHAVE_CONFIG_H -I. -I. -I../.. -DG_LOG_DOMAIN=\"Gdk\" -DGDK_COMPILATION -I../.. -I../../gdk -I../../gdk -DGDK_PIXBUF_DISABLE_DEPRECATED -DGDK_DISABLE_DEPRECATED -DG_DISABLE_CAST_CHECKS -D_REENTRANT -DXTHREADS -I/opt/local/include/glib-2.0 -I/opt/local/lib/glib-2.0/include -I/opt/local/include -I/opt/local/include/pango-1.0 -I/opt/local/include/cairo -I/opt/local/include/freetype2 -I/opt/local/include/libpng12 -I/usr/X11R6/include -xobjective-c -I/opt/local/include -no-cpp-precomp -DX_LOCALE -I/usr/X11R6/include -MT gdkdrawable-quartz.lo -MD -MP -MF .deps/gdkdrawable-quartz.Tpo -c gdkdrawable-quartz.c  -fno-common -DPIC -o .libs/gdkdrawable-quartz.o
gdkdrawable-quartz.c: In function 'gdk_quartz_ref_cairo_surface':
gdkdrawable-quartz.c:64: error: incompatible type for argument 1 of 'cairo_quartz_surface_create'
gdkdrawable-quartz.c:64: error: too many arguments to function 'cairo_quartz_surface_create'
make[4]: *** [gdkdrawable-quartz.lo] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

The Cairo Quartz API has changed.

Attachments

patch-gdk-quartz-gdkdrawable-quartz.c (446 bytes) - added by nox@… 7 years ago.

Change History

Changed 7 years ago by nox@…

comment:1 Changed 7 years ago by nox@…

Oh. This is a duplicate of #11745. Sorry.

comment:2 Changed 7 years ago by rhwood@…

  • Status changed from new to closed
  • Resolution set to duplicate

Closed. Duplicates ticket:11745

comment:3 Changed 5 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.