New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #17075 (closed defect: invalid)

Opened 6 years ago

Last modified 5 years ago

Environment Variables will not save in X11

Reported by: darmish@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

I have macports running fine, in terminal the env variables stay the same all the time. But, using X11 my env variables changes after every session is complete. I've added:

export PATH=/opt/local/bin:/opt/local/sbin:$PATH export DISPLAY=:0.0 export EDITOR=/usr/bin/vim

to .profile

Change History

comment:1 follow-up: ↓ 2 Changed 6 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to invalid

This is not a MacPorts issue. Maybe your Terminal.app is set to use a different shell than login(1). There are no doubt many tutorials on changing and/or configuring your shell available on the web. Or perhaps you need to take this up with your X11 vendor (i.e. Apple), perhaps via http://xquartz.macosforge.org/trac/.

comment:2 in reply to: ↑ 1 ; follow-up: ↓ 3 Changed 6 years ago by darmish@…

Thanks for your speedy reply,

Technically it is a macports issue due to I can't use it(macports) correctly after using the install instructions(line x line). I knew it appear to be a basic question but nonetheless it's an issue, that I've researched again & again with no success. So, I thought I'd post it here to get help for someone who has had the same or similar results or who could just advise.

Thanx

Btw, I even went into the irc channel no one there

comment:3 in reply to: ↑ 2 Changed 6 years ago by blb@…

Replying to darmish@…:

Technically it is a macports issue due to I can't use it(macports) correctly after using the install instructions(line x line).

In the initial description, you said "I have macports running fine..." so it's tough to figure out exactly what the problem is then. Can you demonstrate, specifically, what you're trying to do, and what the results are?

Btw, I even went into the irc channel no one there

There are people there, however it can get quiet at times; just ask the question and, usually, there should be some response (though do wait more than a few minutes).

comment:4 Changed 6 years ago by jmr@…

Feel free to ask for help on the macports-users mailing list as well, but Trac tickets are for reporting bugs (in MacPorts) and contributing enhancements, not tech support.

comment:5 Changed 5 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.