New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #21778 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

vpnc-0.5.3 does not have tuntap-20080804 as a dependency

Reported by: carpeneto@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: Cc: msmk@…
Port: vpnc

Description (last modified by macsforever2000@…) (diff)

Minor quibble - if I install vpnc-0.5.3 it would be nice if it realized tun/tap was a dep for me - would have saved a bit of sleuthing on my part ...

ticket:13609 states the dep is there.

Attachments

vpnc-Portfile.diff (993 bytes) - added by kiehn@… 5 years ago.
Adding tuntaposx as a dependency

Change History

comment:1 Changed 5 years ago by blb@…

  • Keywords vpnc removed
  • Owner changed from macports-tickets@… to kiehn@…

Does the port tuntaposx satisfy this, or does it require something installed outside of MacPorts?

comment:2 Changed 5 years ago by carpeneto@…

tuntaposx does indeed make all things good

Changed 5 years ago by kiehn@…

Adding tuntaposx as a dependency

comment:3 follow-up: ↓ 5 Changed 5 years ago by kiehn@…

I created a quick patch to add tuntaposx as a dependency and remove the relevant part in the description.

The problem is that I could not test this because the current version of tuntaposx does not build on Leopard (see http://trac.macports.org/ticket/21762). Changing this right now would mean that we intentionally break vpnc.

I think we should wait until the issue with tuntaposx is resolved.

comment:4 Changed 5 years ago by macsforever2000@…

  • Description modified (diff)

comment:5 in reply to: ↑ 3 Changed 4 years ago by f_koch@…

Replying to kiehn@…:

I created a quick patch to add tuntaposx as a dependency and remove the relevant part in the description.

The problem is that I could not test this because the current version of tuntaposx does not build on Leopard (see http://trac.macports.org/ticket/21762). Changing this right now would mean that we intentionally break vpnc.

I think we should wait until the issue with tuntaposx is resolved.

about a few minutes ago I build vpnc and tuntaposx on Max OSX 10.6.1 without any problems, it works fine

comment:6 Changed 4 years ago by jmr@…

  • Owner changed from kiehn@… to msmk@…

comment:7 Changed 4 years ago by jmr@…

  • Keywords tuntap removed
  • Owner changed from msmk@… to macports-tickets@…
  • Cc msmk@… added

comment:8 Changed 3 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to fixed

Committed in r74683.

Note: See TracTickets for help on using tickets.