New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #21954 (closed defect: duplicate)

Opened 5 years ago

Last modified 5 years ago

pango doesn't build with a symbol(s) not found error on Snow Leopard 10.6.1

Reported by: macports@… Owned by: ryandesign@…
Priority: Normal Milestone:
Component: ports Version: 1.8.1
Keywords: snowleopard Cc: jryan2002de@…
Port: pango

Description

when tring to compile the latest pango version on snow leopard I get the following error:

--->  Computing dependencies for pango
--->  Fetching pango
--->  Verifying checksum(s) for pango
--->  Extracting pango
--->  Applying patches to pango
--->  Configuring pango
--->  Building pango
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_pango/work/pango-1.24.5" && /usr/bin/make -j2 all " returned error 2
Command output: libtool: link: mv -f ".libs/libpangoft2-1.0.expT" ".libs/libpangoft2-1.0.exp"
libtool: link: (cd .libs/libpangoft2-1.0.lax/libharfbuzz-1.a && ar x "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_pango/work/pango-1.24.5/pango/opentype/.libs/libharfbuzz-1.a")
libtool: link: sed 's,^,_,' < .libs/libpangoft2-1.0.exp > .libs/libpangoft2-1.0-symbols.expsym
libtool: link: /usr/bin/gcc-4.2 -dynamiclib  -o .libs/libpangoft2-1.0.0.dylib  .libs/pangofc-font.o .libs/pangofc-fontmap.o .libs/pangofc-decoder.o .libs/pangoft2.o .libs/module-defs-fc.o .libs/pangoft2-fontmap.o .libs/pangoft2-render.o .libs/pango-ot-buffer.o .libs/pango-ot-info.o .libs/pango-ot-ruleset.o .libs/pango-ot-tag.o   .libs/libpangoft2-1.0.lax/libharfbuzz-1.a/harfbuzz.o   -L/opt/local/lib ./.libs/libpango-1.0.dylib /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libgmodule-2.0.dylib /opt/local/lib/libglib-2.0.dylib -lresolv /opt/local/lib/libintl.dylib -lc /opt/local/lib/libfontconfig.dylib /opt/local/lib/libexpat.dylib /opt/local/lib/libfreetype.dylib -lz /opt/local/lib/libiconv.dylib -lm  -arch x86_64   -framework Carbon -install_name  /opt/local/lib/libpangoft2-1.0.0.dylib -compatibility_version 2401 -current_version 2401.5 -Wl,-single_module -Wl,-exported_symbols_list,.libs/libpangoft2-1.0-symbols.expsym
libtool: link: dsymutil .libs/libpangoft2-1.0.0.dylib || :
warning: no debug symbols in executable (-arch x86_64)
libtool: link: (cd ".libs" && rm -f "libpangoft2-1.0.dylib" && ln -s "libpangoft2-1.0.0.dylib" "libpangoft2-1.0.dylib")
libtool: link: (cd .libs/libpangoft2-1.0.lax/lt1-libharfbuzz-1.a && ar x "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_pango/work/pango-1.24.5/pango/opentype/.libs/libharfbuzz-1.a")
libtool: link: ar cru .libs/libpangoft2-1.0.a  pangofc-font.o pangofc-fontmap.o pangofc-decoder.o pangoft2.o module-defs-fc.o pangoft2-fontmap.o pangoft2-render.o pango-ot-buffer.o pango-ot-info.o pango-ot-ruleset.o pango-ot-tag.o  .libs/libpangoft2-1.0.lax/lt1-libharfbuzz-1.a/harfbuzz.o 
libtool: link: ranlib .libs/libpangoft2-1.0.a
libtool: link: rm -fr .libs/libpangoft2-1.0.lax .libs/libpangoft2-1.0.lax
libtool: link: ( cd ".libs" && rm -f "libpangoft2-1.0.la" && ln -s "../libpangoft2-1.0.la" "libpangoft2-1.0.la" )
/bin/sh ../libtool --tag=CC   --mode=link /usr/bin/gcc-4.2 -xobjective-c -O2 -arch x86_64 -Wall -version-info 2400:5:2400 -export-symbols-regex "^pango_.*"  -framework CoreFoundation -framework Carbon -framework Cocoa -L/opt/local/lib -no-undefined -bind_at_load -o libpangocairo-1.0.la -rpath /opt/local/lib libpangocairo_1_0_la-pangocairo-context.lo libpangocairo_1_0_la-pangocairo-font.lo libpangocairo_1_0_la-pangocairo-fontmap.lo libpangocairo_1_0_la-pangocairo-render.lo  libpangocairo_1_0_la-pangocairo-fcfont.lo libpangocairo_1_0_la-pangocairo-fcfontmap.lo libpangocairo_1_0_la-module-defs-atsui.lo libpangocairo_1_0_la-pangoatsui.lo libpangocairo_1_0_la-pangoatsui-fontmap.lo libpangocairo_1_0_la-pangocairo-atsuifont.lo libpangocairo_1_0_la-pangocairo-atsuifontmap.lo libpango-1.0.la -L/opt/local/lib -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv   -L/opt/local/lib -lcairo -lpixman-1 -lfontconfig -lexpat -lfreetype -liconv -lpng12 -lz   -lm  libpangoft2-1.0.la -L/opt/local/lib -lfreetype -lz   -L/opt/local/lib -lfontconfig -lexpat -lfreetype -lz -liconv    
/bin/sh ../libtool --tag=CC   --mode=link /usr/bin/gcc-4.2  -O2 -arch x86_64 -Wall  -L/opt/local/lib -no-undefined -bind_at_load -o pango-querymodules querymodules.o   libpangoft2-1.0.la  libpango-1.0.la -L/opt/local/lib -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -lintl -liconv   
libtool: link: /usr/bin/gcc-4.2 -O2 -arch x86_64 -Wall -bind_at_load -o .libs/pango-querymodules querymodules.o  -L/opt/local/lib ./.libs/libpangoft2-1.0.dylib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_pango/work/pango-1.24.5/pango/.libs/libpango-1.0.dylib /opt/local/lib/libfontconfig.dylib /opt/local/lib/libexpat.dylib /opt/local/lib/libfreetype.dylib -lz ./.libs/libpango-1.0.dylib -lm /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libgmodule-2.0.dylib /opt/local/lib/libglib-2.0.dylib -lresolv /opt/local/lib/libintl.dylib -lc /opt/local/lib/libiconv.dylib -framework Carbon
libtool: link: /usr/bin/nm  .libs/libpangocairo_1_0_la-pangocairo-context.o .libs/libpangocairo_1_0_la-pangocairo-font.o .libs/libpangocairo_1_0_la-pangocairo-fontmap.o .libs/libpangocairo_1_0_la-pangocairo-render.o .libs/libpangocairo_1_0_la-pangocairo-fcfont.o .libs/libpangocairo_1_0_la-pangocairo-fcfontmap.o .libs/libpangocairo_1_0_la-module-defs-atsui.o .libs/libpangocairo_1_0_la-pangoatsui.o .libs/libpangocairo_1_0_la-pangoatsui-fontmap.o .libs/libpangocairo_1_0_la-pangocairo-atsuifont.o .libs/libpangocairo_1_0_la-pangocairo-atsuifontmap.o   | sed -n -e 's/^.*[	 ]\([BCDEGRST][BCDEGRST]*\)[	 ][	 ]*_\([_A-Za-z][_A-Za-z0-9]*\)$/\1 _\2 \2/p' | /usr/bin/sed 's/.* //' | sort | uniq > .libs/libpangocairo-1.0.exp
libtool: link: /usr/bin/grep -E -e "^pango_.*" ".libs/libpangocairo-1.0.exp" > ".libs/libpangocairo-1.0.expT"
libtool: link: mv -f ".libs/libpangocairo-1.0.expT" ".libs/libpangocairo-1.0.exp"
libtool: link: sed 's,^,_,' < .libs/libpangocairo-1.0.exp > .libs/libpangocairo-1.0-symbols.expsym
libtool: link: /usr/bin/gcc-4.2 -dynamiclib  -o .libs/libpangocairo-1.0.0.dylib  .libs/libpangocairo_1_0_la-pangocairo-context.o .libs/libpangocairo_1_0_la-pangocairo-font.o .libs/libpangocairo_1_0_la-pangocairo-fontmap.o .libs/libpangocairo_1_0_la-pangocairo-render.o .libs/libpangocairo_1_0_la-pangocairo-fcfont.o .libs/libpangocairo_1_0_la-pangocairo-fcfontmap.o .libs/libpangocairo_1_0_la-module-defs-atsui.o .libs/libpangocairo_1_0_la-pangoatsui.o .libs/libpangocairo_1_0_la-pangoatsui-fontmap.o .libs/libpangocairo_1_0_la-pangocairo-atsuifont.o .libs/libpangocairo_1_0_la-pangocairo-atsuifontmap.o   -framework CoreFoundation -framework Carbon -framework Cocoa -L/opt/local/lib ./.libs/libpango-1.0.dylib /opt/local/lib/libcairo.dylib /opt/local/lib/libpixman-1.dylib /opt/local/lib/libpng12.dylib ./.libs/libpangoft2-1.0.dylib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_pango/work/pango-1.24.5/pango/.libs/libpango-1.0.dylib /opt/local/lib/libgobject-2.0.dylib /opt/local/lib/libgmodule-2.0.dylib /opt/local/lib/libglib-2.0.dylib -lresolv /opt/local/lib/libintl.dylib -lc -lm /opt/local/lib/libfontconfig.dylib /opt/local/lib/libexpat.dylib /opt/local/lib/libfreetype.dylib -lz /opt/local/lib/libiconv.dylib  -arch x86_64 -Wl,-dylib_file -Wl,/opt/local/lib/libpango-1.0.0.dylib:/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_x11_pango/work/pango-1.24.5/pango/.libs/libpango-1.0.dylib   -framework CoreFoundation -framework Carbon -framework Cocoa -install_name  /opt/local/lib/libpangocairo-1.0.0.dylib -compatibility_version 2401 -current_version 2401.5 -Wl,-single_module -Wl,-exported_symbols_list,.libs/libpangocairo-1.0-symbols.expsym
Undefined symbols:
  "_cairo_quartz_font_face_create_for_atsu_font_id", referenced from:
      _pango_cairo_atsui_font_create_font_face in libpangocairo_1_0_la-pangocairo-atsuifont.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[4]: *** [libpangocairo-1.0.la] Error 1
make[3]: *** [all-recursive] Error 1
make[2]: *** [all] Error 2
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: Unable to upgrade port: 1

please don't hesitate to require more info

Change History

comment:1 Changed 5 years ago by blb@…

  • Owner changed from macports-tickets@… to ryandesign@…
  • Keywords snowleopard added; pango, snow lepard removed

Are you using the +quartz variant? If so, dup of #17049 I believe.

comment:2 Changed 5 years ago by macports@…

yes maybe I opened another bug 'couse 1.6.0 is marked in that ticket but I didn't se it wasn't closed

comment:3 Changed 5 years ago by jryan2002de@…

  • Cc jryan2002de@… added

Cc Me!

comment:4 Changed 5 years ago by ryandesign@…

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #17049.

Note: See TracTickets for help on using tickets.