New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #24143 (closed defect: fixed)

Opened 5 years ago

Last modified 3 years ago

ELinks 0.11.5 - won't load some pages

Reported by: ryan.wy.chan@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: expiation@…
Port: elinks

Description

Performed a selfupdate and now elinks will not load some pages (it used to work before the selfupdate). I can load google.com but if I try to connect to dpreview.com or hotmail.com I get an "unable to retrieve <website address>" "Error Reading from socket"

I tried loading dpreview.com and hotmail.com from Links and it works fine. Works fine using Safari as well.

Read a similar complaint online where the fix was to toggle the async.dns option, but this did not work for me.

Using a late 2008 MBP, OS X 10.6.2 if that helps.

Change History

comment:1 Changed 5 years ago by macsforever2000@…

  • Keywords elinks, webpage doesn't load, 0.11.5, async.dns removed
  • Cc ryan.wy.chan@… removed
  • Port changed from ELinks 0.11.5 to elinks
  • Owner changed from macports-tickets@… to simon@…

comment:2 Changed 4 years ago by rmsfisher@…

I get the same behavior when running 'elinks macports.org' but can browse to macports.org in Firefox.

comment:3 Changed 4 years ago by joerg@…

The problem is related to zlib version. It appears with zlib @1.2.4_1 and zlib @1.2.5_0 . It does not appear with zlib @1.2.3_4

comment:4 Changed 4 years ago by simon@…

  • Owner changed from simon@… to macports-tickets@…

comment:5 Changed 4 years ago by expiation@…

  • Cc expiation@… added

Cc Me!

comment:6 Changed 4 years ago by expiation@…

What's the likely resolution here? It seems to affect all the elinks versions up to the current 0.11.7 and affects a very large number of sites. Is it something specific to the zlib we have in Macports or something upstream?

For those wanting to work around this for the time being, go back to your old version of zlib (see http://trac.macports.org/wiki/howto/InstallingOlderPort)

comment:7 Changed 4 years ago by perry@…

You can also use the port elinks-devel. elinks macports.org works for me.

The following ports are currently installed:
  elinks-devel @0.12pre5_1+universal (active)
  zlib @1.2.5_0+universal (active)

comment:8 Changed 4 years ago by perry@…

Also note that this version is older than upstream, which is at 0.11.7. Updating the port might fix the problem.

comment:9 Changed 3 years ago by jmr@…

  • Status changed from new to closed
  • Resolution set to fixed
Note: See TracTickets for help on using tickets.