New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #26960 (closed defect: fixed)

Opened 4 years ago

Last modified 4 years ago

qtiplot 0.9.8.3_0 fails patch phase

Reported by: anatuss@… Owned by: jonas@…
Priority: Normal Milestone:
Component: ports Version: 1.9.1
Keywords: Cc: diegotheblind@…, mayace.cysque@…, nicos_pavlov@…, soehn@…, Stochasticus@…, a2piratesoft@…, bgschaid@…, michaelld@…
Port: qtiplot

Description

Hi, I've tried to upgrade qtiplot from 9.7.12 to 9.8.3 yesterday, resulting in failure and destruction of the current version. It was build, well, actually intended to build, on Mac OS X 10.6.4 with macports 1.9.1. Since noone hasn't posted it yet, it's worth to mention.

Cheers, anatuss

DEBUG: Skipping completed org.macports.fetch (qtiplot)
DEBUG: Skipping completed org.macports.checksum (qtiplot)
DEBUG: setting option extract.cmd to /usr/bin/bzip2
DEBUG: Skipping completed org.macports.extract (qtiplot)
DEBUG: patch phase started at Sat Oct 23 03:35:39 CEST 2010
DEBUG: Executing org.macports.patch (qtiplot)
--->  Applying patches to qtiplot
--->  Applying /opt/local/var/macports/sources/rsync.macports.org/release/ports/aqua/qtiplot/files/patch-qtiplot-qtiplot.pro
DEBUG: Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qtiplot/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
DEBUG: Assembled command: 'cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qtiplot/work/qtiplot-0.9.8.3" && /usr/bin/patch -p0'
patching file qtiplot/qtiplot.pro
Hunk #1 FAILED at 1.
Hunk #2 FAILED at 32.
Hunk #3 FAILED at 94.
Hunk #4 FAILED at 138.
Hunk #5 FAILED at 176.
5 out of 5 hunks FAILED -- saving rejects to file qtiplot/qtiplot.pro.rej
shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qtiplot/work/qtiplot-0.9.8.3" && /usr/bin/patch -p0 < '/opt/local/var/macports/sources/rsync.macports.org/release/ports/aqua/qtiplot/files/patch-qtiplot-qtiplot.pro'" returned error 1
Error: Target org.macports.patch returned: shell command failed
DEBUG: Backtrace: shell command failed
    while executing
"command_exec patch "" "< '$patch'""
    (procedure "portpatch::patch_main" line 33)
    invoked from within
"$procedure $targetname"
Warning: the following items did not execute (for qtiplot): org.macports.destroot org.macports.patch org.macports.configure org.macports.build
Log for qtiplot is at: /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_aqua_qtiplot/main.log
DEBUG: couldn't open "/System/Library/Frameworks/Tcl.framework/Versions/8.5/Resources/tclIndex": no such file or directory
    while executing
"open [file join $dir tclIndex]"
Error: Unable to upgrade port: 1
To report a bug, see <http://guide.macports.org/#project.tickets>

Attachments

patch-Portfile-qtiplot.diff (4.3 KB) - added by nicos_pavlov@… 4 years ago.
patch-importOPJ.cpp.diff (459 bytes) - added by nicos_pavlov@… 4 years ago.
Portfile-treehh (1.3 KB) - added by nicos_pavlov@… 4 years ago.
patch2-Portfile.diff (4.6 KB) - added by nicos_pavlov@… 4 years ago.
patch-ApplicationWindow.diff (1.5 KB) - added by nicos_pavlov@… 4 years ago.

Change History

comment:1 Changed 4 years ago by ryandesign@…

  • Owner changed from macports-tickets@… to jonas@…
  • Keywords qtiplot 0.9.8.3_0 removed
  • Port set to qtiplot
  • Summary changed from qtiplot 0.9.8.3_0 failed to patch and install to qtiplot 0.9.8.3_0 fails patch phase

Assigning to maintainer.

comment:2 Changed 4 years ago by diegotheblind@…

  • Cc diegotheblind@… added

Cc Me!

comment:3 follow-up: ↓ 7 Changed 4 years ago by nicos_pavlov@…

It seems that the port was upgraded, but the patches were kept, although they are not valid anymore. I did some digging, and found that some dependencies were also missing, such as QTeXEngine, which is required during compilation.

I made a port which seems to work in my case, in which I also added support for originlab files, which is now in a separate library. This however requires a header for which I had to make another port.

Finally, there is no support for Excel sheets in this version. The library employed is working fine, but it needs to be downloaded from a repository where a login is required (CodeProject). Would someone know if it is possible to download packages automatically for Macports from there ?

Changed 4 years ago by nicos_pavlov@…

Changed 4 years ago by nicos_pavlov@…

Changed 4 years ago by nicos_pavlov@…

comment:4 Changed 4 years ago by mayace.cysque@…

  • Cc mayace.cysque@… added

Cc Me!

comment:5 Changed 4 years ago by nicos_pavlov@…

  • Cc nicos_pavlov@… added

Cc Me!

comment:6 Changed 4 years ago by soehn@…

  • Cc soehn@… added

Cc Me!

comment:7 in reply to: ↑ 3 Changed 4 years ago by wlmcderm@…

I ran into the same problem as the original report while trying to install qtiplot0.9.8.3 de novo using macports1.9.1 with a mac running osx10.5.8. Any word on when the port of qtiplot will be upgraded to allow installation?

Thanks for all the work in sorting this out.

Replying to nicos_pavlov@…:

It seems that the port was upgraded, but the patches were kept, although they are not valid anymore. I did some digging, and found that some dependencies were also missing, such as QTeXEngine, which is required during compilation.

I made a port which seems to work in my case, in which I also added support for originlab files, which is now in a separate library. This however requires a header for which I had to make another port.

Finally, there is no support for Excel sheets in this version. The library employed is working fine, but it needs to be downloaded from a repository where a login is required (CodeProject). Would someone know if it is possible to download packages automatically for Macports from there ?

comment:8 Changed 4 years ago by nicos_pavlov@…

The problem is that the patches I submitted are not valid anymore, with the upgrade of qt to 4.7. Qtiplot uses deprecated code, which has to be installed as a separate package.
See http://labs.qt.nokia.com/2010/06/22/qt-assistant-compat-version-available-as-extra-source-package/

I tested the package, but could not make it possible yet to link to the dynamic libraries generated by qtassistant.

comment:9 Changed 4 years ago by Stochasticus@…

  • Cc Stochasticus@… added

Cc Me!

comment:10 Changed 4 years ago by a2piratesoft@…

  • Cc a2piratesoft@… added

Cc Me!

comment:11 Changed 4 years ago by nicos_pavlov@…

This consists essentially in a hack, but I noticed that qtiplot makes only a small usage of the deprecated code from Qt4.7, corresponding to help files if I am not mistaken. This code can thus be commented out easily to ensure compilation.
The attached patch should work, where the derived products employed for qtiplot are enclosed in the Portfile. A variant for reading OriginLab project should also work.
Therefore, to compile, one needs the patch2-Portfile and the patch-ApplicationWindow.diff file. If one wants to use the origin variant, the patch-importOPJ.cpp.diff and the portfile treehh are also required.

Changed 4 years ago by nicos_pavlov@…

Changed 4 years ago by nicos_pavlov@…

comment:12 Changed 4 years ago by anatuss@…

It does work out using your patches. Thanks a lot. However, I wonder, why I can not use the data reader etc. anymore. Is this because of the compilation or due to the recent donation stuff?

comment:13 Changed 4 years ago by anatuss@…

Well, if you're typing cmd+'+', the features are enable once again.

comment:14 Changed 4 years ago by diegotheblind@…

I'm sorry for asking, but from what I understand, this issue seems resolved, although in a non-conventional way; in this case, is it possible to update this port, or is something still missing (I'm thinking about the Qt problem)?

comment:15 Changed 4 years ago by bgschaid@…

  • Cc bgschaid@… added

Cc Me!

comment:16 Changed 4 years ago by macsforever2000@…

  • Status changed from new to closed
  • Resolution set to fixed

comment:17 Changed 4 years ago by macsforever2000@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:18 Changed 4 years ago by macsforever2000@…

  • Status changed from reopened to closed
  • Resolution set to fixed

Added treehh in r76860.

comment:19 Changed 4 years ago by macsforever2000@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

comment:20 Changed 4 years ago by macsforever2000@…

Added patch-importOPJ.cpp.diff in r78026. But now i see an error with the +origin variant that uses it:

:info:patch --->  Applying /opt/mports/trunk/dports/aqua/qtiplot/files/patch-importOPJ.cpp.diff
:debug:patch Environment: CPATH='/opt/local/include' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/.CC_PRINT_OPTIONS' LIBRARY_PATH='/opt/local/lib' CC_PRINT_OPTIONS='YES' MACOSX_DEPLOYMENT_TARGET='10.6'
:debug:patch Assembled command: 'cd "/opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3" && /usr/bin/patch -p0'
:info:patch patching file qtiplot/src/origin/importOPJ.cpp
:debug:patch Privilege de-escalation not attempted as not running as root.
:notice:patch --->  Configuring qtiplot
:debug:patch Using compiler 'Mac OS X gcc 4.2'
:debug:configure configure phase started at Tue Apr 19 21:51:04 MDT 2011
:debug:configure Executing proc-pre-org.macports.configure-configure-0
:debug:configure euid/egid changed to: 0/0
:debug:configure chowned /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot.pro to nobody
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure setting attributes on /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot.pro
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure chowned /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot/src/core/ApplicationWindow.cpp to nobody
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure setting attributes on /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot/src/core/ApplicationWindow.cpp
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure chowned /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot/qtiplotrc.py to nobody
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure setting attributes on /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot/qtiplotrc.py
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure chowned /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/3rdparty/liborigin2/liborigin2.pro to nobody
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure setting attributes on /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/3rdparty/liborigin2/liborigin2.pro
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure chowned /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/3rdparty/liborigin2/liborigin2.pro to nobody
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure setting attributes on /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/3rdparty/liborigin2/liborigin2.pro
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure chowned /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot/src/origin/origin.pri to nobody
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure setting attributes on /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot/src/origin/origin.pri
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure chowned /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot.pro to nobody
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure setting attributes on /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot.pro
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure chowned /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot.pro to nobody
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure setting attributes on /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot.pro
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure chowned /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot/qtiplot.pro to nobody
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure euid/egid changed to: 0/0
:debug:configure setting attributes on /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot/qtiplot.pro
:debug:configure euid/egid changed to: 4294967294/4294967294
:debug:configure Executing org.macports.configure (qtiplot)
:debug:configure Environment: CPATH='/opt/local/include' CFLAGS='-pipe -O2 -arch x86_64' CPPFLAGS='-I/opt/local/include' CXXFLAGS='-pipe -O2 -arch x86_64' LIBRARY_PATH='/opt/local/lib' MACOSX_DEPLOYMENT_TARGET='10.6' PKG_CONFIG_PATH='/opt/local/lib/pkgconfig' CXX='/usr/bin/g++-4.2' CC_PRINT_OPTIONS_FILE='/opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/.CC_PRINT_OPTIONS' F90FLAGS='-pipe -O2 -m64' LDFLAGS='-L/opt/local/lib -arch x86_64' FCFLAGS='-pipe -O2 -m64' OBJC='/usr/bin/gcc-4.2' INSTALL='/usr/bin/install -c' MOC='/opt/local/bin/moc' FFLAGS='-pipe -O2 -m64' OBJCFLAGS='-pipe -O2 -arch x86_64' QTDIR='/opt/local' CC_PRINT_OPTIONS='YES' CC='/usr/bin/gcc-4.2' QMAKE='/opt/local/bin/qmake'
:debug:configure Assembled command: 'cd "/opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3" && LOCALSOFT=/opt/local /opt/local/bin/qmake PREFIX=/opt/local'
:info:configure QMAKESPEC has not been set, so configuration cannot be deduced.
:info:configure Error processing project file: /opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3/qtiplot.pro
:info:configure shell command " cd "/opt/local/var/macports/build/_opt_mports_trunk_dports_aqua_qtiplot/work/qtiplot-0.9.8.3" && LOCALSOFT=/opt/local /opt/local/bin/qmake PREFIX=/opt/local " returned error 3
:error:configure Target org.macports.configure returned: configure failure: shell command failed (see log for details)
:debug:configure Backtrace: configure failure: shell command failed (see log for details)
    while executing
"$procedure $targetname"
:info:configure Warning: the following items did not execute (for qtiplot): org.macports.activate org.macports.configure org.macports.build org.macports.destroot org.macports.install
:notice:configure Log for qtiplot is at: /opt/local/var/macports/logs/_opt_mports_trunk_dports_aqua_qtiplot/main.log

comment:21 Changed 4 years ago by macsforever2000@…

  • Cc michaelld@… added

@michaelld: Any suggestions on how to fix this qmake issue with QMAKESPEC not being set?

comment:22 Changed 4 years ago by macsforever2000@…

  • Status changed from reopened to closed
  • Resolution set to fixed

+origin variant fixed in r78293.

Note: See TracTickets for help on using tickets.