New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #33222 (closed defect: fixed)

Opened 2 years ago

Last modified 14 months ago

mutt-devel @1.5.21 +sidebar "Could not create temporary file!"

Reported by: Sylvain.Soliman+macports@… Owned by: mnick@…
Priority: Normal Milestone:
Component: ports Version: 2.0.3
Keywords: Cc: kchr@…, jon.armond@…
Port: mutt-devel

Description

A missing closedir() in the old Debian sidebar patch we use results in consuming all file descriptors when handling Maildir.

See http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=610191 for the corresponding Debian bug-report. I get the exact same symptoms on my Snow Leopard MBA (mostly the temp file message, sometimes the missing file descriptors message).

I think we simply need to get the fixed version of their sidebar patch (i.e. 1.5.21_4 or later) [e.g. http://patch-tracker.debian.org/patch/series/view/mutt/1.5.21-5/mutt-patched/sidebar ]

Attachments

Portfile (7.8 KB) - added by kchr@… 18 months ago.
mutt-devel Portfile, revision 1
patch-1.5.21-6.2.debian.sidebar.diff (36.5 KB) - added by kchr@… 18 months ago.
Updated sidebar patch, from mutt-patched in Debian repo (revision 6.2)
Portfile_mutt-devel-1.5.21-3.diff (974 bytes) - added by kchr@… 18 months ago.
Portfile diff against svn trunk

Change History

comment:1 Changed 2 years ago by macsforever2000@…

  • Owner changed from macports-tickets@… to mnick@…
  • Port set to mutt-devel

comment:2 Changed 20 months ago by kchr@…

I can confirm that this is still happening @1.5.21_2.

comment:3 Changed 20 months ago by kchr@…

  • Cc kchr@… added

Cc Me!

comment:4 Changed 20 months ago by kchr@…

According to the Debian bug report aforementioned, the bug was fixed in 1.5.21-4: {{

From: Antonio Radici Date: Tue, 12 Apr 2011 06:19:03 +0000

fixed 610191 1.5.21-4 thanks

I uploaded a version that fixes this yesterday night but unfortunately I put the wrong bug to close in the debian/changelog, this should be fine now.

Cheers Antonio

}}

comment:5 Changed 20 months ago by kchr@…

I have compiled mutt-devel @1.5.21_2 from ports using the latest version of the sidebar patch from the Debian unstable repository. The patch can be found here:

http://patch-tracker.debian.org/patch/series/dl/mutt/1.5.21-6.2/mutt-patched/sidebar

The fd leak seems to be fixed, at least at my end! Let me know if I can help out in any way.

comment:6 Changed 20 months ago by kchr@…

Just contacted the maintainer of mutt-devel port.

comment:7 Changed 18 months ago by kchr@…

I just learned "openmaintainer" means anyone can patch it. I am currently updating the Portfile to apply the latest sidebar patch from Debian, which have been working for two months now without any hitches.

comment:8 Changed 18 months ago by kchr@…

Attaching an updated Portfile and a proper patch from the Debian team (revision 6.2).

Incremented port revision to 1, since the users that have installed this variant would not get notice about the update otherwise — and the bug could be sneaky to discover in some cases.

Changed 18 months ago by kchr@…

mutt-devel Portfile, revision 1

Changed 18 months ago by kchr@…

Updated sidebar patch, from mutt-patched in Debian repo (revision 6.2)

comment:9 Changed 18 months ago by macsforever2000@…

Please instead attach a unified diff of the portfile against svn trunk so we can easily see what changes you made.

Changed 18 months ago by kchr@…

Portfile diff against svn trunk

comment:10 Changed 16 months ago by jon.armond@…

  • Cc jon.armond@… added

Cc Me!

comment:11 Changed 14 months ago by cal@…

  • Status changed from new to closed
  • Resolution set to fixed

Commited in r103397.

Note: See TracTickets for help on using tickets.