New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #34563 (closed defect: fixed)

Opened 2 years ago

Last modified 22 months ago

ghostscript: checksum mismatch because HTML file

Reported by: yusuhail@… Owned by: takanori@…
Priority: Normal Milestone:
Component: ports Version: 2.1.1
Keywords: Cc:
Port: ghostscript

Description

Wrong checksums.

bash-3.2$ sudo port install ghostscript
--->  Computing dependencies for ghostscript
--->  Fetching archive for ghostscript
--->  Attempting to fetch ghostscript-9.05_2.darwin_10.x86_64.tbz2 from http://packages.macports.org/ghostscript
--->  Fetching distfiles for ghostscript
--->  Verifying checksum(s) for ghostscript
Error: Checksum (md5) mismatch for ghostscript-9.05.tar.gz
Error: Checksum (sha1) mismatch for ghostscript-9.05.tar.gz
Error: Checksum (rmd160) mismatch for ghostscript-9.05.tar.gz
***
The non-matching file appears to be HTML. See this page for possible reasons
for the checksum mismatch:
<https://trac.macports.org/wiki/MisbehavingServers>
***
Error: org.macports.checksum for port ghostscript returned: Unable to verify file checksums
Please see the log file for port ghostscript for details:
    /opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_ghostscript/ghostscript/main.log
To report a bug, follow the instructions in the guide:
    http://guide.macports.org/#project.tickets
Error: Processing of port ghostscript failed

Change History

comment:1 Changed 2 years ago by ryandesign@…

  • Owner changed from macports-tickets@… to takanori@…
  • Summary changed from ghostscript checksum to ghostscript: checksum mismatch because HTML file

Did you read the MisbehavingServers page to which the error message directed you?

What is the contents of the HTML file that was downloaded? Try:

cat /opt/local/var/macports/distfiles/ghostscript/ghostscript-9.05.tar.gz

comment:2 Changed 2 years ago by numan.salati@…

I am noticing this exact same error.

Here is the output on my box:

<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/1999/REC-html401-19991224/strict.dtd">
<!-- <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd"> -->
<HTML>
<HEAD>
<META HTTP-EQUIV="Refresh" CONTENT="0.1">
<META HTTP-EQUIV="Pragma" CONTENT="no-cache">
<META HTTP-EQUIV="Expires" CONTENT="-1">
<TITLE></TITLE>
</HEAD>
<BODY><P></BODY>
</HTML>

comment:4 Changed 2 years ago by numan.salati@…

Here is a snippet from the log file:

:info:checksum checksums           ghostscript-9.05.tar.gz \
                    md5     ebf87808253b9892ef15bdfdbd1b7203 \
                    sha1    50e024777cb712ea0aa45aa7dac2e310d9e539b6 \
                    rmd160  dfd0eef6234b07338388bb47f43fbf90d259ab48 \
                    ghostscript-fonts-other-6.0.tar.gz \
                    md5     1a643ae62ef166562e4d422b1a601272 \
                    sha1    da62dfcb9c10d96743c7e30c1eebe7166489798c \
                    rmd160  ab60dbf71e7d91283a106c3df381cadfe173082f \
                    mappingresources4pdf_2unicode_20091116.tar.Z \
                    md5     59267a7d0b818267c8ce85d1dbc4479a \
                    sha1    aaf44cb1e5dd2043c932e641b0e41432aee2ca0d \
                    rmd160  bc1b86e6a5f0e022f88070195eb3e01e167114a7 \
                    mappingresources4pdf_other_20091116.tar.Z \
                    md5     202fa0a291fc1f5b50cfa239106c1b92 \
                    sha1    fc4eabff932c1623f7ee0a34085e79a44d51d0e5 \
                    rmd160  1e2ea9af6be8b60c9a54963e542fa06ceb2daccd
:notice:checksum ***
:notice:checksum The non-matching file appears to be HTML. See this page for possible reasons
:notice:checksum for the checksum mismatch:
:notice:checksum <https://trac.macports.org/wiki

comment:5 Changed 2 years ago by jmr@…

As mentioned on the wiki page, if the problem isn't caused by your network setup, it's caused by the download server. So the important thing is which mirror you are downloading the file from, and nobody in this ticket has yet provided that information.

comment:6 Changed 22 months ago by ryandesign@…

  • Status changed from new to closed
  • Resolution set to fixed

I'm going to assume this was one of the obsolete sourceforge mirrors removed in r98312.

Note: See TracTickets for help on using tickets.