New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #36906 (closed defect: fixed)

Opened 22 months ago

Last modified 3 months ago

osgeo [python-gdal] module missing from qgis install port

Reported by: macports-tickets@… Owned by: vince@…
Priority: Normal Milestone:
Component: ports Version: 2.1.2
Keywords: osgeo python-gdal qgis Cc: mcohen@…, rbeyer@…, egall@…
Port: qgis

Description

I get the following error message upon opening QGIS. The GdalTools plugin is part of the standard install of QGIS.

Unable to load GdalTools plugin. The required "osgeo [python-gdal]" module is missing. Install it and try again.

Is there a way to port install this missing module? I'm a total newbie to macports I don't see this as a variant

Change History

comment:1 Changed 22 months ago by ryandesign@…

  • Owner changed from macports-tickets@… to vince@…

comment:2 Changed 22 months ago by vince@…

I am aware this bug. It is caused by the fact that QGis executes the standard Python distribution provided by Apple and not the Macports Python package, despite all the stuff set during compilation. I just don’t have much time to work on it until the middle of next week, so please be a bit patient. Sorry for the delay.

comment:3 Changed 22 months ago by mcohen@…

  • Cc mcohen@… added

Cc Me!

comment:4 follow-up: ↓ 5 Changed 22 months ago by vince@…

Well, I rebuilt qgis today to see if I could reproduce the bug, but it seems to be gone, so this is not caused by a defect in the Portfile, but by some external element, maybe a bug in ld. Please update or install cctools 836 and/or Xcode to the latest build, and try again.

comment:5 in reply to: ↑ 4 Changed 21 months ago by vaccari@…

Replying to vince@…:

Well, I rebuilt qgis today to see if I could reproduce the bug, but it seems to be gone, so this is not caused by a defect in the Portfile, but by some external element, maybe a bug in ld. Please update or install cctools 836 and/or Xcode to the latest build, and try again.

May I ask if you rebuilt a specific version of qgis? I've built it today (default version) and got the error upon launch. This is on 10.8.2 with Xcode 4.5.2 installed, and self-updated MacPorts before building.

Thanks

Franco

comment:6 follow-up: ↓ 7 Changed 21 months ago by vince@…

Boh, strano ;)… Sorry I did not see your follow-up. What do you get when you try ‘ld -v’

Ciao!

comment:7 in reply to: ↑ 6 Changed 21 months ago by rbeyer@…

Replying to vince@…:

What do you get when you try ‘ld -v’

I have this same problem, 10.8.2, etc. I get:

prompt% ld -v /Applications/MacPorts/QGIS.app
@(#)PROGRAM:ld  PROJECT:ld64-134.9
configured to support archs: i386 x86_64
Library search paths:
	/usr/lib
	/usr/local/lib
Framework search paths:
	/Library/Frameworks/
	/System/Library/Frameworks/
ld: warning: -arch not specified
ld: warning: -macosx_version_min not specified, assuming 10.6
ld: can't map file, errno=22 for inferred architecture x86_64

comment:8 Changed 21 months ago by rbeyer@…

  • Cc rbeyer@… added

Cc Me!

comment:9 Changed 6 months ago by egall@…

  • Cc egall@… added

Cc Me!

comment:10 follow-up: ↓ 12 Changed 4 months ago by macjoost@…

For me on Mavericks, I solved the same issue by manually installing py27-gdal. Maybe it should be a dependency?

comment:11 Changed 4 months ago by ryandesign@…

  • Reporter changed from drew.mueller@… to macports-tickets@…

Changed reporter address because the reporter no longer wishes to be notified about this ticket.

comment:12 in reply to: ↑ 10 Changed 3 months ago by Eric.J.Fielding@…

Replying to macjoost@…:

For me on Mavericks, I solved the same issue by manually installing py27-gdal. Maybe it should be a dependency?

This also fixed the problem for me on both 10.7 and 10.8. Sure seems like it should be a dependency in the port.

comment:13 Changed 3 months ago by vince@…

Oops sorry I overlooked that one. Will do the necessary change today. Apologies for being very sluggish.

comment:14 Changed 3 months ago by vince@…

  • Status changed from new to closed
  • Resolution set to fixed

Done in r120577. Should be fixed now.

Note: See TracTickets for help on using tickets.