New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #5543 (closed defect: duplicate)

Opened 8 years ago

Last modified 8 years ago

BUG: KDE will not build, says qt not compatable with kdelibs (both installed during build)

Reported by: wingdo@… Owned by: ben@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

The complete KDE package attempts to build. Both qt3 and kdelibs3 install, but I get an error which says that the qt version is not compatable with the version of kdelibs installed. Below is the complete build trace.

sudo port install kde ---> Fetching OpenEXR ---> Attempting to fetch OpenEXR-1.2.1.tar.gz from http://savannah.nongnu.org/download/openexr ---> Verifying checksum(s) for OpenEXR ---> Extracting OpenEXR ---> Configuring OpenEXR ---> Building OpenEXR with target all ---> Staging OpenEXR into destroot ---> Packaging tgz archive for OpenEXR 1.2.1_0 ---> Installing OpenEXR 1.2.1_0 ---> Activating OpenEXR 1.2.1_0 ---> Cleaning OpenEXR ---> Fetching aspell ---> Attempting to fetch aspell-0.60.2.tar.gz from ftp://ftp.gnu.org/gnu/aspell ---> Verifying checksum(s) for aspell ---> Extracting aspell ---> Applying patches to aspell ---> Configuring aspell ---> Building aspell with target all ---> Staging aspell into destroot ---> Packaging tgz archive for aspell 0.60.2_2 ---> Installing aspell 0.60.2_2

You must install one of the language dictionaries after installing this port in order for it to work.

---> Activating aspell 0.60.2_2 ---> Cleaning aspell ---> Fetching jasper ---> Attempting to fetch jasper-1.701.0.zip from http://www.ece.uvic.ca/~mdadams/jasper//software/ ---> Verifying checksum(s) for jasper ---> Extracting jasper ---> Applying patches to jasper ---> Configuring jasper ---> Building jasper with target all ---> Staging jasper into destroot ---> Packaging tgz archive for jasper 1.701.0_0 ---> Installing jasper 1.701.0_0 ---> Activating jasper 1.701.0_0 ---> Cleaning jasper ---> Fetching libidn ---> Attempting to fetch libidn-0.5.20.tar.gz from ftp://alpha.gnu.org/pub/gnu/libidn/ ---> Verifying checksum(s) for libidn ---> Extracting libidn ---> Configuring libidn ---> Building libidn with target all ---> Staging libidn into destroot ---> Packaging tgz archive for libidn 0.5.20_0 ---> Installing libidn 0.5.20_0 ---> Activating libidn 0.5.20_0 ---> Cleaning libidn ---> Fetching libogg ---> Attempting to fetch libogg-1.1.2.tar.gz from http://downloads.xiph.org/releases/ogg/ ---> Verifying checksum(s) for libogg ---> Extracting libogg ---> Configuring libogg ---> Building libogg with target all ---> Staging libogg into destroot ---> Packaging tgz archive for libogg 1.1.2_0 ---> Installing libogg 1.1.2_0 ---> Activating libogg 1.1.2_0 ---> Cleaning libogg ---> Fetching libusb ---> Attempting to fetch libusb-0.1.10a.tar.gz from http://puzzle.dl.sourceforge.net/libusb ---> Verifying checksum(s) for libusb ---> Extracting libusb ---> Applying patches to libusb ---> Configuring libusb ---> Building libusb with target all ---> Staging libusb into destroot ---> Packaging tgz archive for libusb 0.1.10a_1 ---> Installing libusb 0.1.10a_1 ---> Activating libusb 0.1.10a_1 ---> Cleaning libusb ---> Fetching libvorbis ---> Attempting to fetch libvorbis-1.1.0.tar.gz from http://downloads.xiph.org/releases/vorbis/ ---> Verifying checksum(s) for libvorbis ---> Extracting libvorbis ---> Configuring libvorbis ---> Building libvorbis with target all ---> Staging libvorbis into destroot ---> Packaging tgz archive for libvorbis 1.1.0_0 ---> Installing libvorbis 1.1.0_0 ---> Activating libvorbis 1.1.0_0 ---> Cleaning libvorbis ---> Fetching pcre ---> Attempting to fetch pcre-6.4.tar.bz2 from ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/ ---> Verifying checksum(s) for pcre ---> Extracting pcre ---> Configuring pcre ---> Building pcre with target all ---> Staging pcre into destroot ---> Packaging tgz archive for pcre 6.4_0 ---> Installing pcre 6.4_0 ---> Activating pcre 6.4_0 ---> Cleaning pcre ---> Fetching qt3 ---> Attempting to fetch qt-x11-free-3.3.4.tar.bz2 from ftp://ftp.trolltech.com/qt/source/ ---> Verifying checksum(s) for qt3 ---> Extracting qt3 ---> Applying patches to qt3 ---> Configuring qt3 ---> Building qt3 with target symlinks src-qmake src-moc sub-src sub-tools ---> Staging qt3 into destroot ---> Packaging tgz archive for qt3 3.3.4_4+darwin_8 ---> Installing qt3 3.3.4_4+darwin_8 ---> Activating qt3 3.3.4_4+darwin_8 ---> Cleaning qt3 ---> Fetching kdelibs3 ---> Attempting to fetch kdelibs-3.4.1.tar.bz2 from http://ftp.rutgers.edu/pub/kde/stable/3.4.1/src ---> Attempting to fetch kdelibs-3.4.1.tar.bz2 from http://mirrors.midco.net/pub/kde/stable/3.4.1/src ---> Attempting to fetch kdelibs-3.4.1.tar.bz2 from http://kde.oregonstate.edu/pub/kde/stable/3.4.1/src ---> Attempting to fetch kde-admindir-3.4.0-6.tar.bz2 from http://ranger.befunk.com/fink/ ---> Attempting to fetch detect-autoconf.tar.bz2 from http://ranger.befunk.com/darwin/ ---> Verifying checksum(s) for kdelibs3 ---> Extracting kdelibs3 ---> Applying patches to kdelibs3 ---> Configuring kdelibs3 ---> Building kdelibs3 with target all ---> Staging kdelibs3 into destroot ---> Packaging tgz archive for kdelibs3 3.4.1_4+darwin_8 ---> Installing kdelibs3 3.4.1_4+darwin_8 ---> Activating kdelibs3 3.4.1_4+darwin_8 ---> Cleaning kdelibs3 ---> Fetching openmotif ---> Attempting to fetch openmotif-2.2.4.tar.gz from http://ftp.motifzone.net/om2.2.4/src/ ---> Attempting to fetch openmotif-2.2.4.tar.gz from http://distfiles-od.opendarwin.org/ ---> Verifying checksum(s) for openmotif ---> Extracting openmotif ---> Configuring openmotif ---> Building openmotif with target all ---> Staging openmotif into destroot ---> Packaging tgz archive for openmotif 2.2.4_1 ---> Installing openmotif 2.2.4_1 ---> Activating openmotif 2.2.4_1 ---> Cleaning openmotif ---> Fetching openssl ---> Attempting to fetch openssl-0.9.8a.tar.gz from http://www.openssl.org/source/ ---> Verifying checksum(s) for openssl ---> Extracting openssl ---> Applying patches to openssl ---> Configuring openssl ---> Building openssl with target all ---> Staging openssl into destroot ---> Packaging tgz archive for openssl 0.9.8a_0+darwin_8 ---> Installing openssl 0.9.8a_0+darwin_8 ---> Activating openssl 0.9.8a_0+darwin_8 ---> Cleaning openssl ---> Fetching samba3 ---> Attempting to fetch samba-3.0.20.tar.gz from http://us1.samba.org/samba/ftp/stable/ ---> Verifying checksum(s) for samba3 ---> Extracting samba3 ---> Applying patches to samba3 ---> Configuring samba3 ---> Building samba3 with target all ---> Staging samba3 into destroot ---> Packaging tgz archive for samba3 3.0.20_0+darwin_8 ---> Installing samba3 3.0.20_0+darwin_8 ---> Activating samba3 3.0.20_0+darwin_8 ---> Cleaning samba3 ---> Fetching kdebase3 ---> Attempting to fetch kdebase-3.4.1.tar.bz2 from http://ftp.rutgers.edu/pub/kde/stable/3.4.1/src ---> Attempting to fetch kdebase-3.4.1.tar.bz2 from http://mirrors.midco.net/pub/kde/stable/3.4.1/src ---> Attempting to fetch kdebase-3.4.1.tar.bz2 from http://kde.oregonstate.edu/pub/kde/stable/3.4.1/src ---> Attempting to fetch kde-admindir-3.4.0-6.tar.bz2 from http://ranger.befunk.com/fink/ ---> Verifying checksum(s) for kdebase3 ---> Extracting kdebase3 ---> Applying patches to kdebase3 ---> Configuring kdebase3 Error: Target com.apple.configure returned: configure failure: shell command "cd "/opt/local/var/db/dports/build/file._opt_local_var_db_dports_sources_rsync.rsync.opendarwin.org_dpupdate_dports_kde_kdebase3/work/kdebase-3.4.1" && CC=gcc-3.3 CXX=g++-3.3 CFLAGS='-Os' CXXFLAGS='-Os' CPPFLAGS='-I/usr/X11R6/include -I/usr/X11R6/include/freetype2 -I/usr/X11R6/include/freetype2/freetype -I/opt/local/include -I/opt/local/include/qt3 -I/usr/include/gssapi -no-cpp-precomp -fno-common -UHAVE_REALTIME_SCHED' LDFLAGS='-L/usr/X11R6/lib -L/opt/local/lib' LIBS='-L/opt/local/lib' lt_cv_sys_max_cmd_len=65536 ./configure --prefix=/opt/local --prefix='/opt/local' --includedir='/opt/local/include' --libdir='/opt/local/lib' --with-extra-includes='/opt/local/include:/usr/include/gssapi' --with-extra-libs='/opt/local/lib' --with-qt-dir='/opt/local' --with-qt-includes='/opt/local/include/qt3' --with-plugins='/opt/local/lib/qt3-plugins' --enable-rpath --with-pic --enable-shared=yes --enable-static=no --enable-mt --libexecdir='/opt/local/lib' --with-xinerama --with-pam --disable-final --disable-dependency-tracking --enable-cups --with-ldap --mandir=/opt/local/share/man --with-pam --with-distribution='DarwinPorts/Mac OS X' --with-ssl-dir=/usr --with-ssl --with-gssapi=framework --disable-dependency-tracking --without-arts" returned error 1 Command output: checking for snprintf... yes checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include checking for IceConnectionNumber in -lICE... yes checking for libXext... yes checking for pthread_create in -lpthread... yes checking for extra includes... added checking for extra libs... added checking for libz... -lz checking for libpng... -lpng -lz -lm checking for libjpeg6b... no checking for libjpeg... -ljpeg checking for perl... /opt/local/bin/perl checking for Qt... libraries /opt/local/lib, headers /opt/local/include/qt3 using -mt checking for moc... /opt/local/bin/moc checking for uic... /opt/local/bin/uic checking whether uic supports -L ... yes checking whether uic supports -nounload ... yes checking if Qt needs -ljpeg... no checking for rpath... yes checking for KDE... libraries /opt/local/lib, headers /opt/local/include checking if UIC has KDE plugins available... no configure: error: you need to install kdelibs first.

If you did install kdelibs, then the Qt version that is picked up by this configure is not the same version you used to compile kdelibs. The Qt Plugin installed by kdelibs is *ONLY* loadable if its the same Qt version, compiled with the same compiler and the same Qt configuration settings.

Error: The following dependencies failed to build: kdebase3 kdenetwork3 kdepim3 kdeutils3

Change History

comment:1 Changed 8 years ago by wingdo@…

  • op_sys changed from Mac OS X 10.0 to Mac OS X 10.4

comment:2 Changed 8 years ago by mww@…

  • Owner changed from darwinports-bugs@… to ben@…
  • Summary changed from KDE will not build, says qt not compatable with kdelibs (both installed during build) to BUG: KDE will not build, says qt not compatable with kdelibs (both installed during build)

comment:3 Changed 8 years ago by ben@…

  • Status changed from new to closed
  • Resolution set to duplicate

* This bug has been marked as a duplicate of 5342 *

Note: See TracTickets for help on using tickets.