Opened 3 years ago

Closed 2 years ago

#45449 closed defect (fixed)

apple-gcc42 @5666.3_14, llvm-gcc42 @2336.11_1: can't build on Yosemite

Reported by: elbert.castaneda@… Owned by: larryv (Lawrence Velázquez)
Priority: Normal Milestone:
Component: ports Version:
Keywords: yosemite Cc: ryandesign (Ryan Schmidt), mamoll (Mark Moll), bgschaid@…, ayhan@…, jon_schang@…
Port: apple-gcc42 llvm-gcc42

Description

  • I install Yosemite MacOS Version today
  • I Install MacPorts for this MacOS Version(Yosemite)
  • I execute this command : sudo xcode-select --install
  • I execute this command for upgrade all packages and here it's the problem: sudo port upgrade outdated
  • Error: apple-gcc42 is not supported on Yosemite or later.
  • Error: org.macports.fetch for port apple-gcc42 returned: unsupported platform

Attachments (1)

llvm-gcc42-yosemite.patch (9.6 KB) - added by jhowarth@… 3 years ago.
patch to solve llvm-gcc42 build problems on 10.10

Download all attachments as: .zip

Change History (19)

comment:1 Changed 3 years ago by ryandesign (Ryan Schmidt)

  • Cc ryandesign@… added
  • Keywords apple-gcc42 removed
  • Milestone MacPorts 2.3.2 deleted
  • Owner changed from macports-tickets@… to jeremyhu@…
  • Port apple-gcc42 added

Correct. Sorry, this port is not supported on Yosemite right now. Are you sure you need it?

comment:2 Changed 3 years ago by jeremyhu (Jeremy Huddleston Sequoia)

  • Resolution set to wontfix
  • Status changed from new to closed

It will not be supported on Yosemite. Developers have had many many years to update their software for newer compilers. If you still need gcc 4.2 for some reason, please file a bug with llvm.org indicating what the issues are with clang that you need fixed.

Changed 3 years ago by jhowarth@…

patch to solve llvm-gcc42 build problems on 10.10

comment:3 Changed 3 years ago by jhowarth@…

On fink, I have solved our llvm-gcc42 build problems with the attached patch. The first part of the patch is a back port of the upstream fix for the ENVIRONMENT_MAC_OS_X_VERSION_MIN_REQUIRED support...

http://permalink.gmane.org/gmane.comp.gcc.cvs/164573

and the second half adds a fixincludes entry to work around the problematic conditionals in the xpc/base.h system header by hardcoding those to

if 0

The existing packaging in fink for llvm-gcc42 builds fine under 10.10.0 with this patch applied.

Version 0, edited 3 years ago by jhowarth@… (next)

comment:4 Changed 3 years ago by jhowarth@…

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:5 Changed 3 years ago by jhowarth@…

There is one additional section to the patch that modifies the sed in llvmgcc42-2336.11/llvmCore/Makefile.rules that sets DARWIN_VERSION and DARWIN_MAJVERS. I suspect that change is only valid for 10.10 and later so you will only want to apply the patch for those releases.

comment:6 Changed 3 years ago by mamoll (Mark Moll)

  • Cc mmoll@… added

Cc Me!

comment:7 Changed 3 years ago by mamoll (Mark Moll)

The attached patch (minus the patch to llvmgcc42-2336.11/llvmCore/Makefile.rules) makes llvm-gcc42 compile for me. Thanks! I need it to compile gccxml-devel.

Last edited 3 years ago by mamoll (Mark Moll) (previous) (diff)

comment:8 follow-up: Changed 3 years ago by jeremyhu (Jeremy Huddleston Sequoia)

What was the source of the attached patch? If it was upstream gcc, it is not acceptable as it is GPL3.

Please base your changes on the version I provided in apple-gcc42, yosemite-deployment-target.patch

comment:9 Changed 3 years ago by jeremyhu (Jeremy Huddleston Sequoia)

Also, your patch says "The lowest digit is always zero, as is the second lowest for '10.10.x' and above." which is an incorrect assumption to make.

comment:10 in reply to: ↑ 8 Changed 3 years ago by larryv (Lawrence Velázquez)

Replying to jeremyhu@…:

What was the source of the attached patch? If it was upstream gcc, it is not acceptable as it is GPL3.

It looks to be largely derived from the upstream fix.

comment:11 Changed 3 years ago by jeremyhu (Jeremy Huddleston Sequoia)

  • Owner changed from jeremyhu@… to larryv@…
  • Status changed from reopened to new

To larryv to fix using the changes from https://gcc.gnu.org/bugzilla/show_bug.cgi?id=63810 if desired or closed as NTBF if not.

comment:12 Changed 3 years ago by larryv (Lawrence Velázquez)

  • Port llvm-gcc42 added

comment:13 Changed 3 years ago by larryv (Lawrence Velázquez)

  • Summary changed from Error: apple-gcc42 is not supported on Yosemite or later. to apple-gcc42 @5666.3_14, llvm-gcc42 @2336.11_1: can't build on Yosemite

comment:14 Changed 3 years ago by bgschaid@…

  • Cc bgschaid@… added

Cc Me!

comment:15 Changed 3 years ago by ayhan@…

  • Cc ayhan@… added

Cc Me!

comment:16 Changed 2 years ago by jon_schang@…

  • Cc jon_schang@… added

Cc Me!

comment:17 Changed 2 years ago by larryv (Lawrence Velázquez)

  • Status changed from new to assigned

comment:18 Changed 2 years ago by larryv (Lawrence Velázquez)

  • Resolution set to fixed
  • Status changed from assigned to closed

r136962 and r136963, using my GPLv2-relicensed fix.

Note: See TracTickets for help on using tickets.