Changes between Initial Version and Version 1 of Ticket #61361


Ignore:
Timestamp:
Oct 22, 2020, 2:33:59 AM (2 years ago)
Author:
ryandesign (Ryan Schmidt)
Comment:

there is no Package vim-8.2.1719_0+huge+python38.darwin_19.x86_64.tbz2

That's correct. Packages are not necessarily always available, and that should never be a problem. In this case, it's because +python38 is not one of the default variants, and we only produce packages for default variants.

You should still be able to build the port from source. Presumably that is failing for you. Please attach the main.log file so that we can see why that happened.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #61361

    • Property Status changed from new to assigned
    • Property Owner set to raimue
    • Property Milestone changed from MacPorts Future to
    • Property Port vim added
  • Ticket #61361 – Description

    initial v1  
    11Model: MacBook macOS Catalina 10.15.6
    22
     3{{{
    34vim --version | grep python
     5}}}
    46It said "-python" and "-python3"
    57
    6 Hence installed Xcode and Macports.
    7 Gave the Command "sudo port install vim +python38"
    8 Getting Error: Failed to destroot vim: command execution failed
     8Hence installed Xcode and Macports. \\
     9Gave the Command `sudo port install vim +python38`\\
     10Getting Error:
     11{{{
     12Failed to destroot vim: command execution failed
     13}}}
    914
    1015Seen inside the Log File "/opt/local/var/macports/logs/_opt_local_var_macports_sources_rsync.macports.org_macports_release_tarballs_ports_editors_vim/vim/main.log"
     16{{{
    1117failed to fetch vim-8.2.1719_0+huge+python38.darwin_19.x86_64.tbz2 from https://packages.macports.org/vim
    1218failed to fetch vim-8.2.1719_0+huge+python38.darwin_19.x86_64.tbz2 from https://ywg.ca.packages.macports.org/mirror/macports/packages/vim/vim
    1319failed to fetch vim-8.2.1719_0+huge+python38.darwin_19.x86_64.tbz2 from https://kmq.jp.packages.macports.org/vim
     20}}}
    1421
    1522Went to the 3 Sites, there is no Package  vim-8.2.1719_0+huge+python38.darwin_19.x86_64.tbz2.