Opened 2 years ago

Last modified 16 months ago

#61979 assigned defect

xorg-server @1.20.10 will not start unless openssl is also installed

Reported by: Ch00k (Andrii Yurchuk) Owned by: jeremyhu (Jeremy Huddleston Sequoia)
Priority: Normal Milestone:
Component: ports Version: 2.6.4
Keywords: Cc:
Port: xorg-server


I installed xorg-server @1.20.10, which created the The app does not start though - the dot under the icon keeps blinking for a while until the app reaches the "Not Responding" state. I then tried to run startx manually from the terminal, which produced the error:

$ startx
font_cache: Scanning user font directories to generate X11 font caches
font_cache: Updating FC cache
font_cache: Done
/opt/local/bin/startx: line 213: /opt/local/bin/openssl: No such file or directory
Couldn't create cookie

After running port install openssl both startx and start up correctly.

Change History (4)

comment:1 Changed 2 years ago by mf2k (Frank Schima)

Cc: jeremyhu removed
Owner: set to jeremyhu
Status: newassigned

comment:2 Changed 16 months ago by nortcele

I got the same problem with xorg-server @xorg-server @1.20.11_1 on the following configurations:

  • macOS 10.13.6 17G14042, Xcode 10.1 10B61, MacPorts 2.7.1
  • macOS 10.12.6 16G2136, Xcode 9.2 9C40b, MacPorts 2.7.1

Installing openssl solved the problem.

Version 0, edited 16 months ago by nortcele (next)

comment:3 Changed 16 months ago by nortcele

And the error is also present with xorg-server-legacy in macOS 10.9.5 13F1911, Xcode 6.2 6C131e, MacPorts 2.7.1.

Perhaps should a dependency to openssl be added to the xorg-server portfile.

comment:4 Changed 16 months ago by nortcele

Same problem with macOS 10.9.5 13F1911 (Xcode 6.2 6C131e, MacPorts 2.7.1) and macOS 10.11.6 15G22010 (Xcode 8.2.1 8C1002, MacPorts 2.7.1).

Note: See TracTickets for help on using tickets.