Ticket #26040: INSTALL.macports.xymon.server

File INSTALL.macports.xymon.server, 3.0 KB (added by fclaire@…, 14 years ago)
Line 
1ui_msg "  *** To complete the Xymon install ***
2
3
41) Tune the number of shared message queues
5----------------------------------------------
6
7Xymon server needs at least 9 IPC message queues to run.
8Unfortunately Mac OS X ships with a default max of 8.
9
10Check how much shared segments a process can use on
11your system:
12    $ sysctl kern.sysv.shmseg
13And the max number of shared segments system-wide:
14    $ sysctl kern.sysv.shmmni
15
16If the first number is < 9, you need to tune your system
17before trying to start xymon server (doing so will make
18the whole system to crash).
19
20Run the following commands to increase your shared
21segments:
22    $ sudo echo \"kern.sysv.shmmni=64\" >> /etc/sysctl.conf
23    $ sudo echo \"kern.sysv.shmseg=12\" >> /etc/sysctl.conf
24
25Reboot your system to activate the change. After reboot you can
26read these instructions with:
27    $ cat /opt/local/lib/xymon/INSTALL.macports.xymon.server
28
29More information about shared memory segments on Mac OS X
30can be found here: http://support.apple.com/kb/HT4022
31
32
33
342) Configure your apache web server
35----------------------------------------------
36
37Xymon \"make install\" ends with:
38You must configure your webserver for the Hobbit webpages and CGI-scripts.
39A sample Apache configuration is in /opt/local/lib/xymon/server/etc/hobbit-apache.conf
40If you have your Administration CGI scripts in a separate directory,
41then you must also setup the password-file with the htpasswd command.
42
43So the following commands should do it:
44    $ sudo mv /opt/local/lib/xymon/server/etc/hobbit-apache.conf /etc/apache2/sites/
45    $ sudo /usr/sbin/apachectl restart
46
47
48
493) Make user _xymon part of the admin group:
50----------------------------------------------
51
52We achieve this with the Directory Service command line utility:
53    $ sudo dscl . -append /Groups/admin GroupMembership _xymon
54
55
56
57
584) Start Xymon server
59----------------------------------------------
60
61A startup item has been generated that will aid in
62starting xymon with launchd. It is disabled
63by default. Execute the following command to start it,
64and to cause it to launch at startup:
65
66    $ sudo launchctl load -w /Library/LaunchDaemons/org.macports.xymon.plist
67
68If your Mac OSX firewall is enabled, you'll be asked to allow
69xymon -> accept
70On Mac OSX Server, make sure your ipfw rules will allow
71incoming TCP conections to port 1984
72
73
745) check the status of your Xymon server
75----------------------------------------------
76
77To view the Xymon webpages, go to http://localhost/xymon
78
79----------------------------------------------
80
81
82
83
84  *** Quick start for the impatient ***
85
86Run the following commands in your terminal:
87    $ sudo echo \"kern.sysv.shmmni=64\" >> /etc/sysctl.conf
88    $ sudo echo \"kern.sysv.shmseg=12\" >> /etc/sysctl.conf
89    $ sudo mv /opt/local/lib/xymon/server/etc/hobbit-apache.conf /etc/apache2/sites/
90    $ sudo /usr/sbin/apachectl restart
91    $ sudo dscl . -append /Groups/admin GroupMembership _xymon
92Reboot your system
93    $ sudo launchctl load -w /Library/LaunchDaemons/org.macports.xymon.plist
94Open http://localhost/xymon in your server's browser
95
96"