New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #24348 (closed defect: fixed)

Opened 5 years ago

Last modified 4 years ago

kdesdk4: umbrello problems: deps and dylib

Reported by: roberto@… Owned by: snc@…
Priority: Normal Milestone:
Component: ports Version: 1.8.2
Keywords: Cc: sharky@…, ryandesign@…
Port: kdesdk4

Description

I just built kdesdk4 on a 10.4.11 intel MacBook (and ran into several problems, incidentally, for which there are already tickets submitted). However, once I managed to make the build complete successfully, there was no Umbrello application. This was the only application I really needed, and it was disappointing to go through all of that trouble to not even be able to get it. Please fix kdesdk4 so that umbrello is built.

Change History

comment:1 Changed 5 years ago by macsforever2000@…

  • Owner changed from macports-tickets@… to snc@…
  • Cc sharky@… added
  • Port set to kdesdk4

comment:2 Changed 4 years ago by snc@…

Was this 4.2.2? Do you have a build log we can look at?

comment:3 Changed 4 years ago by roberto@…

It was with 4.4.1 yesterday. I did a 'port selfupdate' and 'port -u upgrade outdated' today and got 4.4.2. Same thing, no umbrello to be found. If you can tell me how to force a rebuild, I can capture the log and post it. (I looked in the man page and it is not clear how to that without uninstalling first. Is that the correct way?)

comment:4 Changed 4 years ago by snc@…

Sure, you can do sudo port -d build kdesdk4 &> ~/kdesdk4.log. That command will do a debug build (which will work without having to uninstall kdesdk4) and save it as a file in your home directory. Just attach it (you may need to have Finder archive it first if it's too big).

comment:5 Changed 4 years ago by roberto@…

I did as you recommended, and this message appeared:

-----------------------------------------------------------------------------
-- The following OPTIONAL packages could NOT be located on your system.
-- Consider installing them to enable more features from this software.
-----------------------------------------------------------------------------
   * boost (1.33.1 or higher)  <http://www.boost.org>
     Boost C++ Libraries
     Required to build Umbrello.
-----------------------------------------------------------------------------

I am installing boost right now and will try to reinstall kdesdk4 4 and see if I get Umbrello that way.

comment:6 Changed 4 years ago by roberto@…

The installation of boost completed, then I uninstalled/installed kdesdk4, and Umbrello was installed. It doesn't launch, but I'll look into it and open a separate ticket if that is what is needed.

comment:7 Changed 4 years ago by roberto@…

Actually, I've got a better handle on this now. Here are the contents of /Applications/MacPorts/KDE4/umbrello.app/Contents/MacOS/umbrello.shell:

#!/bin/sh
# created by cmake, don't edit, changes will be lost

DYLD_LIBRARY_PATH=/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdesdk4/work/build/lib/./:/opt/local/lib${DYLD_LIBRARY_PATH:+:$DYLD_LIBRARY_PATH} "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdesdk4/work/build/umbrello/umbrello/umbrello.app/Contents/MacOS/umbrello" "$@"

The problem is that neither of the referenced files or directories exist:

roberto@vieques:~$ ls /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdesdk4/work/build/lib/
ls: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdesdk4/work/build/lib/: No such file or directory
roberto@vieques:~$ ls /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdesdk4/work/build/umbrello/umbrello/umbrello.app/Contents/MacOS/umbrello
ls: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdesdk4/work/build/umbrello/umbrello/umbrello.app/Contents/MacOS/umbrello: No such file or directory
roberto@vieques:~$

Also, manually launching the application results in this:

roberto@vieques:~$ DYLD_LIBRARY_PATH=/opt/local/lib /Applications/MacPorts/KDE4/umbrello.app/Contents/MacOS/umbrello
dyld: Symbol not found: __cg_jpeg_resync_to_restart
  Referenced from: /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/ImageIO.framework/Versions/A/ImageIO
  Expected in: /opt/local/lib/libJPEG.dylib

Trace/BPT trap
roberto@vieques:~$ ll /opt/local/lib/libJPEG.dylib
lrwxr-xr-x   1 root  admin  15B Mar 28 21:54 /opt/local/lib/libJPEG.dylib -> libjpeg.8.dylib
roberto@vieques:~$

Would it be better to report this in a new ticket?

comment:8 Changed 4 years ago by snc@…

  • Status changed from new to assigned
  • Summary changed from kdesdk4 does not build umbrello to umbrello problems: deps and dylib

Let's keep this one going.

comment:9 Changed 4 years ago by snc@…

I added the variant for boost in r65992.

comment:10 Changed 4 years ago by ryandesign@…

  • Cc ryandesign@… added
  • Summary changed from umbrello problems: deps and dylib to kdesdk4: umbrello problems: deps and dylib

All your variant does is add a lib dep on boost. If having boost installed when building kdesdk4 causes kdesdk4 to build umbrello, then you should also modify the port to ensure umbrello is not built unless the new variant is selected. Otherwise users installing kdesdk4 will get different software depending on whether they already had boost or not.

comment:11 Changed 4 years ago by snc@…

  • Status changed from assigned to closed
  • Resolution set to fixed

Enforced variant in r68608.

Note: See TracTickets for help on using tickets.