Opened 14 years ago

Closed 14 years ago

#10066 closed defect (invalid)

xrender fails to build (compiler errors)

Reported by: David.Squire@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc:
Port:

Description

While trying to do "sudo port install vim +gtk2" on Mac OS 10.4.7 with all Xcode stuff installed, xrender fails to build with compiler errors:


---> Building xrender with target all Error: Target com.apple.build returned: shell command "cd "/usr/local/var/db/dports/build/_usr_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_x11_xrender/work/libXrender-0.9.0" && make all" returned error 2 Command output: make all-am if /bin/sh ./libtool --mode=compile /usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I. -I/usr/local/include -I/usr/X11R6/include -DXTHREADS -g -O2 -MT AddTrap.lo -MD -MP -MF ".deps/AddTrap.Tpo" \

-c -o AddTrap.lo test -f 'AddTrap.c' || echo './'AddTrap.c; \

then mv -f ".deps/AddTrap.Tpo" ".deps/AddTrap.Plo"; \ else rm -f ".deps/AddTrap.Tpo"; exit 1; \ fi

/usr/bin/gcc-4.0 -DHAVE_CONFIG_H -I. -I. -I. -I/usr/local/include -I/usr/X11R6/include -DXTHREADS -g -O2 -MT AddTrap.lo -MD -MP -MF .deps/AddTrap.Tpo -c AddTrap.c -fno-common -DPIC -o .libs/AddTrap.o

AddTrap.c: In function 'XRenderAddTraps': AddTrap.c:38: error: 'xRenderAddTrapsReq' undeclared (first use in this function) AddTrap.c:38: error: (Each undeclared identifier is reported only once AddTrap.c:38: error: for each function it appears in.) AddTrap.c:38: error: 'req' undeclared (first use in this function) AddTrap.c:47: error: 'sz_xRenderAddTrapsReq' undeclared (first use in this function) AddTrap.c:47: error: parse error before ')' token AddTrap.c:47: error: 'X_RenderAddTraps' undeclared (first use in this function) AddTrap.c:54: error: 'sz_xTrap' undeclared (first use in this function) make[1]: * [AddTrap.lo] Error 1 make: * [all] Error 2


I suspect that this will cause all gtk2 stuff to fail to install...

(note I have port installed with prefix=/usr/local)

Change History (2)

comment:1 Changed 14 years ago by David.Squire@…

... yet downloading http://xlibs.freedesktop.org/release/libXrender-0.9.0.tar.gz and building it by hand works fine.

comment:2 Changed 14 years ago by David.Squire@…

Resolution: invalid
Status: newclosed

Silly me. I've now done a clean reinstallation of port, after blitzing /usr/local (OS has just been reinstalled), and this time using /opt/local for port. This time it compiles fine. How embarassing.

Note: See TracTickets for help on using tickets.