Opened 14 years ago

Closed 13 years ago

Last modified 11 years ago

#10071 closed defect (duplicate)

BUG: libsdl-1.2.11 - error: dereferencing pointer to incomplete type

Reported by: colin_kahn@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc:
Port:

Description

When i try to install %sudo port install libsdl or %sudo port install libsdl-framework i get this error message: ---> Fetching libsdl ---> Attempting to fetch SDL-1.2.11.tar.gz from http://www.libsdl.org/release/ ---> Verifying checksum(s) for libsdl ---> Extracting libsdl ---> Configuring libsdl ---> Building libsdl with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_devel_libsdl/work/SDL-1.2.11" && make all" returned error 2 Command output: include/SDL_syswm.h:55:22: X11/Xlib.h: No such file or directory include/SDL_syswm.h:56:23: X11/Xatom.h: No such file or directory In file included from src/events/SDL_events.c:27: include/SDL_syswm.h:73: error: parse error before "XEvent" include/SDL_syswm.h:73: warning: no semicolon at end of struct or union include/SDL_syswm.h:73: warning: no semicolon at end of struct or union include/SDL_syswm.h:74: warning: data definition has no type or storage class include/SDL_syswm.h:75: error: parse error before '}' token include/SDL_syswm.h:86: error: parse error before "Display" include/SDL_syswm.h:86: warning: no semicolon at end of struct or union include/SDL_syswm.h:86: warning: no semicolon at end of struct or union include/SDL_syswm.h:86: warning: no semicolon at end of struct or union include/SDL_syswm.h:87: warning: data definition has no type or storage class include/SDL_syswm.h:97: error: parse error before "fswindow" include/SDL_syswm.h:97: warning: data definition has no type or storage class include/SDL_syswm.h:98: error: parse error before "wmwindow" include/SDL_syswm.h:98: warning: data definition has no type or storage class include/SDL_syswm.h:99: warning: data definition has no type or storage class include/SDL_syswm.h:100: error: parse error before '}' token include/SDL_syswm.h:100: warning: data definition has no type or storage class include/SDL_syswm.h:101: error: parse error before '}' token include/SDL_syswm.h:101: warning: data definition has no type or storage class include/SDL_syswm.h:201: error: parse error before '*' token In file included from src/events/SDL_sysevents.h:24,

from src/events/SDL_events.c:28:

src/video/SDL_sysvideo.h:218: error: parse error before "SDL_SysWMinfo" src/events/SDL_events.c:49: error: field `wmmsg' has incomplete type src/events/SDL_events.c: In function `SDL_AddEvent': src/events/SDL_events.c:276: error: dereferencing pointer to incomplete type make: * [build/SDL_events.lo] Error 1

Error: The following dependencies failed to build: libsdl

Change History (4)

comment:1 Changed 14 years ago by markd@…

Summary: libsdl error: dereferencing pointer to incomplete typeBUG: libsdl-1.2.11 - error: dereferencing pointer to incomplete type

comment:2 Changed 13 years ago by pipping@…

Milestone: Port Bugs

comment:3 Changed 13 years ago by markd@…

Resolution: duplicate
Status: newclosed

A dependency on X11 has been checked in so install X11 and reinstall. This is also a duplicate of #10830.

comment:4 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.