Opened 14 years ago

Closed 14 years ago

#10107 closed defect (worksforme)

BUG: audiofile-0.2.6, Target com.apple.build returns error 2

Reported by: ian@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.2
Keywords: Cc: cssdev
Port:

Description

I discovered this trying to get the esound package built.

uname -a: Darwin Churchkey.local 8.7.0 Darwin Kernel Version 8.7.0: Fri May 26 15:20:53 PDT 2006; root:xnu-792.6.76.obj~1/RELEASE_PPC Power Macintosh powerpc

port version: audiofile 0.2.6, audio/audiofile

output of "port install audiofile": ---> Building audiofile with target all Error: Target com.apple.build returned: shell command "cd "/opt/local/var/db/dports/build/_opt_local_var_db_dports_sources_rsync.rsync.darwinports.org_dpupdate_dports_audio_audiofile/work/audiofile-0.2.6" && make all" returned error 2 Command output: osxplay.c:115: error: 'outputUnit' undeclared (first use in this function) osxplay.c: At top level: osxplay.c:133: error: parse error before 'AudioUnitRenderActionFlags' osxplay.c: In function 'fileRenderProc': osxplay.c:139: error: 'inRefCon' undeclared (first use in this function) osxplay.c:142: error: 'inNumFrames' undeclared (first use in this function) osxplay.c:150: error: 'ioData' undeclared (first use in this function) osxplay.c: At top level: osxplay.c:160: error: parse error before '*' token osxplay.c: In function 'setupOutput': osxplay.c:166: error: 'AudioStreamBasicDescription' undeclared (first use in this function) osxplay.c:166: error: parse error before 'fileASBD' osxplay.c:167: error: 'AURenderCallbackStruct' undeclared (first use in this function) osxplay.c:170: error: 'file' undeclared (first use in this function) osxplay.c:173: error: 'fileASBD' undeclared (first use in this function) osxplay.c:175: error: 'outputUnit' undeclared (first use in this function) osxplay.c:176: error: 'kAudioUnitProperty_StreamFormat' undeclared (first use in this function) osxplay.c:176: error: 'kAudioUnitScope_Output' undeclared (first use in this function) osxplay.c:181: error: 'outputASBD' undeclared (first use in this function) osxplay.c:192: error: 'inputASBD' undeclared (first use in this function) osxplay.c:195: error: 'kAudioUnitScope_Input' undeclared (first use in this function) osxplay.c:207: error: 'renderCallback' undeclared (first use in this function) osxplay.c:211: error: 'kAudioUnitProperty_SetRenderCallback' undeclared (first use in this function) osxplay.c: In function 'main': osxplay.c:225: error: 'AudioUnit' undeclared (first use in this function) osxplay.c:225: error: parse error before 'outputUnit' osxplay.c:240: error: 'outputUnit' undeclared (first use in this function) make[2]: * [osxplay.o] Error 1 make[1]: * [all-recursive] Error 1 make: * [all] Error 2

Error: /opt/local/bin/port: Status 1 encountered during processing.

Change History (3)

comment:1 Changed 14 years ago by markd@…

Summary: cannot install audiofile 0.2.6, Target com.apple.build returns error 2BUG: audiofile-0.2.6, Target com.apple.build returns error 2

comment:2 Changed 14 years ago by cssdev

Cc: css@… added

I have this port installed on my PowerBook, but I installed it in December 2005. The homepage indicates that it builds with gcc 3.3. I wonder if it might not be gcc 4-clean? Can you try running gcc_select 3 and rebuilding?

comment:3 Changed 14 years ago by tobypeterson

Resolution: worksforme
Status: newclosed

Builds for me on 10.4.8... looks like some header files are missing.

Note: See TracTickets for help on using tickets.