Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#1106 closed defect (invalid)

pkgconfig doesn't build on Panther

Reported by: olaf@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

Hi,

I've tried to build gimp on Panther but did run into problems with pkgbuild:

$ sudo port install pkgconfig ---> Building pkgconfig with target all Error: Target com.apple.build returned: shell command "cd "/Volumes/ufs/projects/darwinports/darwinports/dports/devel/pkgconfig/work/pkgconfig-0.15.0" && make all" returned error 2 Command output: make all-recursive Making all in glib-1.2.8 make all-recursive Making all in . /bin/sh ./libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I. -DG_LOG_DOMAIN=g_log_domain_glib -I/opt/local/include -no-cpp-precomp -O3 -funroll-loops -fstrict-aliasing -Wall -D_REENTRANT -no-cpp-precomp -c gmain.c gcc -DHAVE_CONFIG_H -I. -I. -I. -DG_LOG_DOMAIN=g_log_domain_glib -I/opt/local/include -no-cpp-precomp -O3 -funroll-loops -fstrict-aliasing -Wall -D_REENTRANT -no-cpp-precomp -c gmain.c -o gmain.o gmain.c:191:81: poll.h: No such file or directory gmain.c:193: `poll' undeclared here (not in a function) gmain.c: In function `g_main_set_poll_func': gmain.c:1213: `poll' undeclared (first use in this function) gmain.c:1213: (Each undeclared identifier is reported only once gmain.c:1213: for each function it appears in.) make[4]: * [gmain.lo] Error 1 make[3]: * [all-recursive] Error 1 make[2]: * [all-recursive-am] Error 2 make[1]: * [all-recursive] Error 1 make: * [all-recursive-am] Error 2

Change History (2)

comment:1 Changed 17 years ago by blb@…

When you installed the devtools, did you include the DevSDK package? It contains (among other files of course) /usr/include/poll.h

comment:2 Changed 17 years ago by fkr@…

Resolution: invalid
Status: newclosed

can't reproduce on b85. -fkr

Note: See TracTickets for help on using tickets.