Opened 17 years ago

Closed 17 years ago

Last modified 17 years ago

#1218 closed defect (fixed)

tk won't compile on Panther

Reported by: pguyot (Paul Guyot) Owned by: jkh@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: charlie@…
Port:

Description

I'm doing: sudo port -d install tk

I don't have port tcl installed.

After compiling tcl successfully, this yields to: gcc -pipe -c -Os -Wall -Wconversion -Wno-implicit-int -fno-common -I/Volumes/Screwy/src/opendarwin/darwinports/dports/x11/tk/work/tk8.4.1/unix -I/Volumes/Screwy/src/opendarwin/darwinports/dports/x11/tk/work/tk8.4.1/unix/../generic -I/Volumes/Screwy/src/opendarwin/darwinports/dports/x11/tk/work/tk8.4.1/unix/../bitmaps -I/SourceCache/tcl/tcl-14/tcl/generic -I/usr/X11R6/include -DMAC_OSX_TCL -DHAVE_CFBUNDLE -DTCL_DEFAULT_ENCODING=\"utf-8\" -DHAVE_UNISTD_H=1 -DHAVE_LIMITS_H=1 -DTCL_WIDE_INT_TYPE=long\ long -DSTDC_HEADERS=1 -DHAVE_SYS_TIME_H=1 -DTIME_WITH_SYS_TIME=1 -DHAVE_PW_GECOS=1 -DTCL_NO_DEPRECATED -DUSE_TCL_STUBS /Volumes/Screwy/src/opendarwin/darwinports/dports/x11/tk/work/tk8.4.1/unix/../generic/tk3d.c In file included from /Volumes/Screwy/src/opendarwin/darwinports/dports/x11/tk/work/tk8.4.1/generic/tkPort.h:34,

from

/Volumes/Screwy/src/opendarwin/darwinports/dports/x11/tk/work/tk8.4.1/generic/tkInt.h:27,

from

/Volumes/Screwy/src/opendarwin/darwinports/dports/x11/tk/work/tk8.4.1/generic/tk3d.h:18,

from

/Volumes/Screwy/src/opendarwin/darwinports/dports/x11/tk/work/tk8.4.1/generic/tk3d.c:16: /Volumes/Screwy/src/opendarwin/darwinports/dports/x11/tk/work/tk8.4.1/unix/tkUnixPort.h:224:20: tclInt.h: No such file or directory make: * [tk3d.o] Error 1

Charlie (yeled) experienced the same error on his box.

Attachments (2)

port-buid-tk.log (70.6 KB) - added by pguyot (Paul Guyot) 17 years ago.
Complete log of a failure when building tk (without tcl port installed, hence relying on /usr/lib/tclConfig.sh)
Portfile.tk.diff (640 bytes) - added by pguyot (Paul Guyot) 17 years ago.
Patch to fix the port by telling it to look into tcl's port directory.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 17 years ago by pguyot (Paul Guyot)

blocked: 1217

comment:2 Changed 17 years ago by jkh@…

Resolution: worksforme
Status: newclosed

Builds and installs just fine for me on 10.3.1 - what's the sequence of events here? Are you starting with a stock 10.3 installation?

comment:3 Changed 17 years ago by pguyot (Paul Guyot)

Resolution: worksforme
Status: closedreopened

No, I'm doing it with my box. The problem is here:

# This port also needs to have tcl extracted in order to build pre-configure { portexec tcl build }

It actually needs to have tcl *installed* in order to build. Uninstall tcl and you'll see that bug.

comment:4 Changed 17 years ago by jkh@…

Resolution: worksforme
Status: reopenedclosed

tk doesn't use tcl from the ports collection, it uses tcl in the base system. The extracted version is *only* to be able to get at the internal headers. There shouldn't be *any* scenario where "tcl is uninstalled" on your machine unless you're destroying system components, which obviously you should not be doing.

comment:5 Changed 17 years ago by pguyot (Paul Guyot)

Resolution: worksforme
Status: closedreopened

Sure, I understand it's just to get the headers. However, there is no way, by just extracting/building tcl, that you can tell tk where to find the headers. By default, it will look into /SourceCache/tcl/tcl-14/tcl/generic. Cf log.

So you'll need to tell it where to find the headers. Cf patch.

BTW, it may work for you, but it doesn't work for the automated scripts, Charlie and I. I won't gonna spend time to install a stock 10.3 just to prove you wrong when there are so many evidences that this port is broken.

http://lamancha.opendarwin.org/~wbb4/html/tk/

Changed 17 years ago by pguyot (Paul Guyot)

Attachment: port-buid-tk.log added

Complete log of a failure when building tk (without tcl port installed, hence relying on /usr/lib/tclConfig.sh)

Changed 17 years ago by pguyot (Paul Guyot)

Attachment: Portfile.tk.diff added

Patch to fix the port by telling it to look into tcl's port directory.

comment:6 Changed 17 years ago by jkh@…

Resolution: fixed
Status: reopenedclosed
Note: See TracTickets for help on using tickets.