Opened 14 years ago

Closed 14 years ago

Last modified 12 years ago

#12510 closed defect (duplicate)

Mtree violation trying to install ghostscript

Reported by: smithsm@… Owned by: digdog@…
Priority: High Milestone:
Component: ports Version: 1.5.1
Keywords: Cc: smithsm@…, digdog@…, ryandesign (Ryan Schmidt)
Port:

Description

When I try to install xpdf using macports 1.510 it fails (actually on the first dependency ghostscript)

.... ---> Staging ghostscript into destroot Error: violation by /opt/local/man Error: Target org.macports.destroot returned: mtree violation!

I noticed in the archive that this problem was reported before and a new version of ghostscript is needed to fix it. When will the new version be posted as I am dead in the water until then.

I tried downgrading to macports 1.3.2 by deleting /opt and reinstalling but sudo port install xpdf chokes for some other reason

Also tried macports 1.4 but it has the mtree violation. So basically can't do anything with macports until its fixed.

Change History (7)

comment:1 Changed 14 years ago by smithsm@…

here is the failure in 1.3.2 albook:samuel$ sudo port install xpdf Password: Error: Unable to execute port: invalid command name "universal_variant"

comment:2 Changed 14 years ago by nox@…

Milestone: Port Bugs
Owner: changed from macports-dev@… to nox@…
Summary: Mtree violation trying to install portMtree violation trying to install xpdf
Version: 1.5.0

MacPorts 1.3.2 is outdated. I'll fix the problem.

comment:3 Changed 14 years ago by nox@…

Owner: changed from nox@… to macports-dev@…

Oh, I've misread the description, this is an mtree violation in ghostscript. So this ticket is a duplicate of #12496.

comment:4 Changed 14 years ago by nox@…

Summary: Mtree violation trying to install xpdfMtree violation trying to install ghostscript

comment:5 Changed 14 years ago by ryandesign (Ryan Schmidt)

Cc: smithsm@… digdog@… ryandesign@… added
Owner: changed from macports-dev@… to digdog@…
Version: 1.5.1

comment:6 Changed 14 years ago by ryandesign (Ryan Schmidt)

Resolution: duplicate
Status: newclosed

Duplicate of #12496.

comment:7 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.