Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#1252 closed defect (fixed)

Lack of contents listing of the ethereal port by the port(1) utility

Reported by: jmpalaciosp@… Owned by: eric@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc: jmpalaciosp@…
Port:

Description

The current install of the ethereal port fails to list its contents through the port(1) utility:

$[juan@PowerBook: darwinports](165/0,0)-> port contents ethereal Contents of ethereal-0.9.14

of

$[juan@PowerBook: darwinports](166/0,0)->

This contrasts with the behavior of other ports, for instance:

$[juan@PowerBook: darwinports](166/0,0)-> port contents nmap Contents of nmap-3.48

/opt/local/bin/nmap /opt/local/share/man/man1/nmap.1 /opt/local/share/nmap /opt/local/share/nmap/nmap-os-fingerprints /opt/local/share/nmap/nmap-protocols /opt/local/share/nmap/nmap-rpc /opt/local/share/nmap/nmap-service-probes /opt/local/share/nmap/nmap-services

$[juan@PowerBook: darwinports](167/0,0)->

Both ports live in a Mac OS X 10.3.1 system and are the current versions freshly checked out from CVS . However, the ethereal portfile was modified locally to allow a non-X11 build variant, with the adequate removal of the gtk2 library dependency. So, for completeness sake, the Portfile off which the ethereal port was built follows (my diff knowledge is limited!!):


# $Id: Portfile,v 1.17 2003/09/12 18:00:31 olegb Exp $

PortSystem 1.0 name ethereal version 0.9.14 categories net maintainers eric@… description Graphical network analyzer and capture tool homepage http://ethereal.com/ platforms darwin

long_description A network analyzer that lets you capture and \

interactively browse the contents of Ethernet frames. \ Packet data can be read from a file, or live from a local \ network interface.

master_sites ftp://ftp.ethereal.com/pub/ethereal/all-versions/ \

ftp://ftp.planetmirror.com/pub/ethereal/all-versions/ \ ftp://ftp.mirrors.wiretapped.net/pub/security/packet-capture/ethereal/all-versions/ \ ftp://gd.tuwien.ac.at/infosys/security/ethereal/all-versions/ \ ftp://ftp.sunet.se/pub/network/monitoring/ethereal/all-versions/ \ ftp://ftp.ayamura.org/pub/ethereal/all-versions/ \ ftp://ftp.azc.uam.mx/mirrors/ethereal/all-versions/

checksums md5 460ef7b71816316212cbdd26bb3ce0d3

use_bzip2 yes

depends_lib lib:libglib.1:glib

configure.args --without-plugins --enable-ethereal=no --with-ucdsnmp=no


Anything else needed to troubleshoot this do not hesitate to contact me!

Juan (jmpalaciosp@…)

Attachments (1)

patch-port.tcl (1.4 KB) - added by tp62@… 17 years ago.
patch for darwinports/base/src/port/port.tcl

Download all attachments as: .zip

Change History (5)

comment:1 Changed 17 years ago by jmpalaciosp@…

Summary: lack of contents listing of the ethereal port by the port(1) utilityLack of contents listing of the ethereal port by the port(1) utility

comment:2 Changed 17 years ago by opendarwin.org@…

When doing "port contents", the 'port' command does a simple lsearch for "contents" in the receipt file. If the dport has the word 'contents' in something else that ends up in the receipt file (such as the descriptions), 'port' finds that as the keyword 'contents' rather than the "real" one later in the file. A better pattern match is needed, perhaps "contents" or "contents {{" with associated logic- reworking for the indexing.

comment:3 Changed 17 years ago by opendarwin.org@…

Patch attached to bug #1253 removes the 'content' word from the description, resulting in a fix for ethereal, i.e. fixing the symptoms but not the cause.

Changed 17 years ago by tp62@…

Attachment: patch-port.tcl added

patch for darwinports/base/src/port/port.tcl

comment:4 Changed 17 years ago by jkh@…

Resolution: fixed
Status: newclosed

Fix for port.tcl taken, which fixes the essential problem here so no changes to ethereal are necessary.

Note: See TracTickets for help on using tickets.