Opened 14 years ago

Closed 13 years ago

#12602 closed enhancement (fixed)

real author in "From" header in svn commit log emails

Reported by: jmpp@… Owned by: jmpp@…
Priority: Normal Milestone:
Component: server/hosting Version:
Keywords: real author, commit log message Cc: macports-mgr@…
Port:

Description

All commit log mails sent to the changes mailing list come from the single source_changes "user", making it harder to find the real commit author out of mail headers. It would be great to configure the svn hook that sends these mails to use the real author in the From header field, leaving it up to them to subscribe to the mailing list for their posts to be accepted if need be.

-jmpp

Change History (7)

comment:1 Changed 13 years ago by wsiegrist@…

Owner: changed from kvv@… to jmpp@…

Author is the 2nd line of the colored Diff output. Do you really want the emails addressed from the authors too? Like you mentioned, it means the emails to -changes will get deferred if they arent on the list, which is just more admin work for the owner(s) of that list.

comment:2 in reply to:  1 Changed 13 years ago by jmpp@…

Replying to wsiegrist@apple.com:

Author is the 2nd line of the colored Diff output. Do you really want the emails addressed from the authors too? Like you mentioned, it means the emails to -changes will get deferred if they arent on the list, which is just more admin work for the owner(s) of that list.

Yes, having the commit author as the mail remittent would be a big plus for many reasons in my opinion, even though the information is already there in the mail body.

And about committers signing up to the list, that's not much of a problem since we *should* all be there, to stay on top of changes as they happen ;-) I've been forgetting to request newcomers to subscribe to our lists, but I already added that part to my template mail. As for existing members, I'll post to the dev list reminding everyone they need to be subscribed to changes.

So, please, make the change ;-) Thanks!

-jmpp

comment:3 Changed 13 years ago by wsiegrist@…

Done with this. Verify it next time someone commits to macports then go ahead and close the ticket if it looks good.

comment:4 in reply to:  3 Changed 13 years ago by jmpp@…

Resolution: fixed
Status: newclosed

Replying to wsiegrist@apple.com:

Done with this. Verify it next time someone commits to macports then go ahead and close the ticket if it looks good.

Seems to be working great, my latest commit mail was posted as coming from jmpp a t macports.org, rather than the generic address that was being used until now.

Thanks for making things happen, Bill. Much appreciated! Closing ticket.

-jmpp

comment:5 Changed 13 years ago by jmpp@…

Small comment about mails sent by trac: those on the ticket Cc field don't seem to get added explicitly to the Cc header field on the messages. I have a couple of tickets, like this one, in which macports-mgr@… is Cc'd; but when the ticket are changed and mails are generated, macports-mgr is nowhere to be found on the messages Cc field (but they do get there!) and therefore Mailman (for macports-mgr) holds them as having "Implicit destination". Is this expected behavior or a bug? Can it be changed so that those on the ticket Cc are Cc'd explicitly in generated mails?

-jmpp

comment:6 Changed 13 years ago by wsiegrist@…

Resolution: fixed
Status: closedreopened

Yes, it can be changed. Currently the recipients are hidden (Bcc'd), I assume just to protect from harvesting, privacy, etc. I can enable the "use_public_cc" option on your trac which will add the "To:" and "Cc:" fields to all the notification emails.

comment:7 Changed 13 years ago by jmpp@…

Resolution: fixed
Status: reopenedclosed

Mail recipients are now properly addressed and mailman does not bounce the messages as having implicit destination. Ticket resolved, closing.

-jmpp

Note: See TracTickets for help on using tickets.