Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#12663 closed defect (fixed)

avr-binutils patches not applied

Reported by: kintel@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: Cc: pguyot (Paul Guyot), metamagix@…
Port:

Description

When installing avr-binutils @2.16.1, the patches are not applied.

Running "port -d -v patch avr-binutils" displays "DEBUG: Executing org.macports.patch (avr-binutils)", but no details about the patch process. Examining the files in the work directory also shows no trace of the patches.

Looking at the Portfile, it has a patch section in addition to a patchfiles section, which might be (one of) the reason(s) why the patchfiles section is ignored..

Change History (5)

comment:1 Changed 12 years ago by nox@…

Milestone: Port Bugs

comment:2 Changed 12 years ago by nox@…

Cc: pguyot@… metamagix@… added

comment:3 Changed 12 years ago by kintel@…

Update: Comparing the Portfile to other Portfiles, it looks like the "patch {" block cannot coexist with "patchfiles", and it should be called "post-patch {" instead. If I change this, it patches are applied as intended. However, the patches are not actually made against the correct version of binutils, and thus fail to apply.

-> It looks like this port was broken from the start. Is this port (together with the other avr-* ports) actually maintained?

comment:4 Changed 12 years ago by pguyot (Paul Guyot)

Resolution: fixed
Status: newclosed

Fixed in r29582 kintel@, I authored the avr ports, but I don't use them, hence the double maintainers. I can add you to the list of maintainers if you're unhappy with the maintenance.

comment:5 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.