Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#12903 closed defect (fixed)

openssl should not use cd command

Reported by: ryandesign (Ryan Schmidt) Owned by: mww@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc: ryandesign (Ryan Schmidt), mww@…
Port:

Description

I'm running MacPorts from trunk and cannot upgrade openssl because it uses the deprecated cd command:

$ sudo port upgrade openssl
Portfile changed since last build; discarding previous state.
--->  Fetching openssl
--->  Attempting to fetch openssl-0.9.8f.tar.gz from http://www.openssl.org/source/
--->  Verifying checksum(s) for openssl
--->  Extracting openssl
--->  Applying patches to openssl
--->  Configuring openssl
Error: Target org.macports.configure returned: invalid command name "cd"
Error: Unable to upgrade port: 1
$

Change History (2)

comment:1 Changed 11 years ago by mww@…

Resolution: fixed
Status: newclosed

comment:2 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.