Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#13003 closed defect (fixed)

lzo2 install quits with error on Leopard

Reported by: fauconnier.steven@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: lzo2 leopard Cc: yunzheng.hu@…, fauconnier.steven@…, rtiainen+macosforge@…
Port:

Description

Tried installing mplayer on Leopard with MacPorts 1.5.0.
It returned the following two errors when trying to make the lzo2 dependency:

Steven:~ Steven$ sudo port install mplayer
Password:
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_archivers_lzo2/work/lzo-2.02" && make all " returned error 2
Command output:       _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
  "_lzo1f_decompress_asm_fast", referenced from:
      _compress_database in lzotest.o
      _compress_database in lzotest.o
  "_lzo1x_decompress_asm_fast_safe", referenced from:
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
      _compress_database in lzotest.o
ld: symbol(s) not found
collect2: ld returned 1 exit status
make[2]: *** [lzotest] Error 1
make[1]: *** [all-recursive] Error 1
make: *** [all] Error 2

Error: The following dependencies failed to build: lzo2
Error: Status 1 encountered during processing.

Attachments (1)

no-assembly-patch.diff (417 bytes) - added by yunzheng.hu@… 12 years ago.
configures using --no-assembly which will fix compiling under leopard

Download all attachments as: .zip

Change History (6)

comment:1 Changed 12 years ago by yunzheng.hu@…

this seems to be caused by the compiled assembly object files that doesnt seem include their functions when linking the final .dylib..

i attached a patch that configures using --no-assembly which will fix the problem until we can find out why it really fails.

Changed 12 years ago by yunzheng.hu@…

Attachment: no-assembly-patch.diff added

configures using --no-assembly which will fix compiling under leopard

comment:2 Changed 12 years ago by afb@…

Resolution: fixed
Status: newclosed

Fixed in r30456, but only disable asm for Leopard.

comment:3 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: fauconnier.steven@… rtiainen+macosforge@… added
Milestone: Port Bugs

comment:4 Changed 12 years ago by ryandesign (Ryan Schmidt)

Has duplicate #12876.

comment:5 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.