Opened 17 years ago

Closed 17 years ago

Last modified 16 years ago

#1304 closed defect (invalid)

permission problems with mysql4 +server

Reported by: garry@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.0
Keywords: Cc:
Port:

Description

this doesn't seem to be related to the other open mysql server bug but i'm not sure.

with a newly cvs updated mysql port everything compiles fine but then bombs out. ie.:

Error: Target com.apple.destroot returned: shell command "chown mysql:mysql /Volumes/bones/ Manipulation/darwinports/dports/databases/mysql4/work/destroot/opt/local/var/log/mysql" returned error 1 Command output: chown: /Volumes/bones/Manipulation/darwinports/dports/databases/mysql4/ work/destroot/opt/local/var/log/mysql: Operation not permitted

if you run the same command as root sudo port install mysql4 +server the installation goes without a hitch. so maybe it's not a bug after all.

then when you try to run the server you get something similar:

chown: /opt/local/var/db/mysql/big-grey.local.err: Operation not permitted

where big-grey.local is the hostname of the machine.

the permissions on the directories are wrong i guess;

/opt/local/var/db/mysql is owned by me as are all the files and directories under it. i've tried chown -R mysql:mysql /opt/local/var/db/mysql but it's made no difference.

Change History (2)

comment:1 Changed 17 years ago by tp62@…

Resolution: invalid
Status: newclosed

From man chown: "The ownership of a file may only be altered by a super-user for obvious security reasons."

Just start the server as root.

comment:2 Changed 17 years ago by bchesneau@…

Do all the actions you mentionned as super user or root

  • for install port :

sudo port install mysql4 +server

  • sudo chown -R mysql:mysql /opt/local/var/db/mysql

Then it should work.

  • Benoit
Note: See TracTickets for help on using tickets.