Opened 13 years ago

Closed 12 years ago

#13063 closed defect (invalid)

kdepim3 3.5.8_0 won't build

Reported by: breacher@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.0
Keywords: kde kdepim 3.5.8 Cc: breacher@… takanori@…
Port:

Description (last modified by jmpp@…)

--->  Building kdepim3 with target all
Error: Target org.macports.build returned: shell command "cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8 && ./CompileScript.sh" returned error 1
Command output: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/tagnode.cpp:214: warning: unused parameter 'node'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/tagnode.cpp:250: warning: unused parameter 'node'
61% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/folder.cpp
61% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/nodelist.cpp
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/nodelist.cpp:121: warning: unused parameter 'parent'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/nodelist.cpp:121: warning: unused parameter 'name'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/nodelist.cpp:121: warning: unused parameter 'parent'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/nodelist.cpp:121: warning: unused parameter 'name'
61% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/feedlist.cpp
61% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/tagnodelist.cpp
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/tagnodelist.cpp:169: warning: unused parameter 'doc'
62% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/fetchqueue.cpp
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/fetchqueue.cpp: In member function 'void Akregator::FetchQueue::fetchNextFeed()':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/fetchqueue.cpp:85: warning: comparison between signed and unsigned integer expressions
62% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/feediconmanager.cpp
62% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/tagset.cpp
62% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/storagedummyimpl.cpp
62% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/akregator/src/simplenodeselector.cpp
62% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditordialog.cpp
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditordialog.cpp:38: warning: unused parameter 'core'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditordialog.cpp:38: warning: unused parameter 'core'
62% compiling /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditorwidget.cpp
g++ -DHAVE_CONFIG_H -I./kaddressbook -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook -I. -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/interfaces -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/features -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/views -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/printing -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/common -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/editors -I./kaddressbook/common -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8 -I/kaddressbook/editors -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/libkdepim -I/opt/local/include -I/opt/local/lib/qt3/include -I/usr/X11R6/include -I/opt/local/include -DQT_THREAD_SUPPORT -I/opt/local/include/freetype2 -I/opt/local/include -fno-common -no-cpp-precomp -DMACOSX -DARTS_NO_ALARM -I/opt/local/include -I/usr/X11R6/include -D_LARGE_FILES=1 -Wno-long-long -Wundef -Wall -W -Wpointer-arith -Os -Os -fPIC -Wno-non-virtual-dtor -fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE -DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION -fPIC -DPIC -c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditorwidget.cpp -o ./kaddressbook/.libs/addresseeeditorwidget.o -Wp,-MD,./kaddressbook/.deps/addresseeeditorwidget.TUlo
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditorwidget.cpp: In member function 'virtual void AddresseeEditorWidget::load()':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditorwidget.cpp:532: error: 'class KABC::Addressee' has no member named 'department'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditorwidget.cpp:534: error: 'class KABC::Addressee' has no member named 'department'
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditorwidget.cpp: In member function 'virtual void AddresseeEditorWidget::save()':
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kaddressbook/addresseeeditorwidget.cpp:578: error: 'class KABC::Addressee' has no member named 'setDepartment'
Error creating ./kaddressbook/addresseeeditorwidget.lo. Exit status 1.
kdepim3-3.5.8-0 make failed!

Attachments (3)

kdepim3.buildlog.txt (17.2 KB) - added by takanori@… 13 years ago.
kdepim3.buildlog.2.txt (17.5 KB) - added by takanori@… 13 years ago.
make.log (66.1 KB) - added by syrabo@… 13 years ago.
to comment from 2008-01-28 12:23:39

Download all attachments as: .zip

Change History (14)

comment:1 Changed 13 years ago by ryandesign (Ryan Schmidt)

Cc: breacher@… added
Summary: kdepim3 from from kde 3.5.8 won't buildkdepim3 3.5.8_0 won't build

comment:2 Changed 13 years ago by takanori@…

Cc: breacher@… added; breacher@… removed

I could not reproduce such problem. My buildlog is here:

Changed 13 years ago by takanori@…

Attachment: kdepim3.buildlog.txt added

Changed 13 years ago by takanori@…

Attachment: kdepim3.buildlog.2.txt added

comment:3 Changed 13 years ago by breacher@…

Well, I just did port clean kdepim3 && port sync && port install kdepim3 and got the exact same error.

I got a MacBook2,1 with MacOS X 10.4.10.

I'm not sure what to do :(

comment:4 Changed 13 years ago by takanori@…

Have you installed (and activated) kdelibs3 @3.5.8_0? Maybe you are not using the correct version of kdelibs.

Please check the result of the following command:

$ port installed kde*

I'm not sure what to do :(

Don't worry, me too. ;-)

comment:5 Changed 13 years ago by breacher@…

allright

I did rebuild kdelibs 3.5.8_0 and then kdepim did build. Weird, cause I was sure kdelibs already rebuilt.

Anyway I consider my problem solved :)

Now I get empty page when I try to configure folders, but that's another story...

comment:6 Changed 13 years ago by breacher@…

configure desktop*

comment:7 Changed 13 years ago by syrabo@…

kdepim3 build failure. The is kdelibs3 @3.5.8_2:

---> Building kdepim3 with target all Error: Target org.macports.build returned: shell command "cd /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8 && ./CompileScript.sh" returned error 1 Command output: kxml_compiler: substituteReferences for 'attlist.em' kxml_compiler: REF strong kxml_compiler: substituteReferences for 'strong' kxml_compiler: substituteReferences for 'strong' kxml_compiler: REF attlist.strong kxml_compiler: substituteReferences for 'attlist.strong' kxml_compiler: REF br kxml_compiler: substituteReferences for 'br' kxml_compiler: substituteReferences for 'br' kxml_compiler: REF attlist.br kxml_compiler: substituteReferences for 'attlist.br' kxml_compiler: REF responsible kxml_compiler: substituteReferences for 'responsible' kxml_compiler: substituteReferences for 'responsible' kxml_compiler: REF attlist.responsible kxml_compiler: substituteReferences for 'attlist.responsible' kxml_compiler: REF category kxml_compiler: Don't resolve self reference kxml_compiler: Begin creating code kxml_compiler: Create classes kxml_compiler: Create parser kxml_compiler: Creator::createFileParserCustom() kxml_compiler: Begin printing code kxml_compiler: Print external parser. kxml_compiler: Print header kxml_compiler: Print implementation kxml_compiler: Finished. Error creating ./kresources/featureplan/kde-features.h. Exit status 140. ../../kode/kxml_compiler/kxml_compiler --custom-parser /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kresources/featureplan/kde-features.rng kdepim3-3.5.8-0 make failed!

Changed 13 years ago by syrabo@…

Attachment: make.log added

to comment from 2008-01-28 12:23:39

comment:8 Changed 13 years ago by jmpp@…

Description: modified (diff)
Priority: HighNormal

comment:9 Changed 13 years ago by syrabo@…

A solution found on: http://grey.colorado.edu/oreilly/index.php/KDE_on_Mac

quote:

cd  /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kresources/featureplan/kresources/featureplan/
../../kode/kxml_compiler/kxml_compiler --custom-parser /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_kde_kdepim3/work/kdepim-3.5.8/kresources/featureplan/kde-features.rng


comment:10 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:11 Changed 12 years ago by takanori@…

Resolution: invalid
Status: newclosed

KDE 3.5.8 is too old. Please try the latest version.

Note: See TracTickets for help on using tickets.