Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#13121 closed defect (duplicate)

Freeimage Fails to build on Darwin 9 (Leopard)

Reported by: brianjlandau@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: freeimage bug leopard Cc: brianjlandau@…, ryand-ruby@…
Port:

Description

Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_graphics_freeimage/work/FreeImage" && make all " returned error 2
Command output: Source/FreeImage/BitmapAccess.cpp:813: error: expected `;' before 'TAGMAP'
Source/FreeImage/BitmapAccess.cpp:821: error: 'strcmp' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:825: error: 'FreeImage_GetTagCount' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:825: error: 'WORD' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:825: error: 'FreeImage_TagDataWidth' cannot be used as a function
Source/FreeImage/BitmapAccess.cpp:825: error: 'FreeImage_GetTagLength' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:839: error: 'WORD' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:858: error: 'TAGMAP' is not a class or namespace
Source/FreeImage/BitmapAccess.cpp:858: error: 'iterator' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:858: error: expected `;' before 'i'
Source/FreeImage/BitmapAccess.cpp:859: error: 'i' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:869: error: 'TAGMAP' is not a class or namespace
Source/FreeImage/BitmapAccess.cpp:869: error: 'iterator' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:869: error: expected `;' before 'i'
Source/FreeImage/BitmapAccess.cpp:869: error: 'i' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:874: error: type '<type error>' argument given to 'delete', expected pointer
Source/FreeImage/BitmapAccess.cpp: In function 'BOOL FreeImage_GetMetadata(FREE_IMAGE_MDMODEL, FIBITMAP*, const char*, FITAG**)':
Source/FreeImage/BitmapAccess.cpp:887: error: 'TAGMAP' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:887: error: 'tagmap' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:891: error: 'METADATAMAP' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:891: error: 'metadata' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:891: error: 'struct FREEIMAGEHEADER' has no member named 'metadata'
Source/FreeImage/BitmapAccess.cpp: In function 'unsigned int FreeImage_GetMetadataCount(FREE_IMAGE_MDMODEL, FIBITMAP*)':
Source/FreeImage/BitmapAccess.cpp:912: error: 'TAGMAP' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:912: error: 'tagmap' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:915: error: 'METADATAMAP' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:915: error: 'metadata' was not declared in this scope
Source/FreeImage/BitmapAccess.cpp:915: error: 'struct FREEIMAGEHEADER' has no member named 'metadata'
make[1]: *** [Source/FreeImage/BitmapAccess.o-ppc] Error 1
make: *** [all] Error 2

Change History (2)

comment:1 Changed 11 years ago by ryandesign (Ryan Schmidt)

Cc: brianjlandau@… added
Resolution: duplicate
Status: newclosed

Duplicate of #13018.

comment:2 Changed 10 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.