Opened 13 years ago

Closed 13 years ago

Last modified 10 years ago

#13149 closed defect (fixed)

macports-notifier fails to build on case-sensitive FS

Reported by: jfannin@… Owned by: rhwood@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: jfannin@…
Port: macports-notifier

Description

When building macports-notifier, a file is not found on a case-sensitive filesystem due to differing case:

<com.apple.tools.info-plist-utility> /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_macports-notifier/work/trunk/info.plist
-genpkginfo
"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_macports-notifier/work/trunk/build/Release/MacPorts Notifier.app/Contents/PkgInfo"
-expandbuildsettings -o
"/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_macports-notifier/work/trunk/build/Release/MacPorts Notifier.app/Contents/Info.plist"
error: The file “info.plist” does not exist.
** BUILD FAILED **

The problem is in 'PortsNotifier.xcodeproj/project.pbxproj' , under '/* Begin XCBuildConfiguration section */' -- there are two lines that say 'INFOPLIST_FILE = info.plist;' while the file is "Info.plist". After changing those two lines the port built and installed fine.

This is present in upstream's SVN also.

Change History (4)

comment:1 Changed 13 years ago by rhwood@…

Milestone: Port Bugs
Status: newassigned

Fixed in upstream source repository.

comment:2 Changed 13 years ago by rhwood@…

Resolution: fixed
Status: assignedclosed

Since the portfile gets the application directly from the source code repository, there is nothing in it to fix once the fix is upstream.

Thanks for reporting this.

comment:3 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:4 Changed 10 years ago by ryandesign (Ryan Schmidt)

Port: macports-notifier added

Yes, there was; see #30880.

Note: See TracTickets for help on using tickets.