Opened 12 years ago

Closed 12 years ago

Last modified 11 years ago

#13223 closed defect (fixed)

boost fails to build on Mac OS X 10.5 Leopard

Reported by: brianjlandau@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version:
Keywords: boost Cc: sanchom (Sancho McCann), rhwood@…, brianjlandau@…, takanori@…
Port:

Description

Running on a Intel MacBook Pro MacOS X 10.5 Leopard MacPorts 1.5.2 (for 10.5) & Xcode 3.0

Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_34_1" && make all " returned error 2
Command output: Makefile:2: *** missing separator.  Stop.

Attachments (2)

Portfile (3.1 KB) - added by ralf@… 12 years ago.
fixed Portfile for OSX 10.5. Pulls in pristine GNU make on this platform (darwin 9).
boost.diff (317 bytes) - added by takanori@… 12 years ago.
suggested patch (tested on leopard/ppc)

Download all attachments as: .zip

Change History (13)

comment:1 Changed 12 years ago by nox@…

Cc: sanchom@… added
Summary: boost fails to buildboost fails to build on Mac OS X 10.5 Leopard

comment:3 Changed 12 years ago by ralf@…

A (temporary) workaround: I installed gmake through MacPorts, made a symlink in /opt/local/bin from gmake to make, made sure that /opt/local/bin was first in PATH and also set the environment variable MAKE=gmake. Using these kludges I was able to build boost +python25 without trouble. I need to investigate further, whether a simple MAKE=gmake can be used to solve this issue (without reverting to symlinking).

comment:4 in reply to:  3 Changed 12 years ago by sanchom (Sancho McCann)

I (the maintainer) haven't upgraded yet to 10.5 Leopard... I probably should. So any help from others to find a fix/workaround to this problem would be a great help. Thanks to ralf for starting to look into this.

comment:5 in reply to:  3 Changed 12 years ago by tomaz.solc@…

I can confirm that the following command works for me (OS X 10.5, PPC):

MAKE=/opt/local/bin/gmake sudo port install boost

(Of course I first had to install gmake)

Thanks.

Changed 12 years ago by ralf@…

Attachment: Portfile added

fixed Portfile for OSX 10.5. Pulls in pristine GNU make on this platform (darwin 9).

comment:6 Changed 12 years ago by ralf@…

tomaz.solc@…: Great! Thanks for the confirmation. This means the attached Portfile should close the bug.

comment:7 Changed 12 years ago by afb@…

Resolution: fixed
Status: newclosed

Committed, r31716.

comment:8 Changed 12 years ago by takanori@…

Cc: takanori@… added
Resolution: fixed
Status: closedreopened

Seems that this problem has not been fixed properly in r31716. Here is my buildlog:

$ sudo port install boost
--->  Fetching boost-jam
--->  Attempting to fetch boost-jam-3.1.15.tgz from http://downloads.sourceforge.net/boost
--->  Verifying checksum(s) for boost-jam
--->  Extracting boost-jam
--->  Configuring boost-jam
--->  Building boost-jam
--->  Staging boost-jam into destroot
--->  Installing boost-jam 3.1.15_0
--->  Activating boost-jam 3.1.15_0
--->  Cleaning boost-jam
--->  Fetching gmake
--->  Attempting to fetch make-3.81.tar.bz2 from http://ftp.gnu.org/gnu/make
--->  Verifying checksum(s) for gmake
--->  Extracting gmake
--->  Configuring gmake
--->  Building gmake with target all
--->  Staging gmake into destroot
--->  Installing gmake 3.81_0
--->  Activating gmake 3.81_0
--->  Cleaning gmake
--->  Fetching boost
--->  Attempting to fetch boost_1_34_1.tar.bz2 from http://downloads.sourceforge.net/boost
--->  Verifying checksum(s) for boost
--->  Extracting boost
--->  Configuring boost
--->  Building boost with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_devel_boost/work/boost_1_34_1" && make all " returned error 2
Command output: Makefile:2: *** missing separator.  Stop.

Error: Status 1 encountered during processing.

Changed 12 years ago by takanori@…

Attachment: boost.diff added

suggested patch (tested on leopard/ppc)

comment:9 Changed 12 years ago by lhirlimann@…

The attachment also works on Leopard/Intel.

comment:10 Changed 12 years ago by takanori@…

Resolution: fixed
Status: reopenedclosed

Fixed in r31854.

comment:11 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.