Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#13235 closed defect (fixed)

BUG: libbonobo should not depend on broken port p5-getopt-long

Reported by: vinc17@… Owned by: rhwood@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: vinc17@…, rhwood@…, nox@…
Port:

Description

The runtime dependency on p5-getopt-long should be removed: The user should not be forced to install a broken port (p5-getopt-long). And the dependency is not necessary since Getopt::Long is already provided by the perl5.8 port.

Change History (2)

comment:1 Changed 13 years ago by nox@…

Cc: vinc17@… rhwood@… nox@… added; vinc17@… removed
Resolution: fixed
Status: newclosed

You're right. I've added this dependency in my latest commits because there's a bug when trace mode is enabled and p5-getopt-long is installed.

I've removed it in r30905.

comment:2 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.