Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#13337 closed defect (fixed)

BUG: py25-gobject fails at runtime under Leopard (10.5.1)

Reported by: tc@… Owned by: yves@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: pmq@…, tc@…
Port:

Description

Running KedPM in X11 gives this output:

Traceback (most recent call last):
File "/opt/local/bin/kedpm", line 67, in <module>
  main(sys.argv[1:])
File "/opt/local/bin/kedpm", line 57, in main
  app = frontendFactory(frontend)
File "/opt/local/lib/python2.5/site-packages/kedpm/frontends/__init__.py", line 35, in frontendFactory
  from kedpm.frontends.gtk.app import Application
File "/opt/local/lib/python2.5/site-packages/kedpm/frontends/gtk/__init__.py", line 4, in <module>
  import gtk.glade
File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-gtk/work/destroot/opt/local/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 38, in <module>
File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-gobject/work/destroot/opt/local/lib/python2.5/site-packages/gtk-2.0/gobject/__init__.py", line 30, in <module>
File "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_python_py25-gobject/work/destroot/opt/local/lib/python2.5/site-packages/gtk-2.0/gobject/constants.py", line 22, in <module>
ImportError: dlopen(/opt/local/lib/python2.5/site-packages/gtk-2.0/gobject/_gobject.so, 2): Symbol not found: _PyGBoxed_Type
Referenced from: /opt/local/lib/python2.5/site-packages/gtk-2.0/gobject/_gobject.so
Expected in: flat namespace

Running KedPM with the CLI gives this output:

Traceback (most recent call last):
  File "/opt/local/bin/kedpm", line 67, in <module>
    main(sys.argv[1:])
  File "/opt/local/bin/kedpm", line 57, in main
    app = frontendFactory(frontend)
  File "/opt/local/lib/python2.5/site-packages/kedpm/frontends/__init__.py", line 32, in frontendFactory
    from kedpm.frontends.cli import Application
  File "/opt/local/lib/python2.5/site-packages/kedpm/frontends/cli.py", line 33, in <module>
    import readline
ImportError: No module named readline

Change History (12)

comment:1 Changed 13 years ago by pmq@…

Milestone: Port Bugs
Owner: changed from macports-dev@… to pmq@…
Status: newassigned

Second bug is corrected. You can selfupdate in a few hours to test again. I just added a dependency on py25-readline.
For the first bug, I can't reproduce on Tiger. Can you try uninstall/rebuilding from scratch the following ports: glib2, py25-gobject.

comment:2 in reply to:  1 ; Changed 13 years ago by tc@…

Replying to pmq@macports.org:

Second bug is corrected. You can selfupdate in a few hours to test again. I just added a dependency on py25-readline.
For the first bug, I can't reproduce on Tiger. Can you try uninstall/rebuilding from scratch the following ports: glib2, py25-gobject.

Just tried the CLI again, it is working now.

I have tried the suggestions for the first bug. I reinstalled the two ports using:
port uninstall -f <port>
port clean --archive <port>
port install -f <port>

but I am still getting the same message.

Could this be an issue to do with Leopards new implementation of X11?

comment:3 in reply to:  2 Changed 13 years ago by pmq@…

Summary: BUG: kedpm 0.4.1-cvs will not run in x11 or CLI under Leopard (10.5.1)BUG: kedpm 0.4.1-cvs will not run in x11 under Leopard (10.5.1)

Replying to tc@pi3.co.uk:

Could this be an issue to do with Leopards new implementation of X11?

I don't think so. Could you rebuild using the same commands py25-gtk? And if it stills fails, rebuild gtk2 + libglade2 + py25-gtk? As I'm not maintaining these ports, if it still doesn't work, you'll need to reassign the bug to one of those ports' maintainer, they have probably more wisdom than me on that matter.

comment:4 in reply to:  2 ; Changed 13 years ago by skymoo (Adam Mercer)

Replying to tc@pi3.co.uk:

Could this be an issue to do with Leopards new implementation of X11?

Leopard's libX11 has a bug that causes gtk+ apps to crash, there's an unofficial update from Apples X11 maintainer available at http://www.x.org/wiki/XDarwin see if installed that helps.

comment:5 in reply to:  4 Changed 13 years ago by tc@…

Replying to pmq@macports.org:

I don't think so. Could you rebuild using the same commands py25-gtk? And if it stills fails, rebuild gtk2 + libglade2 + py25-gtk? As I'm not maintaining these ports, if it still doesn't work, you'll need to reassign the bug to one of those ports' maintainer, they have probably more wisdom than me on that matter.

I have tried all of those, still getting the same error.

I'm not sure how to reassign the bug though.

Replying to ram@macports.org:

Leopard's libX11 has a bug that causes gtk+ apps to crash, there's an unofficial update from Apples X11 maintainer available at http://www.x.org/wiki/XDarwin see if installed that helps.

I have installed the updates as well now and I am still getting the error.

comment:6 Changed 13 years ago by pmq@…

Owner: changed from pmq@… to yves@…
Status: assignednew
Summary: BUG: kedpm 0.4.1-cvs will not run in x11 under Leopard (10.5.1)BUG: py25-gobject fails at runtime under Leopard (10.5.1)

Sorry to assign this bug to you Yves, but I'm a bit lost too as to whom I should contact on this report. As you maintain py-gobject, you might be able to see where the error stems from? Thanks!

comment:7 Changed 13 years ago by conehead@…

Hi, is there any progress on this?

comment:8 Changed 13 years ago by cwalther@…

I have no idea what I'm doing, but I seem to be able to circumvent the problem by applying this change to py25-gobject:

--- gobject/Makefile.in
+++ gobject/Makefile.in
@@ -259,7 +259,7 @@
 CLEANFILES = constants.py
 EXTRA_DIST = constants.py.in
 _gobject_la_CFLAGS = $(GLIB_CFLAGS) $(am__append_3)
-_gobject_la_LDFLAGS = $(common_ldflags) -export-symbols-regex init_gobject
+_gobject_la_LDFLAGS = $(common_ldflags)
 _gobject_la_LIBADD = $(GLIB_LIBS) $(FFI_LIBS)
 _gobject_la_SOURCES = \
 	gobjectmodule.c \

After this is done, import gtk results in errors of the same kind from _gtk.so and _cairo.so that can be treated in the same way. Or, as an even quicker-and-dirtier workaround, use

cd /usr/bin
mv nmedit nmedit-real
ln -s true nmedit

while installing these packages.

Hope this helps someone find and fix the real bug.

comment:9 Changed 13 years ago by ptman (Paul Tötterman)

It's working for me now, apparently thanks to [32469].

comment:10 in reply to:  9 Changed 13 years ago by tc@…

Replying to paul.totterman@gmail.com:

It's working for me now, apparently thanks to [32469].

Also working for me now.

comment:11 Changed 13 years ago by afb@…

Resolution: fixed
Status: newclosed

Workaround seems to work.

comment:12 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.