New Ticket     Tickets     Wiki     Browse Source     Timeline     Roadmap     Ticket Reports     Search

Ticket #13389 (closed defect: duplicate)

Opened 6 years ago

Last modified 5 years ago

python25 restFP build error with latest portfile on OS 10.4

Reported by: crkrenn@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: jwelp1@…
Port:

Description

Hello,

I'm having trouble installing python25 using macports 1.520 on a PPC iBook with OS 10.4.

I've done "port selfupdate", "port clean python25", "port upgrade python25", and I still get a linking error with the latest (rev 3) portfile:

Do you have any suggestion for fixing or diagnosing this? I tried the older solutions of adding gcc libraries to the python makefile with no luck.

Thanks!

-Chris

error below:

ranlib libpython2.5.a libtool -o libpython2.5.dylib -dynamic \

-all_load libpython2.5.a -single_module \ -install_name /opt/local/lib/libpython2.5.dylib \ -compatibility_version 2.5 \ -current_version 2.5 -lSystem -lSystemStubs -L/opt/local/lib

ld: for architecture ppc ld: warning prebinding disabled because of undefined symbols ld: Undefined symbols: restFP saveFP libtool: internal link edit command failed make: * [libpython2.5.dylib] Error 1

Change History

comment:1 Changed 6 years ago by thijsvermeir@…

I have the same bug on a clean install of macports...

comment:2 Changed 6 years ago by yves@…

This is a rather stupid bug.

Why does python use libtool instead of gcc as link command anyway ?

gcc would link automatically with libc.

Or else, libtool should just be passed the -lc flag explicitly.

comment:3 Changed 6 years ago by ryandesign@…

  • Cc jwelp1@… added
  • Milestone set to Port Bugs

comment:4 Changed 6 years ago by ryandesign@…

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of #13322 which has been fixed.

comment:5 Changed 5 years ago by anonymous

  • Milestone Port Bugs deleted

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.