Opened 13 years ago

Closed 11 years ago

#13503 closed defect (fixed)

freeradius does not compile under Leopard (10.5.1)/Intel

Reported by: jms@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.5.2
Keywords: Cc: richard@…, icebeing_cm@…, ryandesign (Ryan Schmidt)
Port: freeradius

Description (last modified by jmroot (Joshua Root))

Under Leopard (10.5.1) on Intel CPU, FreeRADIUS does not compile.

--->  Fetching freeradius
--->  Attempting to fetch freeradius-1.1.7.tar.gz from ftp://ftp.freeradius.org/pub/radius/
--->  Verifying checksum(s) for freeradius
--->  Extracting freeradius
--->  Configuring freeradius
--->  Building freeradius with target all
Error: Target org.macports.build returned: shell command " cd "/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_freeradius/work/freeradius-1.1.7" && make all " returned error 2
Command output: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_freeradius/work/freeradius-1.1.7/libtool --mode=compile gcc  -O2 -I/opt/local/include -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DDARWIN -Wall -D_GNU_SOURCE -DNDEBUG  -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_freeradius/work/freeradius-1.1.7/src/include -arch i386 -arch ppc -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -Wdeclaration-after-statement -I/usr/local/include  -I/System/Library/Perl/5.8.8/darwin-thread-multi-2level/CORE -no-cpp-precomp -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -Wdeclaration-after-statement -I/usr/local/include -c rlm_perl.c
mkdir .libs
 gcc -O2 -I/opt/local/include -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DDARWIN -Wall -D_GNU_SOURCE -DNDEBUG -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_freeradius/work/freeradius-1.1.7/src/include -arch i386 -arch ppc -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -Wdeclaration-after-statement -I/usr/local/include -I/System/Library/Perl/5.8.8/darwin-thread-multi-2level/CORE -no-cpp-precomp -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -Wdeclaration-after-statement -I/usr/local/include -c rlm_perl.c  -fno-common -DPIC -o .libs/rlm_perl.o
rlm_perl.c: In function 'perl_xlat':
rlm_perl.c: In function 'perl_xlat':rlm_perl.c:658: warning: ISO C90 forbids mixed declarations and code
rlm_perl.c:658: warning: ISO C90 forbids mixed declarations and code

rlm_perl.c:700: warning: format '%d' expects type 'int', but argument 5 has type 'size_t'
rlm_perl.c:700: warning: format '%d' expects type 'int', but argument 5 has type 'size_t'
 gcc -O2 -I/opt/local/include -D_REENTRANT -D_POSIX_PTHREAD_SEMANTICS -DDARWIN -Wall -D_GNU_SOURCE -DNDEBUG -I/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_freeradius/work/freeradius-1.1.7/src/include -arch i386 -arch ppc -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -Wdeclaration-after-statement -I/usr/local/include -I/System/Library/Perl/5.8.8/darwin-thread-multi-2level/CORE -no-cpp-precomp -g -pipe -fno-common -DPERL_DARWIN -no-cpp-precomp -fno-strict-aliasing -Wdeclaration-after-statement -I/usr/local/include -c rlm_perl.c -o rlm_perl.o >/dev/null 2>&1
/opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_freeradius/work/freeradius-1.1.7/libtool --mode=link gcc -release 1.1.7 \
	-module -export-dynamic -L/opt/local/lib   -o rlm_perl.la     \
	-rpath /opt/local/lib rlm_perl.lo rlm_perl.c /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_freeradius/work/freeradius-1.1.7/src/lib/libradius.la \
	`perl -MExtUtils::Embed -e ldopts` -lresolv  -lpthread 

*** Warning: Linking the shared library rlm_perl.la against the
*** static library /System/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DynaLoader/DynaLoader.a is not portable!
gcc ${wl}-flat_namespace ${wl}-undefined ${wl}suppress -o .libs/rlm_perl-1.1.7.so -bundle  .libs/rlm_perl.o  -L/opt/local/lib /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_freeradius/work/freeradius-1.1.7/src/lib/.libs/libradius.dylib -L/usr/local/lib /System/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DynaLoader/DynaLoader.a -L/System/Library/Perl/5.8.8/darwin-thread-multi-2level/CORE -lperl -ldl -lm -lutil -lc -lresolv -lpthread -arch i386 -arch ppc
ld: warning in /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_sysutils_freeradius/work/freeradius-1.1.7/src/lib/.libs/libradius.dylib, file is not of required architecture
(cd .libs && rm -f rlm_perl.so && ln -s rlm_perl-1.1.7.so rlm_perl.so)
ar cru .libs/rlm_perl.a /System/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DynaLoader/DynaLoader.a  rlm_perl.o /System/Library/Perl/5.8.8/darwin-thread-multi-2level/auto/DynaLoader/DynaLoader.a
ranlib: archive member: .libs/rlm_perl.a(DynaLoader.a) fat file for cputype (18) cpusubtype (0) is not an object file (bad magic number)
ar: internal ranlib command failed
make[6]: *** [rlm_perl.la] Error 1
make[5]: *** [common] Error 2
make[4]: *** [all] Error 2
make[3]: *** [common] Error 2
make[2]: *** [all] Error 2
make[1]: *** [common] Error 2
make: *** [all] Error 2

Error: Status 1 encountered during processing.

Change History (13)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Cc: jmr@… added

Did you ask for the universal variant? If not, it shouldn't be building universal, which is a bug in itself. It's also linking against the system perl, which ports should not do. Maybe freeradius should have a perl dependency? What happens if you install perl with MacPorts before trying to build freeradius?

comment:2 Changed 13 years ago by jmroot (Joshua Root)

Milestone: Port Bugs

Joel (the reporter) indicated via private mail that he did not use +universal, and that he has the perl5.8 port installed.

comment:3 Changed 13 years ago by markd@…

Resolution: fixed
Status: newclosed

The port has been updated to 2.0.4 and works for me on 10.5.2.

comment:4 Changed 13 years ago by blb@…

Cc: richard@… added
Resolution: fixed
Status: closedreopened

Cc'ing reporter of duplicate ticket #15965.

comment:5 Changed 13 years ago by blb@…

I've reopened this because of ticket #15965; also I can reproduce this with 1.6 but seems to build fine with trunk. Perhaps the issue has been fixed there, just not migrated to release 1.6?

comment:6 Changed 12 years ago by jmroot (Joshua Root)

Description: modified (diff)
Keywords: freeradius removed
Port: freeradius added

comment:7 Changed 12 years ago by markd@…

It builds fine for me on 10.5.4 intel with 1.6. Also I upgraded the port to 2.1.3 and it still builds fine.

comment:8 in reply to:  7 Changed 12 years ago by icebeing_cm@…

Replying to markd@…:

It builds fine for me on 10.5.4 intel with 1.6. Also I upgraded the port to 2.1.3 and it still builds fine.

Doesn't work for me, and I'm running 10.5.6 Intel

I did the following, according to the freeradius.org web page:

./configure --enable-developer make

and then I get that weird message again.

Can you add some detail on what you did that allowed this compile?

Thanks, charles.

comment:9 in reply to:  7 Changed 12 years ago by icebeing_cm@…

Replying to markd@…:

It builds fine for me on 10.5.4 intel with 1.6. Also I upgraded the port to 2.1.3 and it still builds fine.

I just did a fresh install of 10.5.4 Leopard Server and 2.1.3 and it does NOT build fine. Same error as originally stated.

/cm

comment:10 Changed 12 years ago by jmroot (Joshua Root)

MacPorts version? Xcode version?

comment:11 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

comment:12 Changed 12 years ago by ryandesign (Ryan Schmidt)

Cc: icebeing_cm@… ryandesign@… added

I have recently updated the port to 2.1.6 and fixed some other build issues. Can you please check if you are still seeing the problem now, after a "sudo port sync"?

comment:13 Changed 11 years ago by jmroot (Joshua Root)

Cc: jmr@… removed
Resolution: fixed
Status: reopenedclosed

No response, assuming fixed.

Note: See TracTickets for help on using tickets.