Opened 13 years ago

Closed 13 years ago

#13669 closed defect (duplicate)

mplayer dmg build fails while mplayer build succeeds

Reported by: liontooth@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.6.0
Keywords: mplayer dmg Cc: openmaintainer@…
Port:

Description (last modified by jmpp@…)

I just built mplayer successfully (yay!) and then tried to build a dmg package using the same variant choices:

# port clean mplayer
--->  Cleaning MPlayer
root@dcl03:~# port mdmg mplayer +fontconfig +freetype +gif +theora +xvid +x264 +real +binary-codecs +speex +faac +dv +twolame +dts +sdl +aa +caca
--->  Creating pkg for MPlayer-1.0rc2
Error: Target org.macports.pkg returned: shell command "PMResourceLocale=English /Developer/Applications/Utilities/PackageMaker.app/Contents/MacOS/PackageMaker -AppleLanguages "(English)" --root /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/destroot --out /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/MPlayer-1.0rc2.pkg  --resources /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/pkg_resources --title "MPlayer-1.0rc2" --info /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/Info.plist --target 10.3 --domain system --id org.macports.MPlayer" returned error 1
Command output: Warning: Unknown argument: -AppleLanguages
Warning: Unknown argument: (English)
ERROR: The specified root is invalid: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/destroot

Error: Status 1 encountered during processing.

Change History (6)

comment:1 Changed 13 years ago by afb@…

Does the "destroot" directory actually exist ? If not, could it be the known issue #10881 ?

comment:2 Changed 13 years ago by liontooth@…

Yes, it looks like this is the problem. I issued,

mkdir /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/MPlayer-1.0rc2.pkg

and then used the temporary fix suggested in #10881, "when doing mpkg use the -k flag and it will leave the destroot contents," and the building started. However, only some packages create the destroot directory:

jpeg-6b.pkg
libiconv-1.12.pkg
libpng-1.2.24.pkg
libungif-4.1.4.pkg
ncursesw-5.6.pkg

Others don't and generate an error similar to the above:

lame-3.97.pkg
libmad-0.15.1b.pkg
libogg-1.1.3.pkg
libvorbis-1.2.0.pkg
lzo2-2.02.pkg
ncurses-5.6.pkg
pkgconfig-0.22.pkg
zlib-1.2.3.pkg

Perhaps someone sees a pattern here?

If I create all of the missing directories in the destroot, the build process nearly completes, but bugs out at the end -- likely just a result of previous failed builds:

DEBUG: Executing org.macports.mdmg (MPlayer)
--->  Creating disk image for MPlayer-1.0rc2
Error: Target org.macports.mdmg returned: shell command "hdiutil create -quiet -fs HFS+ -volname MPlayer-1.0rc2 -size 8702b /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/MPlayer-1.0rc2.tmp.dmg" returned error 1
Command output: 
Warning: the following items did not execute (for MPlayer): org.macports.mdmg<br>
Error: Status 1 encountered during processing.

If I run the last command without -quiet,

hdiutil create -fs HFS+ -volname MPlayer-1.0rc2 -size 8702b /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/MPlayer-1.0rc2.tmp.dmg hdiutil: create failed - File exists

Remove the file:

rm /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/MPlayer-1.0rc2.tmp.dmg

hdiutil create -fs HFS+ -volname MPlayer-1.0rc2 -size 8702b /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/MPlayer-1.0rc2.tmp.dmg ............................................................................................................................................................ created: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_multimedia_MPlayer/work/MPlayer-1.0rc2.tmp.dmg

# ls -l

-rw-r--r--@ 1 root staff 4455424 Dec 21 11:09 MPlayer-1.0rc2.tmp.dmg

So this works, but several portfiles don't create their own directories as they should in a package creation context.

Cheers, Dave

comment:3 Changed 13 years ago by liontooth@…

BTW we should reassign this ticket; it's not an mplayer bug. Aside from duplicating #10881, there's something wrong in the portfiles for lame, libmad, libogg, libvorbis, lzo, ncurses, pkgconfig, and zlib that makes them fail to function as dependencies in package builds. Likely easy to fix if someone can spot the error.

comment:4 Changed 13 years ago by jmpp@…

Description: modified (diff)

Please read WikiFormatting to learn how to properly paste terminal output: you should use the {{{ }}} pre-formatted text macro, thanks!

-jmpp

comment:5 Changed 13 years ago by ecronin (Eric Cronin)

Cc: ecronin@… removed

comment:6 Changed 13 years ago by jmpp@…

Component: portsbase
Milestone: Port Bugs
Resolution: duplicate
Status: newclosed

Closing as duplicate of #10881. Individual tickets should be opened for whatever other problems that are being reported here, thanks!

-jmpp

Note: See TracTickets for help on using tickets.