Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#13823 closed defect (invalid)

ncursesw 5.6 activation failure - file exists but is unregistered

Reported by: kilroy@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: ncursesw image Cc: kilroy@…, imajes@…
Port:

Description

Building ncursesw succeeds, but activation fails (thus breaking ports that depend on it) with a complaint about the file /opt/local/bin/captoinfo:

--->  Fetching ncursesw
--->  Verifying checksum(s) for ncursesw
--->  Extracting ncursesw
--->  Applying patches to ncursesw
--->  Configuring ncursesw
--->  Building ncursesw with target all
--->  Staging ncursesw into destroot
--->  Installing ncursesw 5.6_0+darwin_8
--->  Activating ncursesw 5.6_0+darwin_8
Error: Target org.macports.activate returned: Image error: /opt/local/bin/captoinfo already exists and does not belong to a registered port.  Unable to activate port ncursesw.
Error: Status 1 encountered during processing.

Change History (3)

comment:1 Changed 13 years ago by vinc17@…

Resolution: invalid
Status: newclosed

Such kind of error is not a bug in the port (if the filename starts with /opt/local except /opt/local/etc). You just need to remove /opt/local/bin/captoinfo that was installed by some broken software (ncursesw is not responsible for that).

comment:2 Changed 13 years ago by jmpp@…

Priority: HighNormal

comment:3 Changed 11 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.