Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#13895 closed defect (duplicate)

XFree86 build failure

Reported by: probono@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: XFree86 Cc: yves@…
Port: XFree86

Description

On Leopard, port build XFree86 fails with this error; ../../lib/xtrans/Xtranssock.c:1378: error: 'MAXHOSTNAMELEN' undeclared here (not in a function) The patch from http://www.mail-archive.com/debian-x@lists.debian.org/msg37916.html fixes that.

Afterwards, it fails with: mv -f libOSMesa.4.0.dylib~ libOSMesa.4.0.dylib mv: rename libOSMesa.4.0.dylib~ to libOSMesa.4.0.dylib: No such file or directory make[5]: * [libOSMesa.4.0.dylib] Error 1 make[4]: * [all] Error 1

Change History (7)

comment:1 Changed 13 years ago by jmroot (Joshua Root)

Why do you need XFree86 on Leopard anyway? Generally, Apple's X11 or the xorg port will do the job quite nicely.

comment:2 in reply to:  1 Changed 13 years ago by probono@…

Replying to jmr@macports.org:

Why do you need XFree86 on Leopard anyway? Generally, Apple's X11 or the xorg port will do the job quite nicely.

I do not use Aqua, Quartz or any other proprietary parts of Leopard. I am interested in a "pure" Darwin solution.

comment:3 Changed 13 years ago by yves@…

But Leopard is NOT Darwin. So before putting efforts on building XFree86 on Leopard, why don't you try to build it on Darwin ?

comment:4 Changed 13 years ago by probono@…

What I am currently doing is to build the components of Darwin 9 on a Leopard Mac, since Darwin 9 is apparently not yet fully self-hosted. I was hoping that I could build XFree86 on Leopard too, and run the resulting binaries on a Darwin 9 system. That being said, *any* workable solution that gives me XFree86 or X.Org binaries that are usable on Darwin 9 is greatly appreciated.

comment:5 Changed 13 years ago by yves@…

The only usable X binaries for Darwin have to be built on Darwin. Darwin 8 binaries might work on Darwin 9 the only way to know for sure is to try.

If you go for XFree86, the developers are very helpful. I guess bbuyer must be too with X.org.

comment:6 Changed 12 years ago by jmroot (Joshua Root)

Port: XFree86 added
Resolution: duplicate
Status: newclosed

Marking as a duplicate of #16697, since that ticket has a patch.

comment:7 Changed 12 years ago by (none)

Milestone: Port Bugs

Milestone Port Bugs deleted

Note: See TracTickets for help on using tickets.