Opened 15 years ago

Closed 15 years ago

Last modified 13 years ago

#14437 closed defect (duplicate)

port dmg ghostscript: ERROR: The specified root is invalid

Reported by: rick.richardson@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: base Version: 1.6.0
Keywords: Cc:
Port:

Description

$ sudo port install ghostscript Skipping org.macports.activate (ghostscript ) since this port is already active ---> Cleaning ghostscript

$ sudo port dmg ghostscript ---> Creating pkg for ghostscript-8.61 Error: Target org.macports.pkg returned: shell command "PMResourceLocale=English /Developer/Applications/Utilities/PackageMaker.app/Contents/MacOS/PackageMaker -AppleLanguages "(English)" --root /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_ghostscript/work/destroot --out /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_ghostscript/work/ghostscript-8.61.pkg --resources /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_ghostscript/work/pkg_resources --title "ghostscript-8.61" --info /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_ghostscript/work/Info.plist --target 10.3 --domain system --id org.macports.ghostscript" returned error 1 Command output: Warning: Unknown argument: -AppleLanguages Warning: Unknown argument: (English) ERROR: The specified root is invalid: /opt/local/var/macports/build/_opt_local_var_macports_sources_rsync.macports.org_release_ports_print_ghostscript/work/destroot

Error: Status 1 encountered during processing.

Change History (5)

comment:1 Changed 15 years ago by ryandesign (Ryan Schmidt)

Component: portsbase
Milestone: MacPorts base bugs
Priority: HighNormal
Resolution: duplicate
Status: newclosed

Duplicate of #10881.

comment:2 Changed 15 years ago by rick.richardson@…

Resolution: duplicate
Status: closedreopened

This is OPEN. No fix is provided.

comment:3 Changed 15 years ago by afb@…

Resolution: duplicate
Status: reopenedclosed

There are two workarounds in the ticket above:

  • port -f destroot ghostscript, to make the root "valid"
  • disable autoclean for future installs to be packageable

But the issue is nothing specific to ghostscript.

comment:4 Changed 14 years ago by tobypeterson

Milestone: MacPorts base bugsMacPorts Future

Milestone MacPorts base bugs deleted

comment:5 Changed 13 years ago by jmroot (Joshua Root)

Milestone: MacPorts Future
Note: See TracTickets for help on using tickets.