Opened 13 years ago

Closed 13 years ago

#14489 closed defect (duplicate)

macports installation problem

Reported by: sica@… Owned by: macports-tickets@…
Priority: Normal Milestone:
Component: ports Version: 1.6.0
Keywords: Cc:
Port:

Description

I recently upgraded to leopard. I installed X11 and the X11 Xcode v3.0. I installed macports and it said it was successful. /opt/local exists, as does ./bin, which has the port executable in it. However it won't run, even if I sudo in the subdirectory I still get "command" not found. Also man port doesn't work (No manual entry for port). This looks like a "rehash" problem (?) but I don't know how to do that in Darwin. I checked, the only .bash file in my home directory is .bash_history. There is a .profile but all that is in it is pman() { man -t "${1}" | open -f -a /Applications/Preview.app/ }

This is a single user MacBook with all the latest Leopard updates on it.

Please help, if I can get you any more information let me know. I'm trying to install this so I can easily install the new version of Gimp.

Bob Sica

Change History (1)

comment:1 Changed 13 years ago by raimue (Rainer Müller)

Resolution: duplicate
Status: newclosed

There is a known bug in the installer for Leopard. Please either see http://guide.macports.org/#installing.shell how to setup it manually, or run this command:

curl -O http://svn.macports.org/repository/macports/branches/release_1_6/base/portmgr/dmg/postflight && chmod +x postflight && ./postflight

Duplicate of #13742.

Note: See TracTickets for help on using tickets.